Redefining command keys on MacBook

Hello Friends,

I have tried to redefine the keyboard layout today in a new Manjaro installation on a MacBook Pro. It seems like literally every setting in the operation system stating "German MacBook Layout" was fully ignored. It took me several hours to just swap the y and the z. But by now, I have managed that nearly every key is correctly matched, except the crucial five ones:
ctrl, alt, cmd on the left side and
cmd, alt on the right side

As of the fact that these are not working, I cannot for example build the [at] sign, because that needs alt and L.

I am not one hundre percent sure how I really solved the problem with the other keys after trying heaps of articles and commands, but I guess, the most relevant thing was to change the content of the /usr/share/X11/xkb/symbols/de file where I changed several keys with help of somebody else.
(something like that:

So my question is:
Is it possible to match the five control keys in that file as well such that this applies for the entire operation system?
I just don't know what key numbers (like key ) they have and what to write in these lines.

What I want is the following:
both cmd keys (on left and the right side) should do what the ctrl key does at the moment (f.eks. cmd + c for copying).
Both alt keys (left and right) should do the same, enabling me to get the third character behind a key (like alt + L becoming [at])
and last, the ctrl button should do the rest, like stopping something in the terminal with ctrl + c. Cannot really describe it.

Is there somebody who had the same issues? How can I solve that?

Thanks in advance!

Start with

$ inxi -Fxxxz


welcome-03-sgs :slight_smile:

Thanks for your answer. I guess that means I should provide more information from that command, which I will do now:

System:    Host: Linux-PC Kernel: 4.19.66-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           Desktop: Deepin 15.8 tk: Qt 5.13.0 info: dde-dock wm: DeepinWM dm: LightDM 1.30.0 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookPro12,1 v: 1.0 serial: <filter> Chassis: 
           type: 9 v: Mac-E43C1C25D4880AD6 serial: <filter> 
           Mobo: Apple model: Mac-xxx v: MacBookPro12,1 serial: <filter> UEFI: Apple 
           v: date: 06/14/2019 
Battery:   ID-1: BAT0 charge: 61.9 Wh condition: 70.2/74.8 Wh (94%) volts: 12.3/11.4 
           model: DP bq20z451 type: Li-ion serial: N/A status: Discharging cycles: 445 
CPU:       Topology: Dual Core model: Intel Core i7-5557U bits: 64 type: MT MCP arch: Broadwell 
           rev: 4 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 24806 
           Speed: 901 MHz min/max: 500/3400 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
Graphics:  Device-1: Intel Iris Graphics 6100 vendor: Apple driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:162b 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
           alternate: fbdev,vesa resolution: 2560x1600~60Hz 
           OpenGL: renderer: Mesa DRI Intel Iris 6100 (Broadwell GT3) v: 4.5 Mesa 19.1.4 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Apple driver: snd_hda_intel v: kernel 
           bus ID: 00:03.0 chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Device-3: Broadcom and subsidiaries 720p FaceTime HD Camera driver: bdc-pci 
           bus ID: 02:00.0 chip ID: 14e4:1570 
           Sound Server: ALSA v: k4.19.66-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM43602 802.11ac Wireless LAN SoC vendor: Apple 
           driver: brcmfmac v: kernel port: efa0 bus ID: 03:00.0 chip ID: 14e4:43ba 
           IF: wlp3s0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 8.56 GiB (0.5%) 
           ID-1: /dev/sda vendor: Apple model: SSD SM1024G size: 931.84 GiB speed: 6.0 Gb/s 
           serial: <filter> rev: SA0Q scheme: GPT 
           ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2 size: 931.48 GiB 
           serial: <filter> rev: 1004 scheme: GPT 
Partition: ID-1: / size: 93.45 GiB used: 8.56 GiB (9.2%) fs: btrfs dev: /dev/sdb4 
           ID-2: /home size: 93.45 GiB used: 8.56 GiB (9.2%) fs: btrfs dev: /dev/sdb4 
Sensors:   System Temperatures: cpu: 52.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 193 Uptime: 2m Memory: 15.57 GiB used: 466.3 MiB (2.9%) Init: systemd v: 242 
           Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 running in: deepin-terminal inxi: 3.0.35

Do you have this parameters in the file /etc/default/keyboard



or is something else?

Also is important to know if the layout is qwerty, qwertz, azerty, dvorak or ... so maybe you need to use something like:

1 Like

Good morning.
The data in that file have been:



So backspace and xkblayout where like your example (just with German German instead of Swiss German). I am not quite sure about the differences between mac and de_mac and macbook78 and macintosh, but I changed both nevertheless. I also added the options file, such that the entire file was like your example. After a restart, nothing changed. So the keyboard is still German like in the entry post, but none of the five controlling keys was doing what it is supposed to be, unfortunately.
Thanks for reminding me of talking about my layout, I am writing on QWERTZ. My system language is en_NZ, if this makes any difference.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by