Redshift not working on XFCE Raspberry Pi 4

I have installed redshift on Manjaro ARM with XFCE for the Raspberry Pi 4, but it does not change
the screen colour. The taskbar icon starts normally, but to test I changed both the day and night colour to 2000K in /home/nifrec/.config/redshift/redshift.conf, and the info menu correctly displays 2000K, but the screen colour does not change at all.

I have tried the following:
I added

[redshift]
allowed=true
system=false
users=

to /etc/geoclue/geoclue.conf.
I ran both systemctl --user restart redshift-gtk.service and
systemctl --user restart redshift.service, but neither changed the screen colour.

Does anyone know how to solve this (or know a working alternative to redshift)?

Output of redshift -v:

[nifrec@pilium redshift]$ redshift -v
Trying location provider `geoclue2'...
Using provider `geoclue2'.
Solar elevations: day above 3.0, night below -6.0
Temperatures: 2000K at day, 2000K at night
Brightness: 1.00:1.00
Gamma (Daytime): 1.000, 1.000, 1.000
Gamma (Night): 1.000, 1.000, 1.000
Using method `randr'.
Waiting for initial location to become available...
Location: 51.53 N, 4.47 E
Colour temperature: 6500K
Brightness: 1.00
Status: Enabled
Period: Daytime
Colour temperature: 2000K

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by