Regularly can't load forum

I face this issue quite often. In Firefox, when I hit the url archived.forum.manjaro.org, I get this error. But, when I do ctrl+F5, the page loads fine.

possibly related thread

@jonathon this is getting worse i get the "can't open app" and the Manjaro forum will not load till i open another book mark then it opens fine for a few hours then the same again.

I still haven't noticed anything.

The total number of requests has risen over the last few months so I'll look into this server-side:

total-requests

If this is a resource/rate limiting thing I may not have noticed because I'm an admin and Discourse wants to keep my account/session/etc. active.

that graph is starting to resemble manjaro :slight_smile:

anyhow, is it a potential DNS resolution issue specific to the affected users as the number of comments about this seems too low for it to be a major issue with the server load handling aspect.

I use quad9 for primary DNS and connectsafe for secondary because my own ISP's DNS servers are about as much use as a chocolate fireguard and if used the browser regularly state pages are inaccessible or such cause partial loading errors.

try disabling e10s. ...not that that's a great long-term solution, but hopefully that'll lead discourse down the right path to fix it if it works for you too.

If this is "fixed" by a clean browser profile (or running in -safe-mode) then it's not a forum issue.

I continue to have this problem when I use Firefox Safe Mode.

When I open the Manjaro forums in a tab, load another site in the same tab, and then return to the Manjaro forums in the same tab (with Alt+Left), I see the error.

Also, when I close and reopen Firefox (which I have configured to save all my open tabs), I see the error on the page containing the Manjaro forums.

Also, when I close the tab containing the Manjaro forums and then select the Undo Close Tab option, I see the error.

Reloading the page always corrects the error.

Edit to add these observations:

I do not have this problem when I type the URL of the Manjaro forums in the Firefox address box myself. Rather, I have to perform one of the actions mentioned above which, apparently, fail to reinitialize the state of the forum page I had been viewing.

I have this problem in Firefox, in both Windows and Linux.

I do not have this problem in Opera or Vivaldi.

I also have this problem on other Discourse forums, not just on the Manjaro forums. For example, it happens on Discourse's own forums.

This problem is being discussed here:

The Discourse co-founder, Sam Saffron, claims the problem lies with Adblock Plus. However, the problem also happens in Firefox Safe Mode, with all add-ons disabled, so Adblock Plus cannot be the sole cause of the problem.

1 Like

Well, I'm happy I started this post possibly rekindling the interest to the already known problem. I'm still having problems, some days more failing to load the forum than succeding to load it. There is not much more than I can add, other than that the failing occurs on both my OSs, so on different firefoxs, and on different internet connections, at home like at school.

And a clean browser profile?

Starting Firefox with a clean browser profile does indeed correct the problem:

firefox --profile ~/.mozilla/firefox/temp_profile --no-remote

However, without the clean profile, clearing the browser cache and the forum cookies is not enough to correct the problem.

The other question is why only Manjaro no other forum acts this way Void uses discourse no problem their so this site is not closing cleanly for some users or something

The problem doesn't happen on Void:

https://forum.voidlinux.eu/

However, it does happen on Discourse:

I have discovered a solution to this problem that does not require that you create a new Firefox profile. It turns out that you need to delete the local storage used by the Discourse app. Here's how to do it safely:

  1. In Firefox, close any tab displaying the Manjaro forums.
  2. Open Preferences from the Firefox main menu.
  3. Select the Privacy & Security tab.
  4. Under Site Data, click Settings....
  5. Select archived.forum.manjaro.org from the list of sites.
  6. Click Remove Selected.
  7. Click Save Changes.
  8. On the Removing Site Data dialog, click Remove, which acknowledges that cookies for the site will be removed in addition to other site data.
  9. Open the Manjaro forums.
  10. Since cookies were deleted, you'll need to log in again.

The Manjaro forums should now behave normally.

5 Likes

Well, about a day later, the problem returned. However, after again deleting site data as I described above, the problem went away. So deleting site data corrects the problem, but it does not result in a permanent fix.

I don't know yet whether creating a new Firefox profile results in a permanent fix.

1 Like

I am with this problem too, even in safe-mode

1 Like

So you're saying that clearing the site data or using a clean browser profile doesn't work? Or that you haven't tried that?

1 Like

If I started with this command I get this:

Your Firefox profile cannot be loaded. It may be missing or inaccessible

I tried "clearing the site data or using a clean browser profile" and didn't worked. I will stay with this problem. I think it is because I keep many tabs fixed and many others tabs open to open with the browser on initialization. And another thing is that I use "preload"

First, create this empty folder:

~/.mozilla/firefox/temp_profile

Then run this command:

firefox --profile ~/.mozilla/firefox/temp_profile --no-remote --new-instance

Firefox should open a new instance with a new profile (even if an instance with your old profile remains open). My experience is that the new instance will not have the problems described in this thread. I have not tested long enough (and with my usual add-ons installed) to determine that a new profile results in a permanent fix.

The other solution, clearing site data, also works for me. I have tried it in Firefox on two computers, and the problems resolved immediately. In one case, though, the problems returned about a day later. However, once again clearing site data resolved the problems immediately, and they haven't returned since then.

Forum kindly sponsored by