Regularly can't load forum

I have discovered a solution to this problem that does not require that you create a new Firefox profile. It turns out that you need to delete the local storage used by the Discourse app. Here's how to do it safely:

  1. In Firefox, close any tab displaying the Manjaro forums.
  2. Open Preferences from the Firefox main menu.
  3. Select the Privacy & Security tab.
  4. Under Site Data, click Settings....
  5. Select archived.forum.manjaro.org from the list of sites.
  6. Click Remove Selected.
  7. Click Save Changes.
  8. On the Removing Site Data dialog, click Remove, which acknowledges that cookies for the site will be removed in addition to other site data.
  9. Open the Manjaro forums.
  10. Since cookies were deleted, you'll need to log in again.

The Manjaro forums should now behave normally.

5 Likes

Well, about a day later, the problem returned. However, after again deleting site data as I described above, the problem went away. So deleting site data corrects the problem, but it does not result in a permanent fix.

I don't know yet whether creating a new Firefox profile results in a permanent fix.

1 Like

I am with this problem too, even in safe-mode

1 Like

So you're saying that clearing the site data or using a clean browser profile doesn't work? Or that you haven't tried that?

1 Like

If I started with this command I get this:

Your Firefox profile cannot be loaded. It may be missing or inaccessible

I tried "clearing the site data or using a clean browser profile" and didn't worked. I will stay with this problem. I think it is because I keep many tabs fixed and many others tabs open to open with the browser on initialization. And another thing is that I use "preload"

First, create this empty folder:

~/.mozilla/firefox/temp_profile

Then run this command:

firefox --profile ~/.mozilla/firefox/temp_profile --no-remote --new-instance

Firefox should open a new instance with a new profile (even if an instance with your old profile remains open). My experience is that the new instance will not have the problems described in this thread. I have not tested long enough (and with my usual add-ons installed) to determine that a new profile results in a permanent fix.

The other solution, clearing site data, also works for me. I have tried it in Firefox on two computers, and the problems resolved immediately. In one case, though, the problems returned about a day later. However, once again clearing site data resolved the problems immediately, and they haven't returned since then.

As a slightly more streamlined option,

firefox -P -new-instance

will allow you to create (and switch to) a new profile.

A post was split to a new topic: "WARNING: pipe error: Broken pipe" from Firefox

I tried creating a new profile and running a new instance of firefox with firefox --profile ~/.mozilla/firefox/temp_profile --no-remote --new-instance and I can confirm that the forum loads properly.

1 Like

I created a new Firefox profile a few days ago for testing the Manjaro forums, while I continue my regular work in a separate instance of Firefox with my original Firefox profile. (See my post above for how to run two Firefox instances at once with separate profiles.) For about a day now I've been using the new Firefox profile exclusively while I access the Manjaro forums.

All was well for several hours, but a few minutes ago the instance of Firefox with the new profile failed with the familiar "Cannot load app" message. As usual when this error message appears, I had loaded a new site in the tab displaying the Manjaro forums and then returned to the Manjaro forums by clicking the browser's "Back" button (or typing Alt+Left).

At the moment that the Manjaro forums failed, my new Firefox profile was running only one add-on: New Tab Override. I'll be testing further with another new profile, with this add-on disabled.

As far as I know, both of the solutions proposed in this thread (creating a new profile and deleting site data) have similar, impermanent results, because they both do the same thing: clear, temporarily, the local storage used by the Discourse app.

1 Like

I don't know if this new, but I get the forum to load 100% of the time if I hit CTRL+ F5 when it gets stuck. F5 and CTRL + R don't work though.

I used to have some really bad issues with this Forum in the past, which may have been a different issue, than your's is presently.
But so far, (knock-on-wood) I've had no problems with the Forum loading times here with Firefox, or Chromium, with just defaults, no fancy profiles.

...and of course, just because I said it, now it'll happen to me too. :wink:

1 Like

Funny. This one page/thread wont load
Google Analytics blank page Chromium & Firefox
With the "Cannot load app" error.

Still can't replicate this.

Does the page load if you press F5?

Here's an update on my experience with the problem.

The problem only occurs after I leave the Manjaro forums by loading another domain in the same Firefox tab and than back-page in the same tab to the Manjaro forums. (The problem also occurs when I start up Firefox with the Manjaro forums in a saved tab).

Pressing F5 always loads the page, but as soon as I leave the domain and then return, the problem always occurs again immediately.

When I create a new Firefox profile, the problem does not recur immediately, but it always returns eventually. It returns even if I have not installed any add-ons in the new profile. So, in my experience with this problem, it has nothing at all to do with add-ons.

Clearing site data (see my instructions in my earlier post) works as well as (and is easier than) creating a new Firefox profile. The problem does not recur immediately, but it always returns eventually (and no sooner than it does with a new profile).

So I recommend clearing site data. The forums should then be trouble-free for at least a while.

By the way, I have used Firefox Web Developer Tools to monitor network traffic and the values of variables in local storage. I don't see any anomalous behavior with the forums, even when the error occurs.

However, I did find it interesting that, after clearing site data, the app does not begin to use local storage again immediately. Eventually, it does begin to use local storage, but until then, the forums behave normally. Oddly, the problem doesn't always recur immediately upon the initialization of local storage, but it can take a few hours longer.

1 Like

My issue was only for that one thread .. but it was fixed after clearing cache/data.

Recently, I've been seeing this message in place of the "Cannot load app" message I used to see:

Corrupted Content Error

The site at https://archived.forum.manjaro.org/latest has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

Please contact the website owners to inform them of this problem.

Whatever the message, it looks like Mozilla may have fixed the problem:

If so, we should see the fix when Firefox 60 ships on May 9.

2 Likes

same problem here

8 posts were split to a new topic: Weird third-party script loading in Firefox

Forum kindly sponsored by