Remove Manjaro, Install windows 7, Add Manjaro as dual Boot

Yes, the 'media creation tool' is an official microsoft program for dealing with windows 10 install/upgrade. If your OS activates after the install your good to go, at some point they may stop it, but its worth a shot if your doing a clean install. The win 10 license key is then linked to your motherboard so you can't activate on another computer (unless you updated from a retail version of win 7 rather than the more common OEM that came with the purchase of a computer).

When visiting Microsoft with a Win 7 computer you get served a 'Win 10 creation tool'. But if visit with a Linux machine, you get served a unique download link to an ISO (5 Gb) that caters for a good old offline installation. Sounds like OP has the latter.

I did that, it said there was nothing to do so i applied transaction and my machine froze again

'Nothing to do' means that your machine is up-to-date and you can attempt again with woeusb. Having said that, I have no experience with woeusb myself.

Transaction successfully finished.

so now it is ready to use? i looked in add or remove programs and it is listed.

I notice that you have updated older posts after that I have given replies. So now I am a bit lost on where you are...
By the sounds of it, your Manjaro install is up to date?
You have managed to install woeusb?

sorry my friend haha being a little impatient on this end! I have now just opened woeusb and will try and create the boot drive! thank you all for your help!!

i will install and then try to upgrade

Use Manjaro to create a free partition (ntfs) on your storage drive before installing Windows. Also, as someone said before, Windows might wipe your Linux installation without even a single warning shot.

1 Like

ok so i created the windows USB drive with woeusb.

gparted wont let me create a new partition as im using the partition that i need to split. there is an option for using gparted live USB, but my USB has windows on it.

set boot menu to.......boot menu, USB drive, Manjaro etc

on restart; tries to launch USB (load failure, not supported), boot menu load (no USB drive listed in boot menu) , loads Manjaro.

I don't mind if windows wipes Manjaro as i'll just add it again afterwards, probably easier that way. i just need to get windows installed on my machine. (i have a minimal install of manjaro and practically zero files, which have been backed up)

any tips on why there is a failure? shall i use the chainlink process in GRUB? sorry guys or gals, these things are never simple in linux world eh.....really appreciate the help so far.

search -s root -f /EFI/Microsoft/Boot/BCD
chainloader /EFI/Microsoft/Boot/bootmgfw.efi
boot

something like this?

Actuallly it will fail to activate a straight clean install attempt, you have to do an in place upgrade from a successfully activated copy of Windows 7 for a Windows 10 activation code generation to go through in that manner. After you've done that annoyingly long winded step once you can then clean install to that machine if desired with no problems. I briefly outlined this in my post above.

ok i did a bit of research;

so i need to do ls in Grub, to list devices. it should be hd1 (USB drive) or hd1 part2 (something like that). hd0 should be where manjaro is located
the file i need is located in hd1/EFI/Boot/bootx64.efi (in the UEFI_NTFS (2nd) partition)
or hd1/bootmgr.efi in the windows (1st) partition

ive been looking at the grub 2 commands, tried to execute some but i don't know enough about this type of stuff to be doing what i'm doing. how can it take nearly 2 days to sort something like this.................i took the risk with Manjaro because i wasn't going to be doing anything complicated to the system. I know my limits, somehow i'm now trying to do something i know nothing about, that has turned out to be very complicated although its a a very simple thing in principle. HOW DO I WIPE manjaro....what a waste of time.

Sure, i implied that in my first post when i said i upgraded win 7 over the holidays.
It may still work.

If you are prepared to sacrifice your Manjaro installation in order to add it later (which is easy do to), you do not have to create any partitions or remove Manjaro now. The Windows installer will take care of that for you ;-).

Your problems still suggest to me that your USB creation is not working and that it has nothing to do with GRUB. You need to find a way to create a workable USB stick. Maybe there are options in woeusb that you need to set before burning the ISO image? Hey @dalto, where are you?

2 Likes

I agree with @TheApologist. You are going down the wrong path. Booting off a USB stick it entirely between the USB stick and your BIOS. It happens before grub or linux gets loaded. If you can't boot off the USB stick, either it isn't made correctly or there is something different you need to do with/in your BIOS.

2 Likes

What @dalto and @antikythera said were exactly what I was thinking.

If your PC has a Windows 7 Pro key on a sticker somewhere, you can try to use that with a Windows 10 Pro ISO with the accessibility trick and it should work. The good thing is you only have to do that trick once and the key will be a valid 10 and 7 key from there. A lot of the people suggesting 7 then 10 for the free update probably didn't realize or know that their 7 key would work directly with 10 and that doing an upgrade is unnecessary.

I'll also add that in my experiences a dual boot setup with only one drive should be done like:

  1. Install Windows

  2. Split the Windows partition into two so Linux has a partition to install to

  3. Install Linux

  4. Make sure the Linux partition has the boot flag set since the Windows bootloader doesn't normally add Linux entries and then double check that GRUB has the Windows entries and run "sudo update-grub" from Manjaro if GRUB doesn't.

Step 2 can be done from the Manjaro Live media and step 4 should be done the first boot after the Linux install.

The Windows installer is a horrible, horrible piece of software and just does its own thing...sometimes seemingly without reason. Best to just let it do its thing and install Linux afterwards. Doing it the other way can be a nightmare and I can tell y'all some horror stories from the times I've tried over the years.

EDIT: Did you format the USB drive to NTFS or FAT32 before using WoeUSB? If no, that might be why it isn't working.

Hey dudes, just wanted to thank you for your help and patience with this :slightly_smiling_face: had to leave it for a few days and sort some other things. i'm going to have another crack at this today.

20200126_105214
here's a shot of the error on start

20200126_105304
This is my bios screen? Doesn't look like a bios screen and there are not options to do anything other than load manjaro. This is why i was trying to go through GRUB as it was the only thing accessible pre-load .

Screenshot_efibootmgr
this is a screen of my bootmgr settings.

when i insert my usb drive when manjaro has loaded it mounts as a windows usb and another mount for UEFI_NTFS.

Does any of this help you with working out whats happening.
like you say it seems to be an error when actually trying to run the installer, my system initiates the process to run and install from the USB but it fails.
The load failure error message is 'unsupported' that's why i tried to chainload from GRUB as i assumed it was my system that didn't support the function, not the file being corrupt or inaccessible.

IS THIS SERIOUS??? lol......i mean what, i can actually use my windows 7 key to install 10? It makes sense if you can upgrade for free legally that you can also do it the way you suggest, but it just sounds so crazy......i mean....it's microsoft innit

this seems to be dependent on doing it with a windows installation. so it's not the same
method as using the accessibility update, which doesn't seem to be available now anyway, last time i can find that anyone was able to do so was in 2018 (unless you know otherwise). I'll try the media creation method once 7 is installed

image

There are no options or settings to change on woeusb, other than NTFS/FAT. Is there maybe a problem with the way the USB has been formatted that is somehow messing with the iso? i Thought woeusb re-formats the drive previous to burning?

I Have deleted the two partitions and re-formated the drive to NTFS will now try a fresh burn with woeusb

Forum kindly sponsored by