Requesting proper configuration for Virtualbox (Manjaro KDE)

I installed Manjaro KDE in Virtualbox so I can play with it during downtime while I'm at work. Unfortunately I can't seem to be able to get it to work properly. I think it's related to the emulated GPU or something like that. Anyone here who uses it with Virtualbox without the graphics corrupting every 5 minutes, constant crashing of Plasmashell, and weird refresh issues all over the place? I don't think it's worth it to discuss my settings, if you use it and it works properly for you, please tell me which settings you use within Virtualbox (ie if you use 3D acceleration or not, VMSVGA or something else, and so on) and within Plasma (compositor and plasma renderer settings). Thanks in advance.

Btw, the Manjaro Wiki says:
Tip: Graphics : 128MB , VBoxSVGA , Enable 3D Acceleration .
But for me these settings aren't working properly and I have all the issues I listed above, I had to select software rendering mode in Plasma Renderer and Xrender in Compositor to make it usable (but now it's pretty awfully slow).

Did you try disabling 3D acceleration as well?
Both VBoxSVGA and VMSVGA should work out of the box without configuration.

Since you asked for config: I use VMSVGA, a minimum of 64MB of VVRAM and no 3D accel, most of the other settings are the defaults from "Arch" preset.

It appears you have read the wiki page so the link is just for reference.

You do not mention your host system - not that it should matter (much) - but the host does influence the overall functionality of VirtualBox.

Besides doing the graphics configuration - did you also set the minimum requirements for the system

I am not a KDE user but your topic sparked me to test it in VirtualBox - using the recommend settings.

  • Host system virtual extensions enabled
~ >>> inxi -CGm
Memory:
  RAM: total: 31.26 GiB used: 2.03 GiB (6.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP 
  L2 cache: 6144 KiB 
  Speed: 1886 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Desktop v: 4.5 Mesa 19.2.2 
  • Manjaro Openbox linux54

  • Virtual machine
    • manjaro-kde-18.1.2-191028-linux53.iso
    • 2 CPU
    • 2G RAM
    • VBoxSVGA
    • 128M
    • 3D acceleration
    • 20G virtual disk
    • no swap

I am now running a YouTube playlist and the system does not break down on me.

20191030-111713_449x265_screenshot

EDIT
Loaded additional four (4) additional tabs in Firefox - cnn with a streaming video.

This can make minor stutters in the audio stream from youtube - but no breakage so far.

20191030-113701_1163x332_screenshot

But I reckon that is due to the missing swap and the low memory.

1 Like

Thank you, I will try to replicate your settings in a new install and see what happens.

Anyway the host system is a W10 machine with an 4core-8threads i7 4770 (4cores for the vm), 16Gb (4Gb for the VM), and a dedicated Nvidia Quadro card (k620). Have you installed the virtualbox guest additions from the built in virtual cd or from somewhere else (IE in the way it's explained in the wiki)?

Maybe the problem lies in how I installed the guest additions.

Remember to set the graphics before launching the ISO for the first time.

There is no need to install the guest additions as the necessary packages are installed my mhwd.

The only package which is problematic is when you set to VMSVGA install and then change to VBoxSVGA - this change requires manual intervention.


I can make the system break - not completely - but stutter and behave badly by overloading it with firefox multimedia tasks - but that is possible because I limited the system to 2G RAM and no swap.

When you install Manjaro in a VM the installer leaves it to the user to select if swap should be created and if it should use it for hibernation.

The default swapiness - when the system will try to use swap - happens quite fast as it defaults to a value of 60.

Your crashes may simply be system overload e.g. many tabs open in a browser and the system has nowhere to go for swapping out memory.

I would exclude an issue with memory overload, because the vm has plenty of free ram and I don't even browse on it, I mostly use it for messing around in the terminal, learn commands, and try new programs. I gave 40Gb to the vm and swap because I wanted to test hibernate under various conditions (ie encrypted home and so on, but I haven't gotten to it yet).

I will try to make a new one and install the driver from mhwd. I thought I had to install the guest additions from the cd in order to fully enable shared clipboard and so on. I'll let you know what happens. I am pretty sure it's related to the emulated gpu or some other video related config being messed up.

Check the VirtualBox HowTo - it explains what services needs enabled in the guest.

Ok then, I think I solved the graphical corruption and plasma crashes by reinstalling the guest additions (still used the built in CD instead of pacman though, wanted to try both methods but it seems to be working now) and restoring every other setting related to the compositor and plasma renderer to default. I also rebooted and re-applied all settings to Virtualbox itself. It seems to work better now, I wonder what caused the corruption to begin with.

Now I can resume playing with Manjaro instead of doing my job :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by