Resolution help needed systemd-backlight@backlight:acpi_video0.service loaded failed failed

I'm having trouble resolving a failed program during startup. I've read and tried some post that had fixes outlined on this forum but still haven't been able to fix my problem.

Here's the error message:

[michael@HP-X360 ~]$ systemctl list-units --failed

● systemd-backlight@backlight:acpi_video0.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video0

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.

1 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.
[michael@HP-X360 ~]$ systemctl status systemd-backlight@backlight:acpi_video0.service
● systemd-backlight@backlight:acpi_video0.service - Load/Save Screen Backlight Brightness of backlight:acpi_video0
Loaded: loaded (/usr/lib/systemd/system/systemd-backlight@.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Sun 2018-12-09 07:16:41 MST; 10min ago
Docs: man:systemd-backlight@.service(8)
Process: 771 ExecStart=/usr/lib/systemd/systemd-backlight load backlight:acpi_video0 (code=exited, status=1/FAILURE)
Main PID: 771 (code=exited, status=1/FAILURE)

Dec 09 07:16:41 HP-X360 systemd[1]: Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
Dec 09 07:16:41 HP-X360 systemd-backlight[771]: Failed to get backlight or LED device 'backlight:acpi_video0': No such device
Dec 09 07:16:41 HP-X360 systemd[1]: systemd-backlight@backlight:acpi_video0.service: Main process exited, code=exited, status=1/FAILURE
Dec 09 07:16:41 HP-X360 systemd[1]: systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-code'.
Dec 09 07:16:41 HP-X360 systemd[1]: Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.

Here's a copy of my grub:

GRUB_DEFAULT=saved
GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet  cryptdevice=UUID=5c12bc51-88a4-4187-bf1d-8ff5b8e2096b:luks-5c12bc51-88a4-4187-bf1d-8ff5b8e2096b root=/dev/mapper/luks-5c12bc51-88a4-4187-bf1d-8ff5b8e2096b resume=/dev/mapper/luks-5c12bc51-88a4-4187-bf1d-8ff5b8e2096b"
GRUB_CMDLINE_LINUX=""

If you want to enable the save default function, uncomment the following
 line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

 Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

 The resolution used on graphical terminal
note that you can use only modes which your graphic card supports via VBE
 you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

Uncomment if you want GRUB to pass to the Linux kernel the old parameter
 format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

 Uncomment and set to the desired menu colors.  Used by normal and wallpaper
modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

 Uncomment to get a beep at GRUB start
GRUB_INIT_TUNE="480 440 1"
GRUB_ENABLE_CRYPTODISK=y

And a copy of systemmd backlight service

SPDX-License-Identifier: LGPL-2.1+

 This file is part of systemd.
#
  systemd is free software; you can redistribute it and/or modify it
  under the terms of the GNU Lesser General Public License as published by
  the Free Software Foundation; either version 2.1 of the License, or
 (at your option) any later version.

[Unit]
Description=Load/Save Screen Backlight Brightness of %i
Documentation=man:systemd-backlight@.service(8)
DefaultDependencies=no
Conflicts=shutdown.target
After=systemd-remount-fs.service
Before=sysinit.target shutdown.target

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/usr/lib/systemd/systemd-backlight load %i
ExecStop=/usr/lib/systemd/systemd-backlight save %i
TimeoutSec=90s
StateDirectory=systemd/backlight

Any assistance with resolving this would be GREATLY appreciated.

1 Like

Your backlight device is not being detected. You probably need to pass the correct device via a kernel parameter. Pick one of:

acpi_backlight=video
acpi_backlight=vendor
acpi_backlight=native
acpi_backlight=none

then if it doesn't work try another.

https://wiki.archlinux.org/index.php/backlight#Kernel_command-line_options

2 Likes

I'm not the most technical person and read the link page but I'm not sure what to do. Could you please provide some further guidance on what I actually need to do? Thanks

No, there's a link on that page ("kernel parameters") which tells you what to do.

This has been covered numerous times and while I'd love to repeat myself for the 100th time it's not really beneficial to either of us. If you're "not technical" yet you're running Linux then learning how to find answers to your questions is a very good thing to do.

If you have a specific issue with the process or instructions then post back and I'll happily help with that.

Let me ask my question differently then as I read kernel parameters page and also went to /sys/class/backlight/ within this section I believe it states there should be a doc called backlight.rules. I don't see this doc. What is there is a folder called radeon_b10. I looked within this folder and I don't see anything defined a backlight.rules. And so I don't know what to do.

I can appreciate that you helped 100's of people with this but as more and more people use Linux I believe helping and educating is a better solution to the community rather than shutting them out. If I learn how to properly deal with this problem I can share my knowledge with others.

Thanks again for sharing your expertise as I am stuck regarding how to proceed.

When I also look with the folder /etc/udev/rules.d that file is also empty.

From https://wiki.archlinux.org/index.php/Kernel_parameters#GRUB

Try each of the options I gave above in turn. One of them will work correctly. Once you have found the one that works,

Is there someone in the Manjaro community that would be patient and willing to help me resolve this problem at a very basic level? I would really like to understand what to do and what I am doing from a simplistic standpoint. I have a basic understanding of how Linux/Manjaro works and need guidance from a beginner level as I am not an expert with this program in any way.

Thank you in advance for your help I really appreciate it.

1 Like

OK so let's try this step-by-step.


When you boot the system you will see a menu which lists the various boot options. The top one will say Manjaro.

When you can see the word Manjaro and it is coloured green, press the letter "e" on your keyboard once.

This will take you to a menu where you can edit the options used by the computer when it boots.

Find the line which starts with the word "linux" and use the arrow keys on your keyboard to move the cursor to the end of that line.

Once you have reached the end of that line, press the spacebar once to add a space, then type the letters

acpi_backlight=video

one at a time. Make sure you double-check the letters to make sure they are correct. If they are not correct, press the backspace key to remove the letters and type them again.

Once you are certain the letters have been typed correctly, press the F10 key on your keyboard once.

The operating system will now begin to boot and you can check the journal entries for see if the error persists. Apparently you're technical enough to know how to do that bit.

If the error persists, or you find you can no longer alter the backlight by pressing the backlight keys on your keyboard, then repeat the above steps but change the letters you add to line beginning "linux" to one of the other three options:

  • acpi_backlight=vendor
  • acpi_backlight=native
  • acpi_backlight=none

If one of these options works in the way you are hoping for, you can add this option permanently so you don't have to type it every time you boot.

One way to do this is to open a terminal application (for example, click on the Applications menu and look for a program called "Terminal").

Once you have opened a terminal application, type these letters:

sudo nano /etc/default/grub

Make sure the letters are correct. If they are not correct, use the backspace key to delete the letters and re-type them.

Now press the Enter key on your keyboard once. You will be asked to type your password to let you edit the file.

Type your password carefully. Make sure it is correct or you will get an "access denied" error and will have to try again.

Once you have typed your password, press the Enter key once.

The "nano" text editor will load and show you the content of the /etc/default/grub file.

Use the arrow keys on your keyboard to move the entry cursor down to the line which begins GRUB_CMDLINE_LINUX_DEFAULT.

Move the cursor to the end of that line and place it between the h and the " characters so you can add letters after the word "splash".

Press the spacebar key on your keyboard once to enter a space.

Then type the letters which match the working option you typed in when you booted the computer. As a reminder, that will be one of these options:

  • acpi_backlight=video
  • acpi_backlight=vendor
  • acpi_backlight=native
  • acpi_backlight=none

Make sure you check the letters you type to make sure they are correct. They must match the option exactly or they won't work. Make sure the line ends with a quotation mark ".

If you make a mistake, use the Backspace key to delete the letters, then re-type them.

Once you are happy that you have typed the letters correctly press the key combination (that is, press and hold the first key, then press and release the second key, then release the first key):

CTRL-O
CTRL-X

This will save the file (output to a file) and exit the nano editor.

You should now be back at the black terminal window.

Type the letters for this command:

sudo update-grub

and press the Enter key on your keyboard once.

You may have to enter your password again. If so, type your password, making sure you type it correctly. If you make a mistake you will get an "access denied" error and will have to try again. Press Enter to confirm the password.

If you have entered the command correctly GRUB will add the backlight option to its menu entry and it will be present for every boot in the future.

You can verify it works by rebooting your computer. Please use the "reboot" menu item rather than holding down the power button or using the reset button on the case (if there is one).


This took me twenty minutes to write.

Moved from #technical-issues-and-assistance to #newbies as OP wanted steps rather than pointers

8 Likes

Thank you for the fix!

Once I knew what to do I actually updated the Grub by using Kate and the update command in the terminal. I couldn't figure out how to do it your way as my system is a single boot that is encrypted and I couldn't figure out how to get to Grub.

With all the work you did taking 20 minutes I've cut and pasted the document then saved it. If I see anyone else needing the fix I'll just paste it in and share it, noting the author of course. You did a lot of work and I recommend saving the content, it might save you some time when the next neophyte shows up needing the same fix. :grinning:

Thank you!

Please don't do that. Just link to the post instead.

link-to-post

1 Like

@jonathon incredible post. Please make it a tutorial or better a #faq.
You are the Forum Hero!!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by