restarting openbox sends conky to ontop layer

Every time I restart openbox , conky comes above other windows . and I have to kill it from terminal .
I tried adding this lines to rc.xml , but it does nothing :

    <application name="*">
        <layer>above</layer>
    </application>
    <application name="conky">
        <layer>below</layer>
    </application>

Why this is happening and how can I fix thix?
p.s. conky added to openbox autostart using this method :

.
.
.
### launch conky
### manjaro-conky-session &
conky &
.
.
.

When you run conky from the command line it will create a default ~/.conkyrc unless you specify a conky using the -c argument.

Please don't be a help vampire.

Study the supplied conky files and read up on the conky configuration.

Use the Help and info menu entry to go directly to pages describing the various parts of Manjaro Openbox.

1 Like

I noticed the same behaviour, so I searched around the Conky configuration.

Regardless of the Conky you're using (I used the default PacBang.conkyrc), try to change these two settings in the .conkyrc file (in my case ~/.config/conky/PacBang.conkyrc):

own_window_type = 'desktop',

and

own_window_argb_visual = true,

Save the file and restart Openbox to see if this makes a difference.

1 Like

I know it is an issue if you run conky using the default file but the PacBang.conkyrc contains these settings - snippet

-- Window specifications #
	own_window = true,
	own_window_type = 'override',
	own_window_transparent = true,
	own_window_hints = 'undecorated,sticky,skip_taskbar,skip_pager,below',

Producing this - which is not a topmost window

20200315-144330_360x385_screenshot

Which leads me to think - compositor?

Under some circumstances you may not be able to start the picom compositor. I vaguely remember the compositor didn't run using VMSVGA in VBox - but it didn't affect the conky drawing.

Other possible attempts to troubleshoot - graphics driver - wrong config - I don't know.

1 Like

What happens if you restart Openbox in place (I'm referring to Right click Menu > Preferences > Restart Openbox) and then maximize a window?

Isn't the Conky shown on top of the maximized window?

This was the issue in my case and I think this is what the OP is referring to.

1 Like

Doing this I can reproduce it - I know of this - but it is due to the window manager being restarted - a window manager restart does not reload the autorun which will take conky out of sync with the window manager.

Just reload conky - using the menu or the terminal

manjaro-conky-session &

Only on rare occations is is needed to restart openbox - making changes to menu.xml and rc.xml only requires reconfiguration.

If you use the own_window_type = 'desktop' you will get screen artifacts and a distorted conky.

2 Likes

I am open to suggestions which may improve the conky - by all means - you welcome. :slight_smile:

1 Like

the reason I was using custom conkys is that by the default autostart configs , nothing was load up .
so i executed manjaro-conky-session in the terminal , and this is the output :

conky: cannot open /home/fh/.config/conky/PacBang-4-Core-CPU.conkyrc: No such file or directory

this is not my user name . my user is master . but i don't know how to tell manjaro-conky-session to use my home directory

This is a bug I have overlooked - I will fix that.

Just open the root menu Super+Space and navigate Preferences -> Conky -> Conky Chooser -> select your conky and click ok.

Or you could manually edit the ~/.config/conky/conky-sessionfile - the end result is the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by