Restore Manjaro boot

Edited: 20180309
Reason for edit: Since Manjaro install cd is now based on grub, it is simpler, easier and safer to use this instead. However, the method originally outlined is still effective and we'll leave it here as a useful reference.
Use Boot up your installed Manjaro using install media instead.

There are times we lose our Manjaro boot and we cannot boot back into Manjaro.
The usual causes are

  • when we install another linux distro
  • when another linux distro gets updated
  • when we reinstall Windows

The best and easiest way to handle this problem is to have a grub rescue cd handy. In this case, use the grub rescue cd to boot into Manjaro and proceed straight to "When booted" section below.

If in the rare case this is not available, here are some steps to get back Manjaro.
But since we have the Manjaro install cd, we can use that instead.
Refer to top of post then.

And all the following applies only to bios-legacy/msdos.
If system is uefi/gpt, just go to uefi bios to reset Manjaro as default boot and then "update-grub" if necessary

(Case 1) Another linux bootloader has become the default
and the problem is usually due to the other OS picking up just only Manjaro's intel-ucode.img as its initrd file.

Use that other linux bootloader to boot into Manjaro
There are several ways to do this, but I will mention only one.

At that other linux grub menu, go into its grub prompt (grub>) by pressing 'c'
At its grub prompt,
grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

Manjaro grub menu will then appear, enter at the first (top) entry and we will boot into Manjaro.
Jump below to the "When booted" section below.

(Case 2) Windows installation.

Boot up a livecd, at livecd terminal,

sudo mount /dev/sdxy /mnt
sudo grub-install --boot-directory=/mnt/boot /dev/sda

where /dev/sdxy is Manjaro partition -- check with "lsblk -f", "sudo blkid", "sudo parted -l" etc to be sure to get partition correct.

When booted into Manjaro, at terminal,
sudo grub-install /dev/sda
sudo update-grub

Reference notes -
manjaro forum link
grub manual -external

Footnote -
If we choose to use the other linux bootloader as default boot, make a corrected entry for Manjaro and put it in the other OS /boot/grub/custom.cfg. See here.

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
I delete my bootloader!
Dual Boot two Linux distro
Minimal bash, and can't fix grub
How To Prepare For A Swap UUID Change (Read on)
Rule of thumb for fixing kernel panic?
Can't find where to boot into Manjaro
Manjaro not booting after Ubuntu reinstall!
Updated Kernel on Linux Mint, now cannot boot Manjaro
XPS15 Manjaro Deepin boot problems
Installing Manjaro Xfce on multi-boot UEFI laptop - problem on reboot
How to handle GRUB
Cannot run windows anymore
Cannot boot to Manjaro after dual boot
Manjaro Not Booting After Antergos GNOME Install
Manjaro Not Booting After Antergos GNOME Install
URL's from my cheat sheet
Install Manjaro along with a dual boot Mint 18 / Windows 7
Kernel panic - not syncing: VFS: Unable to mount root fs on
Trouble install dual boot W10
Will upgrading my version of Windows interfere with dual-boot?
Not booting after installation. grub problems?
Failed triple booting between windows 7, manjaro, and ubuntu
Manjaro/Win7 dualboot. GRUB not showing Windows
Bei Multiboot-System bricht der Manjaro ab
How to deal with AUR packages that break things
Dual Boot Question Again
Installing Manjaro alongside Linux Mint
[MJ GNOME] Error Bootloader Job [UEFI]
Preventing Manjaro bootloader from being overridden
MBR broke after updating to latest kernel
Could not boot into Manjaro
No grub after Windows 10 upgrade
Uefi doesn't recognize bootloader after disconnecting and reconnecting the ssd
The "Restore the GRUB Bootloader" in Manjaro wiki needs an update
Problems getting grub to load on dual boot
Kernel Panic at starting system
Kernel panic after installing manjaro kde on multiboot system
Manjaro not booting after battery change
Tried to change kernel 4.13
Can't boot into Manjaro
Booting Manjaro from elementaryOS grub?
Unsure how to install manjaro alongside linux mint?
Kernel Panic / Manjaro switch from /dev/sd4 to /dev/sd7
Unable to boot Manjaro
So how's Manjaro KDE?
[Stable Update] 2017-10-29 - KDE, Gnome, Deepin, Firefox, Mesa, Kernels
[SOLVED] GRUB connect new HDD with Windows installed
Grub falls in rescue mode repeatedly after Win10 update
Installing Windows 7 alongside Manjaro
HP EliteBook: In BIOS mode, Manjaro boots automatically, but not in EFI mode
Restore grub
Kernal Panic after upgrade
Dual boot update causes kernel panic
Grub problem with multible distros [Solved]]
[SOLVED] Problems with Grub and /boot/efi after install Manjaro KDE 17.0.1
[solved]Unable to mount root
Windows 10 bootloader doesn't start after grub entry is chosen
Blinking underscore when booting + Manjaro grub skipped
[SOLVED] GRUB Disappeared
Identify W10 boot partition to overwrite it with GRUB
Installing Windows 10 for dual boot AFTER installing Manjaro?
Installation: Cannot install to hard drive (only to USB stick)
efi partition fubared (not nuked). Grub couldn't help.
How can i change the default systemd-boot entry to manjaro?
[TOC] Boot-GRUB problems
Restoring GRUB2 after Windows 10 install
Grub password prompt is not shown, when chained after Clover
Installed Manjaro Gnome on my HP laptop: no bootloader installed
Can't boot encrypted Manjaro after installing Windows 10.
Manjaro grub entry in another linux OS' has dropped the crucial initramfs item
Can't see Windows 10 in Grub after dual-boot install
Restore GRUB after Windows 10 reinstall
Grub error while installing
Kernel panic or freeze sometimes
Installation of manjaro deepin on a second hdd: error at bootup
Can't run Sparky Linux (installed after manjaro, UEFI)
Dual booting manjaro and pacbang
Help fix manjaro grub screen after
Grub rescue help?
Install manjaro and debian linux in the same hard disk
I booted Ubuntu on a different suvol and updated it, that apparently overwrote grub?
Recovering Windows 10 EFI partition
Updated Kernel on Linux Mint, now cannot boot Manjaro

Forum kindly sponsored by