Resume on suspend causes immediate restart

I have problem with resume on suspend.
When I wake up my Dell laptop it is immediately restarted.
I am on stable Manjaro KDE.

It has nothing with the last stable update, the problem started before.

I was trying to install some AUR package for BT AptX and since then I have this problem.
I reverted back the packages but that did not help.
The other package I installed was Mullvad VPN but I also uninstalled this and it did not help either.

This is my journal:

Oct 10 14:05:22 NEHEZ-DELL plasmashell[1359]: [14:05:22.227] unknown: QXcbClipboard: SelectionRequest too old
Oct 10 14:05:22 NEHEZ-DELL plasmashell[1359]: [14:05:22.279] unknown: QXcbClipboard: SelectionRequest too old
Oct 10 14:05:22 NEHEZ-DELL plasmashell[1359]: [14:05:22.329] unknown: QXcbClipboard: SelectionRequest too old
Oct 10 14:05:22 NEHEZ-DELL systemd[1]: Started TLP suspend/resume.
Oct 10 14:05:22 NEHEZ-DELL audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Oct 10 14:05:22 NEHEZ-DELL systemd[1]: Reached target Sleep.
Oct 10 14:05:22 NEHEZ-DELL systemd[1]: Starting Suspend...
Oct 10 14:05:22 NEHEZ-DELL kernel: audit: type=1130 audit(1539173122.458:286): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Oct 10 14:05:22 NEHEZ-DELL systemd-sleep[10527]: Suspending system...
Oct 10 14:05:22 NEHEZ-DELL kernel: PM: suspend entry (deep)
-- Reboot --
Oct 10 14:52:18 NEHEZ-DELL kernel: microcode: microcode updated early to revision 0xc6, date = 2018-04-17
Oct 10 14:52:18 NEHEZ-DELL kernel: Linux version 4.18.12-1-MANJARO (builduser@development) (gcc version 8.2.1 20180831 (GCC)) #1 SMP PREEMPT Fri Oct 5 16:06:16 UTC 2018
Oct 10 14:52:18 NEHEZ-DELL kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.18-x86_64 root=UUID=997dfaf3-c356-4c0e-81f4-570cd90b2e6e rw radeon.modeset=0 amdgpu.runpm=0
Oct 10 14:52:18 NEHEZ-DELL kernel: KERNEL supported cpus:
Oct 10 14:52:18 NEHEZ-DELL kernel:   Intel GenuineIntel

More data at https://pastebin.com/8sHVdgQY.

As you can see there is nothing what could tell me more.

Please, does anybody have an idea?

You have not setup a swap partition/file for suspension to work.
If you have a swap partition, you need to add its UUID to /etc/default/grub and add resume to /etc/mkinitcpio.conf.
Read more info.
Or you mean "suspend to memory"? Check your Power Management settings.

I mean "suspend to memory", hibernation removal was intentional.

The strange thing is that I am not facing the issue anymore since I've written this post and added acpi_sleep=nonvc into GRUB_CMDLINE_LINUX_DEFAULT.

Out of curiosity - what is the difference having it in GRUB_CMDLINE_LINUX_DEFAULT and GRUB_CMDLINE_LINUX?

Or are there other kernel options which would help by logging more data?
I mean to have more info between the following 2 lines:

Oct 10 14:05:22 NEHEZ-DELL kernel: PM: suspend entry (deep)
-- Reboot --

If your system was on sleep and you wake to a restart, this is the same as a crash-restart.
I mean, your system may have been shutting down, when you suspend it.
You haven't mentioned your info source for the kernel param that solved it, so we know more.
As for the Off topic questions, I can't remember by heart. I 'll have to lookup in Archwiki, or you can do it and remind me.

This has been added to GRUB_CMDLINE_LINUX_DEFAULT.

This was not the case while I pressed "Suspend" in KDE Menu or called systemctl suspend.
And to wake up the computer I just opened the lid.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by