Rhythmbox not playing .mp4 files

Dear all,

When I was on ubuntu, I used to be able to add and play mp4 files on Rhythmbox. But now for some reason I can't add any mp4 files to Rhythmbox.

When I add any mp4 file I receive the error message:

Error transferring track
Didn't get a playback URI for entry file:///home/..../file.mp4

Any ideas please?
Thank you.

Have you added the necessary libraries?

There is a lot of optional packages with extra media codecs - search for gst-plugins-.

Isn't mp4 a video format to begin with?... :thinking:

Yes it is. But all other music players can play mp4: take Audacious and Exaile.

Currently I have already installed:

gst-plugins-bad
gst-plugins-base
gst-plugins-base-libs
gst-plugins-good
gst-plugins-ugly

It still won't play mp4..

MP4 is a wrapper around audio and video - usually (H264 and MP3).

If you file cannot play - it may as well be an issue with the encoding of the file.

I'm not using Rhythmbox, so I can only suggest to follow the troubleshooting steps from the Arch Wiki:
https://wiki.archlinux.org/index.php/Rhythmbox

Especially the last suggestion might be worth a try:

I tried running files downloaded with youtube-dl as well as ones converted with Handbrake. I'm sure they used to play fine on ubuntu. They also play well now on manjaro on other players (Audacious & Exaile).

I tried deleting the database & the config files but it did not work..

Then it is an issue with Rhythmbox and the specific file's encoding - nothing Manjaro can change.

How is it possible that they work well on ubuntu under Rhythmbox then? Could it be it's a different build?

Okay I'll try build it myself..

Working on Ubuntu does not guarantee working on Manjaro.

Manjaro generally has newer packages than Ubuntu.

After all Manjaro is rolling release while Ubuntu is fixed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by