Rofi based application launcher menu with categories

Theme variant without compositor

rofi-2018-03-26-0744-00000

changes to rofimenu.rasi
button {
	horizontal-align:	0;
	expand:			true;
//	expand:			false;
	padding:		@addpadding;
	width:			18ch;
	background-color:	@background;
}
listview {
	lines:			12;
//	lines:			20;
	fixed-height:	true;
//	fixed-height:	false;
	dynamic:		false;
	scrollbar:		true;
}
1 Like

do i need to update the rofi script / rofimenu.rasi ? [to show the "Menu Settings" option on left pane ? OR i add the menulist ?

You should update the script.
Now rofimenu has config file ~/.config/rofimenu/rofimenurc. It is created on the first start.
EDIT.
If you want lines on the left to fill all height, edit .rasi as in previous post

how do i do ?
i had cloned your script from git earlier ! i simply cloned into my scripts folder and execute it ! [though i know its crude]

Clone it again, or just copy/paste from github site. Be aware that scripts on github were moved to /bin folder.

1 Like

Ahhh.. missed out on the change in folder path ! i was wondering why i could not find them.

just curious....
roficatmenu / boxmenu ? variants ?

This is menu script @Chrysostomus intends to use as desktop menu.

This is my first attempt at showing categories.

1 Like

waiting for update... ! till then i may explore by replacinf the GKTmenu "LaunchMenu" option to check out !

Default theme now has two styles.

Submenu-like style (requires compositor):

rofi-2018-03-27-1453-00000

Tabs-like style (works without compositor):

rofi-2018-03-27-1452-00000

It takes a couple of lines to comment/uncomment to change menu style.

1 Like

I changed now the mainmenu of bspwm-minimal to use this instead, and the desktop menu to use my variant of rofi cat menu. The packaging solution was not ideal, but I was lazy. Probably need to change that later on...

2 Likes

7 posts were merged into an existing topic: Scriptable lightweight panel for bspwm with lemonbar

Have you tried

  export BROWSER=chromium

yes...
still no result...
BTW, just wonder, i had to set it when i first installed bspwm... perhaps 16.X version i cant remember... is it so ?

EDIT:
rofimenu script says "default-browser" for Browser, "default-terminal" for TERMINAL, "default file browser" which opens $terminal -e ranger.

   ~   master  xdg-settings get default-web-browser                                   ✔  10027  23:05:18 
chromium.desktop

default-browser is a script that sources your ~/.profile and run $BROWSER that is set there.

The point is, it has nothing to do with desktop files or default browser of xdg specification

1 Like

The easiest way is just to set applications you want in menu config file in Favourites() function like this:
echo " Browser:chromium"

It can be set to xdg-open ~ instead

EDIT. Also consider following:

exo-open --launch WebBrowser

or

gtk-launch $(xdg-settings get default-web-browser)

if you have them installed

1 Like

@Chrysostomus
adding export BROWSER=chromium in ~/.profile does it for rofi... :+1:

@kainonergon
editing rofimenu with either of the options [ exo-open OR xdg-settings does it too.... too, doesnt touch ~/.profile ]
:+1:

EDIT:
I think adding entries in (dot)profile is mandatory ?
if i comment out the entry, rofimenu fails to open chromium)

Tested bspwm-minimal with it. I'll have to work on the font settings, some category icons are not displayed properly. I like to use terminus font for its sharpness, but for some reason some fallback fonts do not pick all the icons on bspwm-minimal.

Other than that I'm quite satisfied with it.

try TerminessTTF Nerd Font OR DejaVuSansMonoForPowerline Nerd Font

This is the fallback font used for the icons. Problem is, it is horribly blurry and renders badly. Normal terminus font is bitmap font, so it is always sharp even without antialiasing

my simplepanelrc fonts

SP_FONT_1="DejaVuSansMonoForPowerline Nerd Font:pixelsize=11"		# main font
SP_OFFSET_1=-1
SP_FONT_2="DejaVuSansMonoForPowerline Nerd Font:pixelsize=11"	# iconic font
SP_OFFSET_2=-1
#SP_FONT_3="-misc-knack nerd font-medium-r-normal-*-18-*-*-*-p-*-iso10646-1"	# extra font
SP_FONT_3="-misc-anonymicepowerline nerd font-medium-r-normal-*-13-*-*-*-m-*-iso10646-1"	# extra font
SP_OFFSET_3=0

rofimenu font

//    font:                        "xos4 Terminus 18px";
    font:                        "DejaVSansMonoForPowerline Nerd Font 14px";

with above settings, i get this...
[i have colorized monotone icons (shown iin app menu) to match the nerd icon color to keep in sync]
rofimenu

unfortunately i cant install knack nerd fonts [name changed to hack nerd but still not able to install from nerd-fonts aur repo for technical reasons. i could manually install dejavusansmono nerds complete manually and hence able to use it

1 Like

Forum kindly sponsored by