Rofi freezes

Hey dudes, I love bspwm edition. Is there an open repo to post issues? I had an issue that was solved on Arch forums under this link
https://bbs.archlinux.org/viewtopic.php?id=229095
Has anyone had the same problem? Is there an option to implement the solution to the distro?

Hello! I moved your question to a separte topic.
Please, explain the issue in you own words, edit your post, even if it is "exactly" the same as the linked post.

1 Like

Alright, thanks!
So after booting Manjaro it would freeze for 30 seconds or more when rofi was first used. Couldn't change working space, run anything, only the mouse moved and hover on toolbar worked (tooltips showed, hover effects were visible). I logged onto another tty and saw a rofind process with find command ran which had around 10% CPU usage. I found the solution and edited /usr/bin/rofind adding coproc which ran it asynchronously and it rofi now shows without delay.

3 Likes

Nice improvement. You can send the pull request in this repo:

Alrighty, I've opened a PR https://github.com/Chrysostomus/rofi-scripts/pull/1

1 Like

Alright, this is embarassing. I haven't checked if the script works - it did for me, as it loaded fast, but actually rofind was just crashing. This script uses dash shell which has no coproc implemented. I committed new code that kinda works, but needs some improvement.
@Chrysostomus please take a look https://github.com/fraunos/rofi-scripts/commit/3fb26f7e171fdb49653dc2ffa88cbd982bc2c0c0

1 Like

Well, good thing I didn't build the package yet :grinning:
Thus is my laziness rewarded

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by