rookie mistake - I selected the wrong keyboard layout on a new install

#tldr: I selected the wrong keyboard layout during install. Is there a way to use chroot, or just go through the M-A steps again with out actually doing the install and just selecting the correct keyboard layout of "US"?

First, I'm a total newb and had several fits just getting the install procedure correct, but after several failed attempts I definitely know more than when I started, but have a loooong way to go. Last night I finally completed the install using manjaro-architect and had a mini celebration as it booted up, only to be crushed again when I couldn't login, I kept getting the wrong password. Thinking I had somehow made the same typo twice when setting my user password I clicked on "other user" thinking maybe I could log in as root, where I realized my mistake, I selected "AM" as my keyboard layout, thinking it stood for "America" like in the locale setting... :grimacing::unamused: (it was late...).

Simple fix is to just reformat and re-do the install, and I may do that, but I thought hey, another learning opportunity, and chance to engage some of you awesome people who got me this far even though you don't know it, plus hopefully give some of you a laugh.

Is there a way to use chroot (command line syntax is still foreign to me) , or just go through the M-A steps again with out actually doing the install and just selecting the correct keyboard layout of "US"?

image

Thank you in advance!

ETA: I'm at work now and won't be able to work on this until tonight, or over the weekend. Thanks again!

1 Like

Refer SGS links and you can at your (normal) grub menu, type in these keyboard parameters so you can boot in to your OS. Then use the other link to setup your keyboard configuration. Keyboard configurations vary with diffferent DE, but localectl (and mhwd) will be the same throughout. Still best to also go through your DE settings.

2 Likes

Awesome! Thank you both for your help! I'll try this tonight.

Just so I'm clear, I type 'c' at boot menu to enter grub, then enter the commands you @gohlip provided here:

/etc/locale.gen
# locale-gen
$ localectl list-locales
sudo localectl set-locale LANG="en_US.utf8"

Then from reading the wiki, it seems I should enter this:

/etc/vconsole.conf
KEYMAP=us

Am I close?

Also, my DE is XFCE, how would I go about checking the DE settings as you suggest?

Oh no, my bad. I'm sorry.
Confused the links. The link should be this one here

The parameters to be added as examples in the correct link is

tz=Europe/Berlin lang=de_DE keytable=de

Use the right one for your language and keytable.
And type 'e' at the grub menu to add in. Not 'c'.

And when booted up, do the setting changes.
Sorry again.

2 Likes

No worries!
So not a command line entry, just add those parameters (but modified to my language and keytable) to the grub menu options, this will give me a temporary fix to login then I can use terminal to correct once fully booted into the system. That sounds even easier! Thanks again! I'll let you know how it goes!

1 Like

I think I've entered the parameters correctly but still unable to type in English on login screen :frowning:
I think I might just wipe the drive and reinstall. Thank you for your help and expertise! Many of the posts I found when searching for answers during my earlier difficulties during install were yours @gohlip
20190426_200051 20190426_201127~2

1 Like

Okay, understand. It was a new install so a reinstall would probably be the best and easiest. I have a (non-manjaro) Enlightenment distro where switching languages is a simple click but keytable is still 'us' (input on 'us' table). And most of the rest of my distros are usually 'fixed' on a particular language. I'm quite comfortable with 'english' and my beginnings with linux necessitates me to install in English.

Cheers, take care.

1 Like

Thanks again for your help! Done with reformat and reinstall, and posting this logged in to my new OS :grin:
Now the fun begins! I'm sure it won't take long and I'll break something again though!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by