[RPI3] Kernel now updated to 4.14

Hi all.

The raspberry Pi kernel is now updated to 4.14, because the newly released Raspberry Pi 3 Model B+ could not boot with our old 4.9 kernel.

I am also preparing a new minimal image release 18.04 with this new kernel, effectively supporting all Raspberry Pi 2 and 3 models.

There is a known issue with this kernel though, and that is the new firmware-raspberrypi package keeps spamming dmesg, which is present in the TTY at all times. I haven't been able to find a way to suppress these images yet, other than uninstalling that package.
The package does contain some firmware for the Wifi and Bluetooth components and maybe others.

8 Likes

On my Pi2 and on my XU4 with alarm and Kernel 4.14.31-1 no Problems.

Linu74

1 Like

I have problems with my raspberry 3 b.

I flashed my MicroSD wtih the latest minimal release and plugged it into my raspi and after 30 seconds I get spammed with something like: firmware-raspberrypi not supported 0x21332435 blablabla..

Every second this error message comes, even if I press ctrl+c or if a switch to another "session" with ctrl + alt + f2.

I don't know exacly the message, because I currently have another OS on the system.

Maybe you have an idea what I can do, if not, then I will flash manjaro arm again and post a screenshot in the again.

--
Benyoo

Yeah, thats the issue I mentioned in the main post.
There is no fix yet, as far as I know.

Replacing the firmware files in the boot partition with ones found here solved this problem for me.

ok thank you very much, I will test it in the evening.

Update:
It worked, but out of 40 restarts. I get the most time: Kernal panics.

But that one time where I was able to login, was worth it. Maybe I find a solution for the kernel crash.

Maybe you over wrote kernel.img and kernel7.img also?

I just replaced the bcm27xx...dtb files. these are the broadcom firmware. This has worked reliably form me.

Sorry. I should have been more specific.

yeah I overwrote all :slight_smile: Tomorrow my new MicroSD card is coming, then I can play around with that. Thanks.

I tried what you said, it didn't stopped spamming the TTY, there was something else that you did?

I copied the complete bootfolder incl. overlay folder to my mount and then flashed it. For me the spamming was gone and I am was able to login once to the manjaro arm os. But as I said, I had many cpu panics.

Currently I try only to copy the bcm27 files, the first try failed. I saw only the rainbow Screen the whole time.

(INFO I use a Raspberry PI 3 b, so that we know about which device we are talking :D)

Update#1:
Second try: Now I copied the firmwares only; without removing the other onces from the .img and I get the spamming error again. Next try :slight_smile:

Update#2:

ITS WORKING!

What I did:

First I downloaded a fresh .img from Manjaro ARM on main-site (http://manjaro-arm.org/downloads.php) and the complete firmware source (Master Brunch) from the official raspberryGithub (https://github.com/raspberrypi/firmware/tree/master/boot).

Then I mounted the .img with and deleted the complete overlays folder. Then I copied the complete overlays folder from the brunch to the mounted img.

Files from the /boot folder I copied:

  • all .dtb files
  • the start_xxx files (4files, i think they were up-to-date, just in case copied them)
  • and the fixup_xxx files (4files as well) I think this are the important once!!!

If someone is new to linux and have questions how to mount the manjaro img with the offsets, feel free to ask me.

manjaroARM

Update#3:

After running: sudo pacman -Syu and reboot, the system is still running \o/!

3 Likes

Very nice. I will keep this in mind for our next release!

@GrayJack, you think you can do a package that does this?

Yeah, no problem :smiley:

@GrayJack, it's working for you as well?

Yeah, it wasn't related to .dtb files, probably related to .dat or .elf files, we already updated the package that update these files: raspberrypi-bootloader

1 Like

This topic was automatically closed 89 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by