Rpi4 | 4K | XFCE version

Hi all,

I tried to search before posting but i didn't find anything. Is it normal that using 2K or 4K resolution the system becomes laggy? in 1080p everything is fine. When i was using Raspian, the resolution didn't have that much impact on the system performance. In any case, i am not complaining, i just want to make sure that this is normal or it's me having something not properly configured. Thank you in advance for the amazing work with Manjaro ARM!

if it didn't happen with raspbian then there's something fishy here, did you try any other DE?, i might have some clues leading to xfwm4 and with your help i could confirm them.

Also what about compositor ? does it make a difference on/off ? how is it configured ?

inxi -Fxxxza --no-host

might also tell us more

I didn't try with other DE. Definitely enabling/disabling compositor directly affects to the problem. When disabled, the system is more responsive, so it feels faster, but when moving windows is like they freeze per every frame for some seconds. When compositor is enabled, this effect disappear, but the system becomes less responsive so it feels slower.

System:
  Kernel: 4.19.97-1-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: coherent_pool=1M 8250.nr_uarts=0 cma=64M cma=256M 
  video=HDMI-A-1:3840x2160M@30,margin_left=0,margin_right=0,margin_top=0,margin_bottom=0 
  smsc95xx.macaddr=DC:A6:32:1B:D2:35 vc_mem.mem_base=0x3ec00000 
  vc_mem.mem_size=0x40000000 root=/dev/mmcblk0p2 rw rootwait 
  console=ttyS0,115200 console=tty1 selinux=0 plymouth.enable=0 
  smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200 
  elevator=noop snd-bcm2835.enable_compat_alsa=0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro ARM 
Machine:
  Type: ARM Device System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835 
  rev: c03111 serial: <filter> 
CPU:
  Topology: Quad Core model: N/A variant: cortex-a72 bits: 64 type: MCP 
  arch: ARMv8 family: 8 model-id: N/A stepping: 3 microcode: N/A 
  features: Use -f option to see features bogomips: 432 
  Speed: 600 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 600 2: 600 
  3: 600 4: 600 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 mitigation: __user pointer sanitization 
  Type: spectre_v2 status: Vulnerable 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: bcm2835-vc4 driver: vc4_drm v: N/A bus ID: N/A chip ID: brcm:soc 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A chip ID: brcm:soc 
  Display: x11 server: X.org 1.20.7 driver: modesetting alternate: fbdev 
  resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: bcm2835-audio driver: bcm2835_audio bus ID: N/A 
  chip ID: brcm:soc 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A chip ID: brcm:soc 
  Sound Server: ALSA v: k4.19.97-1-MANJARO-ARM 
Network:
  Message: No ARM data found for this feature. 
  IF-ID-1: eth0 state: down mac: <filter> 
  IF-ID-2: wlan0 state: up mac: <filter> 
Drives:
  Local Storage: total: 28.89 GiB used: 8.26 GiB (28.6%) 
  ID-1: /dev/mmcblk0 model: SD32G size: 28.89 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> scheme: MBR 
Partition:
  ID-1: / raw size: 28.79 GiB size: 28.28 GiB (98.22%) 
  used: 8.22 GiB (29.1%) fs: ext4 dev: /dev/mmcblk0p2 
  ID-2: /boot raw size: 94.0 MiB size: 93.8 MiB (99.79%) 
  used: 38.6 MiB (41.1%) fs: vfat dev: /dev/mmcblk0p1 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 168 Uptime: 39m Memory: 3.73 GiB used: 1.63 GiB (43.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by