RPI4 overclocking [Manjaro ARM performance BUG]

Hi guys. I've got an RPI4 and want to use it for a stock trading.
I have:

  • 2 monitors with 1080p.
  • Latest Manjaro ARM xfce.
  • Brand RPI power supply
  • active cooling with a heat sink case

My case looks like that:

So, when i open 3 chromium tabs of Tradingview.com (two on first display and one on second) whole system response slowly.
I have a previous install a KDE version, and it was too slow and not usable. So i decided to install xfce, and now its much better but still slow.
I try to do an overclock by this link https://www.tomshardware.com/reviews/raspberry-pi-4-b-overclocking,6188.html

However, the original launch firmware for the Pi 4 could only reach 1.75 GHz on the CPU and 600 MHz on the GPU.

If you want the latest and greatest overclocking ability on the Pi 4, you'll need to upgrade to the latest experimental firmware build, which could possibly have bugs. To update your firmware, enter these three commands in a terminal window.

sudo apt updatesudo apt dist-upgradesudo rpi-update

As of publication time, the highest speeds we had achieved were 2.147 GHz for the CPU and 750 MHz for the GPU, but newer firmware may let you push it even farther. Also, because not all processors are identical, your mileage may vary.
So i edit values only for stock firmware and system stay a little bit faster, but still laggy.

How i can update my rpi firmware on manjaro arm to make a full overclock?
or it already latest and i just should to edit config.txt to maximum values?

Where are firmware located? If i boot from another microsd with raspbpian and do firmware update and then back to my manjaro sd. Are my firmware will be updated on a manjaro?

Maybe i have some problem with performance like in this thread, i don't know. I want to boot into rasbpian, and try chromium with 3 tabs there and compare.

On the KDE edition I can easily do 7+ tabs before it starts to significantly slow down. I'm overclocked to 2GHz CPU / 750MHz GPU
Manjaro updates the firmware with the rest of the os so as long as you are up to date there you will be fine.

I made a simple test. Took a new sd card and installed a last Raspberry OS. Open exact 3 tabs in Chromium.
And i saw an amazing performance with no lags.
BTW i use a Synergy app to use a same mouse and keyboard for two PC. And it was no lags on cursor movement too.

So results:

  • On clean Manjaro ARM KDE and Manjaro ARM XFCE on Raspberry PI 4 i've experienced a slow performance in Chromium using at least a 3 tabs. Even an overclocking dont solve a problem.
  • On clean Rasbperry OS there are no problem at all. Fastest performance from the box.

My conclusion:
There are some bug in Manjaro distribution. Maybe some corrupted drivers or some error in configs.
There is a chance, thad LXDE much better for RPI4 then XFCE, but i dont belive in it.

I have no time and possibility to make more test, i just solve my problem changing to Raspberry OS.

I hope Manjaro maintaners will spot my post and do some test ad bugfix. I really love manjaro, and want it to be on all my devices, but in this time i loose with it.

I almost sure that this post also proof's that problem exist.

I am pretty sure Raspberry OS uses a heavily optimized Chromium in their repo. So it probably has all the acceleration stuff for the GPU in it.
While we use the Chromium provided by Arch Linux ARM, which is a lightly optimized PKGBUILD, just so it builds on aarch64/ARM.

Are there any possibility to build Raspbian optimized Chromium for Manjaro?
I almost sure that ive tried firefox on Manjaro ARM, and result was the same. I just remember that i try all i cat, include a different browsers.

Nope. We don't have the manpower to keep a browser like Chromium up to date.

Good news though, Arch has started building Chromium with vaapi support enabled.

1 Like

Hello, and welcome to the forum!

To check your firmware version, run this command in the terminal (without any flags, it will just display info about your EEPROM and not actually do anything to it):
sudo rpi-eeprom-update

Output if you're up to date will look something like this:
image

If it says you're NOT up to date, and that an update is available:

  1. make sure you've backed up anything you would hate to lose;

  2. update the system (sudo pacman -Syu) and reboot;

  3. run the same command, with the -a argument: sudo rpi-eeprom-update -a; and reboot.

If you want to monitor your CPU temp and speed while trading, download and install cpu-temp-speed (sudo pacman -S cpu-temp-speed) and run this in the terminal while working. It is my understanding that unless you're going over 70 degrees C, you're in no danger of thermal throttling, and the actual thermal limit is around 80 degrees C.

Once you've updated the firmware (if necessary), you should be good to attempt overclocking, but I've never done that, so no idea how it works. You've already got active cooling, though, so you're at least in good shape to try it. Once you do, I'd go in increments (that is, don't jump straight to 2.0 Ghz--make sure you're stable at, say 1.75 first, then 2.0. You can also try a minor graphics overclock, but I'm not sure how valuable something like a 20 Mhz graphics chip overclock actually is for your workload.

**EDIT: ** When it's not busy, the CPU hovers around 600 MHz according to cpu-temp-speed, so don't be alarmed when you see that. When it's being worked, without overclock, it'll hit 1500 until it thermal throttles back down to 600.

Forum kindly sponsored by