RTL8111/8168/8411 driver issues

I have just installed manjaro on a PC with brand new motherboard (MSI B450 Mortar Max), Ethernet controller on it happened to be Realtek RTL8111/8168/8411. And now I have issues with it, at first it works, but sometimes it drops connection to the router and it cannot reconnect. I've looked on google, it appears driver for this device had some issues, most of the forum threads suggested to switch the driver to r8168 or r8169, I tried booth, r8168 and r8169 and booth seem to have this problem.

There's also this one strange thing I noticed, if I start downloading a game on Steam it drops the connection shortly after, unless I set bandwith limit. I have 100Mb/s connection, I have to limit it to 7MB/s in Steam settings to not get disconnected, if it's unlimited I can't even ping my router. I assume it's the problem with the driver or the motherboard hardware as everything worked fine on my previous motherboard.

If anyone has any ideas, please help.

Recent kernels has excellent support for that NIC or your system is one of the few actually needing this.

Try uninstalling the r8168 package. Depending on your actual kernel package it may have different names.

mhwd-kernel -li

Either of these is probably installed

  • $KERNEL-r8168
  • linux-latest-r8168
  • linux-lts-r8168

Verify the blacklist conf is removed from /etc/modules-load.d

Right now I don't have r8168 on my system, which I just confirmed with lsmod. Im on r8169, problem persist.

BTW I'm on linux 4.19 LTS kernel

8168/8169 same cup

Try removing the mentioned package.

Without having any of those modules Ethernet controller is not being recognized, I can't even try to connect. It says "No network devices available"

Then install a newer kernel - 5.3 or 5.4

Kernel 5.4 - exact same thing happens, "No network devices available"

Did you check the folder /etc/modules-load.d if a blacklist file is present for your NIC? If it is and you do not have the modules installed - then remove the blacklist.

This particular NIC has been beaten to death in the forum - I don't have any ideas but you may find what you seek

https://archived.forum.manjaro.org/search?q=8168

That folder doesn't have any blacklist file in it

I am out of options - I have a laptop with that NIC - it works OOB with kernel 5.x

Are you sure that you don't have any of those modules I mentioned on your laptop? If you run hwinfo on it doesn't Ethernet has a Driver field with r8169/r8168?

Yes - I am sure - my system run on kernel drivers.

Just for the sake of testing I installed 4.19 and used an internet connection tester and I get the speed I pay for - up/down - no issues.

On my LAN which I cabled years ago using CAT5e I am getting Gbit connection I get the speed my ISP advertise through Gbit router and three Gbit switches - I get +300Mbit which is what I pay for.

Snip from hwinfo - kernel provide r8169 driver

59: None 00.0: 10701 Ethernet
  [Created at net.126]
  Unique ID: n2mR.ndpeucax6V1
  Parent ID: vg8X.XxQoMhAHdj3
  SysFS ID: /class/net/enp58s0f1
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.4/0000:3a:00.1
  Hardware Class: network interface
  Model: "Ethernet network interface"
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: enp58s0f1
  HW Address: 80:fa:5b:60:c4:53
  Permanent HW Address: 80:fa:5b:60:c4:53
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #26 (Ethernet controller)

...
So you are on r8169, as I am.

So anyway, I'm on r8169, same as you, it doesn't work properly.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by