RTL8192EU - Realtek & Intel wifi not working

I was absent at home for about a week, meanwhile I updated Manjaro (Cinnamon). After returning I can't connect to the internet via my TP-Link Archer C6. I'm pretty sure that router works fine - two Windows-machines and Android-smartphone have their internet.
Network Manager says that connection is established. It shows correct my (dynamic) IP and DNS-server (router's IP). All information is the same as in the Windows (password, MAC, IPs, channel etc.) but there is no connection to the internet. I can ping my router and access it by IP. When I try to ping google.com I see correct IP but all packets are lost. There is no access to any site.
Even more. When I tried to boot with Manjaro-live the situation appeared to be the same: Network Manager connected to router but internet is inaccessible.
Please give me a clue what to do with this trouble!
Here's the output of inxi -Fdxxxz command

System:
  Host: dmitry-magicbook Kernel: 5.2.2-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.1.0 Desktop: Cinnamon 4.2.2 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HUAWEI product: KPL-W0X v: M1B serial: <filter> 
  Mobo: HUAWEI model: KPL-W0X-PCB v: M1B serial: <filter> UEFI: HUAWEI 
  v: 1.22 date: 02/26/2019 
Battery:
  ID-1: BAT1 charge: 56.9 Wh condition: 56.9/56.3 Wh (101%) volts: 8.6/7.6 
  model: DYNAPACK HB4593R1ECW type: Li-ion serial: <filter> status: Full 
  cycles: 3 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 31952 
  Speed: 1371 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz): 
  1: 1370 2: 1381 3: 1459 4: 1427 5: 1371 6: 1372 7: 1371 8: 1374 
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
  vendor: Huawei driver: amdgpu v: kernel bus ID: 02:00.0 chip ID: 1002:15dd 
  Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa tty: N/A 
  OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.2-1-MANJARO LLVM 8.0.1) 
  v: 4.5 Mesa 19.1.3 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei 
  driver: snd_hda_intel v: kernel bus ID: 02:00.1 chip ID: 1002:15de 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Huawei driver: N/A bus ID: 02:00.5 chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Huawei driver: snd_hda_intel 
  v: kernel bus ID: 02:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.2.2-1-MANJARO 
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel 
  bus ID: 01:00.0 chip ID: 8086:24fd 
  IF: wlp1s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 2.05 TiB used: 1.72 TiB (83.8%) 
  ID-1: /dev/sda vendor: LITE-ON model: CV8-8E256 size: 238.47 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 402 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 10B8 
  size: 1.82 TiB serial: <filter> rev: 1012 scheme: MBR 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / size: 19.82 GiB used: 15.46 GiB (78.0%) fs: ext4 dev: /dev/sda5 
  ID-2: /home size: 160.38 GiB used: 8.02 GiB (5.0%) fs: ext4 dev: /dev/sda6 
  ID-3: swap-1 size: 4.14 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: amdgpu temp: 45 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 236 Uptime: 22m Memory: 6.77 GiB used: 905.7 MiB (13.1%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: zsh v: 5.7.1 
  running in: gnome-terminal inxi: 3.0.35 

The fix is apparently in 5.2.5-2.

Thank you!
I've read that topic and made downgrade to linux-formware-20190514.711d329 but nothing changed.
And Manjaro-Cinnamon Live 18.0.4 didn't worked either (AFAIR it has version of linux-firmware earlier than 20190514.711d329).
And I don't know yet how can I upgrade my system without internet connection.

1 Like

Yeah, updating is definitely an issue without internet. :grin:

Try this...

sudo systemctl stop NetworkManager; sudo ip link set wlp1s0 down; sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod; sleep 3; sudo modprobe iwlwifi; sudo ip link set wlp1s0 up; sudo systemctl start NetworkManager

Stolen from @tbg's post
And see if it starts up.

Refer to post below:

3 Likes

Thank you, @tbg and @Sinister!
Alas, after this procedure with modules everything remained as before.
I have usb-adapter RTL8192EU but it doesn't work without proper driver on my laptop. And I have no internet connection, so I can't install this driver. It's a vicious circle! :slight_smile:
I'll be thinking what else I can do.

Hi! :slightly_smiling_face:

Smartphone-Hotspot....

Thank you!
I've tried it. Network Manager couldn't connect.

Oh sorry! Thats your problem. :sweat_smile:

But Thetering is a idea. In AUR is a app called "easytheter". I dont try it and its flagged "out of date"?...

But here is a link in Arch -Wiki:

https://wiki.archlinux.org/index.php/Android_tethering

If your smartphone support this. A USB Port seems to be present. Or you download per smartphone...

This is the procedure I would recommend to install the 8192eu driver.

Install the linux headers package for your kernel.

The following command will install the linux-headers automatically for all installed kernels:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

*credit @dalto for the command

Install the driver dependencies:

sudo pacman -S dkms git

A blacklist file must be also generated to block the loading of the kernel modules at startup.

The following command will automatically generate "/etc/modprobe.d/blacklist.conf" with the correct blacklist entry:

sudo echo -e "blacklist rtl8xxxu" | sudo tee -a /etc/modprobe.d/blacklist.conf

Uninstall any wifi drivers that were previously installed.

Then restart.

If you do not already have AUR support enabled on your system then install pamac-cli.

sudo pacman -S pamac-cli

Install 1 or the other of these 2 AUR drivers:

pamac build 8192eu-dkms

or

pamac build rtl8192eu-git

After either the 8192eu-dkms or the rtl8192eu-git driver is installed, reboot.

Hopefully your 8192eu driver is now working after restarting.

2 Likes

Here is the link to "easytheter" (if you cant find):

http://www.mobile-stream.com/easytether/drivers.html

1 Like

You do not need to install any software to use USB Android phone tethering.

https://wiki.archlinux.org/index.php/Android_tethering#USB_tethering

2 Likes

Sorry again! I dont checked the problem. You need the firmware! I searched again and here is the link to "linux-firmware":

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git

You must download the package -"0618". In the package is a "Makefile". Open "Makefile" and follow instructions at the end of the file. ("make install" or so as root...). After this reboot and your WIfi will working. AND after this action should you install Thetering! Nobody buys a notebook with no LAN Port... :shushing_face:

1 Like

Do you have other kernels still installed?

Test all other kernels you have installed.

If you deleted your other kernels, you need to keep at least 2 kernels installed at al times.

I have Linux51 (5.1.21-1) and Linux52 (5.2.4-1). I tested both of them, they work identically.
Yes, I always keep two installed kernels!

Thanks!
That works for me.

1 Like

Thank you for such comprehensive instruction!
I'll do it.

1 Like

Actually, it worked.
That's what I did. I made smartphone-hotspot and loaded with Manjaro-Live. Network Manager connected to hotspot, than I installed mhwd-chroot and upgrade my system.
But in the end Network Manager still doesn't work with my router, but works with hotspot.

Sorry, but I have to ask. Have you rebooted your router?

2 Likes

Yes, I rebooted it several times.
Now I think that this is the problem not with laptop but with router.
I tried to connect to another router (old model). Wifi-module and usb-adapter both worked perfect.
But with this particular Archer C6 situation doesn't change.

Forum kindly sponsored by