Rtl8723be WiFi card issues

Hey there. I am having issues with the rtl8723be on Manjaro. My problem is that I can connect to WiFi but the signal is poor and it keeps dropping out

Here is what I've tried to fix this:
Enabled the ant_sel=2, fwlps=N and IPS=N settings in /etc/modprobe.d/rtl8723be.conf but this only solves the dropping out issue and ignores the ant_sel=2 setting(I've tried ant_sel=1 to no avail)
I've tried downloading the rtlwifi_new drivers from github and building then however it complains that it can't build the drivers for the Manjaro kernel.

Please can someone help me with this as it is annoying how this worked fine in Mint but not Manjaro

I would recommend trying kernels 4.18 and 4.19 with this adapter (if you haven't already).

Information on how to post hardware specs and logs on the forum:

I will try this when I get home then

What is the difference between rtl8723be and rtl8723bu?

I know the former is a USB device - is the first a PCI device?

WiFi card

I believe any of the realtek adapters ending in "U" are USB devices.

Please post:

inxi -Fxxxz
lsmod grep | 8723
hwinfo --netcard --wlan --bluetooth | grep -Ei "model\:|driver\:|status\:|cmd\:|file\:|detected\:" | grep -v "Config Status" 

Are you using the kernel module, or have you installed a driver from the AUR.

If you installed an AUR driver, exactly which one did you install?

I haven't used a driver yet
I tried to use one from.github but it doesn't support Manjaros Kernel

Follow @tbg's request below before following this post. It is a good point made.

A dkms driver is available from AUR.

As these AUR dkms packages requires the kernel headers to be installed you need to install the headers for your kernel manually. Your kernel can be found with

$ uname -r

In this example the kernel is 4.19 so install the headers for the kernel with

sudo pacman -Syu linux419-headers

When the headers are installed install the dkms package for the 8723be

pamac build rtlwifi_new-dkms

Please do an lsmod and post it before you install any other drivers. I need to compare the module names to see if the kernel module needs blacklisting after the install. Most dkms drivers from the AUR automatically install the correct blacklist (but some do not). That is why I will need to compare a before and after output of:

lsmod | grep 8723

The realtek dkms driver modules are sometimes named differently than the kernel modules, so I will need to know both to be sure if blacklisting is required.

1 Like

That driver is marked as outdated (I believe). If you try that driver and it does not work, then try this driver instead:


This card often does not work well even with the AUR drivers.

Had to reinstall trying that

Right, I reinstalled and the original issues are fixed but it's a bit slow

You are being as clear as mud. Reinstalled what? Did you totally reinstall Manjaro? If so, why? Did you reinstall the drivers? If so, which drivers?

Did you run the lsmod and all the other commands I asked you to run? If so, why did you not post them?

Did you install the newer kernels as I recommended?

All you have given us on your thread is more questions and zero information. Wifi issues can not be troubleshot without you providing proper information. If you can not provide proper information when requested, do not expect anyone to waste time and effort helping you.

Please post the input/outputs of all requested commands.

Information on how to post hardware specs and logs on the forum:

Reinstall Manjaro as trying to install the WiFi card broke WiFi support cometely. Thankfully I was able to flash an old usb with the latest version of Manjaro with the new kernel which fixes the original issue but now it's slower than normal

You do not listen to anything that has been posted. Simply installing the newer kernels may have been enough to improve reliability on the kernel modules. That was my very first recommendation.

Why on Gods green earth did you think a full reinstall of Manjaro was required. Simply uninstalling the drivers should have been sufficient. If you'd used your phone to ask advice and performed the lsmod I requested you would have been able to give me some useful information to fix your drivers. All you probably needed to do to fix things up was blacklist the kernel module. But without running the commands, or posting the info I requested that was obviously impossible.

Hopefully the next person who happens along to help you will get more cooperation from you. I've had to implement a three strikes rule for people who do not provide outputs when requested as it becomes too frustrating trying to help someone who can not follow instructions.

Good luck getting your wifi issue resolved.

Forum kindly sponsored by