RTL8723DE - WiFi connection is not working

IMG_20200724_120639
WiFi option is not showing just fresh installed manjaro kde

'''[krushi21@Manjaro ~]$ inxi --full --verbosity=7 --filter --no-host
System:    Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Desktop: KDE Plasma 5.19.3 tk: Qt 5.15.0 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 15-da0xxx v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 84A7 v: 80.31 serial: <filter> UEFI: Insyde v: F.07 date: 11/21/2018 
Battery:   ID-1: BAT1 charge: 24.9 Wh condition: 40.1/41.0 Wh (98%) volts: 11.9/11.4 model: Hewlett-Packard PABAS0241231 
           type: Li-ion serial: <filter> status: Unknown 
Memory:    RAM: total: 7.69 GiB used: 571.8 MiB (7.3%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 6144 KiB 
           bogomips: 28808 
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
           clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
           flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
           invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
           pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
           smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
           vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Device-2: NVIDIA GM108M [GeForce MX110] vendor: Hewlett-Packard driver: nouveau v: kernel bus ID: 01:00.0 
           chip ID: 10de:174e 
           Display: x11 server: X.Org 1.20.8 driver: intel,nouveau unloaded: modesetting alternate: fbdev,nv,vesa 
           compositor: kwin_x11 resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.3 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel 
           port: 4000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter vendor: Hewlett-Packard driver: N/A port: 3000 bus ID: 03:00.0 
           chip ID: 10ec:d723 
           Device-3: Realtek 802.11n WLAN Adapter type: USB driver: btusb bus ID: 1-6:3 chip ID: 0bda:b009 serial: <filter> 
           IF-ID-1: enp0s20f0u2 state: unknown speed: N/A duplex: N/A mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: dynamic noprefixroute scope: global 
           IP v6: <filter> type: noprefixroute scope: link 
           WAN IP: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 9.06 GiB (1.0%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: RSM7 scheme: GPT 
           Optical-1: /dev/sr0 vendor: hp model: DVDRW DA8AESH rev: XH6M dev-links: cdrom 
           Features: speed: 24 multisession: yes audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r state: running 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 6060 bus ID: 00:17.0 
           chip ID: 8086.282a rev: 21 
Partition: ID-1: / size: 294.75 GiB used: 9.05 GiB (3.1%) fs: ext4 dev: /dev/sda2 label: N/A 
           uuid: db803222-7ae6-4105-a3a5-dd5f4a0ec747 
           ID-2: /boot/efi size: 96.0 MiB used: 9.8 MiB (10.2%) fs: vfat dev: /dev/sda1 label: N/A uuid: E2BB-6AE0 
Unmounted: ID-1: /dev/sda5 size: 2.03 GiB fs: vfat label: N/A uuid: 3955-4090 
           ID-2: /dev/sda6 size: 627.56 GiB fs: ntfs label: New Volume uuid: 01D64C6393879D60 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-2:5 info: Xiaomi Mi/Redmi series (RNDIS) type: Bluetooth,CDC-Data driver: rndis_host interfaces: 2 
           rev: 2.0 speed: 480 Mb/s chip ID: 2717:ff80 serial: <filter> 
           Device-2: 1-5:2 info: Quanta HP TrueVision HD Camera type: Video driver: uvcvideo interfaces: 2 rev: 2.0 
           speed: 480 Mb/s chip ID: 0408:5362 
           Device-3: 1-6:3 info: Realtek 802.11n WLAN Adapter type: Bluetooth driver: btusb interfaces: 2 rev: 1.1 
           speed: 12 Mb/s chip ID: 0bda:b009 serial: <filter> 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
Sensors:   System Temperatures: cpu: 43.0 C mobo: 29.8 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 205 Uptime: 5m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 running in: konsole 
           inxi: 3.0.37 
'''

Screencaps/pics are not preferred on technical help requests:

Provide more background info.

Did your wifi break after an update?

Did you just perform a fresh install?

(Thanks for adding required info to your OP)

I hope you don't mind, I have edited your title to be more informative for others.

1 Like

no, i second time installing manajro and same wifi issue happen i think issue with drivers or something

its fresh install

Read these search results for instructions on how to install the RTL8723DE driver:

https://archived.forum.manjaro.org/search?q=Install%20Rtl8723de%20driver%20in%3Asolved%20order%3Alatest

Start with the most recent thread.

Most recent working instructions:


Install the RTL8723DE driver:

Use either an Ethernet connection or USB Android phone tethering to install the required packages and driver.

Install the linux-headers for all currently installed kernels, (command courtesy of @dalto):

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ') 

Install other required dependencies:

sudo pacman -Syyu dkms git base-devel

Then install the RTL8723DE driver:

git clone https://github.com/smlinux/rtl8723de
sudo dkms add ./rtl8723de
sudo dkms autoinstall
sudo depmod -a
sudo mkinitcpio -P

Reboot.



2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by