RTL8723DE - Wifi Driver Installation

Before anything, thanks for reading this and helping!

Today i installed Manjaro Live on my HP Laptop knowing that the Wifi driver doesn't work natively, before doing the installation I checked several web pages with guides to install the driver. (RTL8723DE) so I tried it from the LIVE USB without success, so I assumed it would be because it is not installed properly, so I installed it and it did not have that error but it could not do it for another error either.

I add the link of the guide I used here:

RTL8723DE - How to install Wifi driver

The error is the following:

Error! Bad return status for module build on kernel: 5.6.16-1-MANJARO (x86_64)

UPDATE: I copied the exact same error I have, to avoid confusion in the kernel version

The reason why I make this post is because there are other users with the same error, I don't know if they solved it, but none of the solutions that the users proposed worked for me.

I need to use linux on my laptop and I have not found any linux distro where the wifi works natively, I really like Manjaro :(

I'll leave some details in case they can help:

  • I tried to install the driver as soon as I installed Manjaro, after it did not work with the same error I proceeded to update everything that could be updated with the system tool, it did not work the same way (I did this because I read that someone from the forum helped update the system).

  • I followed the installation steps to the letter, updated the headers and everything essential.

  • The bluetooth controller works, the Ethernet too.

  • I also tried "uninstalling" the driver and reinstalling, it is in quotes because it was never installed, I only managed to get it out of the list of dkms, after a reboot I tried again and nothing.

  • I accept any solution, seriously. I need to run my laptop with linux, if i have to reinstall or download another .iso i will, i just want the wifi to work.

Thanks for reading, I hope you can help me :frowning:

Hello,
Mind you but that kernel is EOL (End Of Life)
Install another kernel, for example 5.6 or the LTS 5.4, and do the steps in the tutorial again.

5.6 is EOL as well - so 5.7 is the one to go with.

Often Realtek Wifi drivers will not be supported for quite some time on the newest kernel. I would suggest installing kernel 5.4 and then repeat the install procedure on kernel 5.4.

If kernel 5.4 will not work with the smlinux driver then I would install kernel 4.19 and repeat the install procedure one more time. Always keep at least 2 kernels installed for an extra safety factor on Manjaro.

Please post:

inxi -Fxxxza

Edit:

See revised instructions linked below:

Hello! Thanks for the answers, how can i install that Kernel? Sorry, i'm pretty noob on Linux.

Edit: I'm using 5.6.16-1

I'm using 5.6 and it's not working :confused:

inxi -Fxxxza

System:
  Host: laptop-gonzalo Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=2b0160fd-2920-412a-92e2-9d713b882ea0 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 14-cm0xxx v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 84A0 v: 83.44 serial: <filter> UEFI: AMI v: F.53 
  date: 12/27/2019 
Battery:
  ID-1: BAT0 charge: 31.3 Wh condition: 40.5/40.5 Wh (100%) volts: 12.0/11.6 
  model: Hewlett-Packard Primary type: Li-ion serial: <filter> 
  status: Discharging 
CPU:
  Topology: Dual Core model: AMD A4-9125 RADEON R3 4 COMPUTE CORES 2C+2G 
  bits: 64 type: MCP arch: Excavator family: 15 (21) model-id: 70 (112) 
  stepping: N/A microcode: 6006705 L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 9184 
  Speed: 1296 MHz min/max: 1300/2300 MHz boost: enabled Core speeds (MHz): 
  1: 1565 2: 1364 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard 
  driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
  Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.36.0 5.6.16-1-MANJARO LLVM 10.0.0) 
  v: 4.5 Mesa 20.0.7 direct render: Yes 
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:15b3 
  Device-2: AMD Family 15h Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
  Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter 
  vendor: Hewlett-Packard driver: N/A port: d000 bus ID: 03:00.0 
  chip ID: 10ec:d723 
Drives:
  Local Storage: total: 465.76 GiB used: 7.26 GiB (1.6%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1C scheme: GPT 
Partition:
  ID-1: / raw size: 213.03 GiB size: 208.68 GiB (97.96%) 
  used: 7.24 GiB (3.5%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 43.0 C mobo: 0.0 C gpu: amdgpu temp: 43 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 162 Uptime: 10m Memory: 3.73 GiB used: 1.26 GiB (33.8%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 
  running in: xfce4-terminal inxi: 3.0.37

Install kernel 5.4:

sudo mhwd-kernel -i linux54

Tried with 5.4 and doesn't work, i'm trying with 4.19.

What errors did you receive?

The same :confused:

Error! Bad return status for module build on kernel: 5.4.44-1-MANJARO (x86_64)

Have you installed kernel headers? You should. sudo pacman -S linux54-headers

Yeah, i'm using the Manjaro Qt Client that automatically install the headers! :slight_smile:

Try:

sudo pacman -S $(pacman -Qsq "^linux" | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ') 
git clone https://github.com/smlinux/rtl8723de
sudo dkms add ./rtl8723de
sudo dkms autoinstall

On kernel 4.19, 5.4 or 5.6

Today I missed that package, then I got same error.

Also you can try 4.19 kernel. Worked for me either.

I tried 4.19 and it works perfectly! thanks to the community!

Special thanks to tbg!

2 Likes

Both of these statements are totally ambiguous. If you want to be helpful on technical support threads you must give clear concise directions, commands, outputs, etc.

Not vague generalizations.

Thanks for your criticism. I’ve just told about my experience and hoped that they will work. I won’t try again :slight_smile:

Sorry, but you need to be clearer if you wish to be helpful. My apologies.

1 Like

One last thing, if i boot on the 5.6 the wifi will work or i need to boot in 4.19 everytime? And if so, how do I make it default to boot in 4.19?

Forum kindly sponsored by