RTL8821CE - WiFi for HP Pavilion

I am new in Linux and in Manjaro in particular.

I am looking to find the driver for my adapter RTL8821CE but all the the forums I found, cannot show me how to get this driver now.

Please help me install this driver. Thanks.

Plenty of threads about this particular adapter:


Have a read through those first, then post back with what you have tried and what didn't work.


I apologize.. Here is the result..

System: Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=cad1f469-fc7c-4ce0-9171-e4d854ed3b84 rw
quiet apparmor=1 security=apparmor udev.log_priority=3
Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0
Distro: Manjaro Linux
Machine: Type: Convertible System: HP product: HP Pavilion x360 Convertible 11m-ap0xxx
v: Type1ProductConfigId serial: Chassis: type: 31 serial:
Mobo: HP model: 85CA v: 26.19 serial: UEFI: Insyde v: F.02 date: 05/07/2019
Battery: ID-1: BAT0 charge: 17.4 Wh condition: 37.6/37.6 Wh (100%) volts: 7.6/7.6
model: 333-1C-3D-A PO02037XL type: Li-ion serial: status: Discharging
Device-1: hid-0018:04F3:2420.0002-battery model: ELAN0732:00 04F3:2420 serial: N/A charge: N/A
status: N/A
CPU: Topology: Quad Core model: Intel Pentium Silver N5000 bits: 64 type: MCP arch: Goldmont Plus
family: 6 model-id: 7A (122) stepping: 1 microcode: 2E L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8756
Speed: 1194 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1174 2: 1121 3: 1171 4: 1104
Vulnerabilities: Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Graphics: Device-1: Intel UHD Graphics 605 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:3184
Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 605 (Geminilake) v: 4.5 Mesa 19.1.5 compat-v: 3.0
direct render: Yes
Audio: Device-1: Intel vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:0e.0
chip ID: 8086:3198
Sound Server: ALSA v: k5.2.11-1-MANJARO
Network: Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard
driver: N/A port: 1000 bus ID: 02:00.0 chip ID: 10ec:c821
Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a bus ID: 2-2:4
chip ID: 0b95:1790 serial:
IF: enp0s21f0u2 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 119.24 GiB used: 6.52 GiB (5.5%)
ID-1: /dev/sda vendor: LITE-ON model: CV8-8E128-HP size: 119.24 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s serial: rev: V881 scheme: MBR
Partition: ID-1: / raw size: 40.14 GiB size: 39.26 GiB (97.81%) used: 6.40 GiB (16.3%) fs: ext4 dev: /dev/sda1
ID-2: /home raw size: 40.04 GiB size: 39.16 GiB (97.81%) used: 125.6 MiB (0.3%) fs: ext4
dev: /dev/sda3
Sensors: System Temperatures: cpu: 42.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 168 Uptime: 4h 54m Memory: 3.43 GiB used: 1.15 GiB (33.6%) Init: systemd v: 242
Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 running in: xfce4-terminal inxi: 3.0.36

I followed all the forums on this -- Realtek rtl8821ce 802.11ac WIFI PROBLEM

They all don't work. looks like they are all outdated.

Nope. You didn't read them properly.

Install base-devel, headers for your kernel, and then the AUR package listed in the above thread.

It worked three days ago so that's definitely not "outdated".

Where's that AUR package and how to get that?

I still don't get how to install the driver. Anyone can help?

Assuming"help" means "give me the commands",

sudo pacman -S base-devel linux??-headers yay
yay -S rtl8821ce-dkms-git

where ?? are the numbers for your running kernel (e.g. 419 or 52 or...)

1 Like

That's right. I need the exact commands. As I have said, I am very new here. Before I could learn further, I need to get this thing work first.

I am running these now.. I will let you know how it goes.
sudo pacman -S base-devel linux53-headers yay
yay -S rtl8821ce-dkms-git

I get this message when running the yay...

(1/2) Install DKMS modules
==> dkms install rtl8821ce/1.0.5.r65.g55b90f4 -k 5.2.11-1-MANJARO
==> Unable to install module rtl8821ce/1.0.5.r65.g55b90f4 for kernel 5.3.0-1-MANJARO: Missing kernel modules tree.
(2/2) Arming ConditionNeedsUpdate...
==> Found git repo: github.com/tomaspinho/rtl8821ce.git

how do I get this fixed?

looks like I got it working. I will test further and will let you know.

These works in my case:
sudo pacman -S linux52-headers /* re-installed the header /
sudo pacman -S base-devel linux52-headers yay
yay -S rtl8821ce-dkms-git
reboot /
after reboot the wifi works */

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by