RTL8822BE Wifi

Hello, I have a Lenovo laptop with the RTP8822BE Wifi chip and I cannot get it to load/start. It is installed but it will not. I have secured boot turned off and there are no wifi options in the BIOS.

Thanks for any suggestions.

Host: jeffrey-pc Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc
v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux
Type: Laptop System: LENOVO product: 81LD v: Lenovo Legion Y7000P
Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial:
UEFI: LENOVO v: 9PCN15WW date: 07/17/2018
ID-1: BAT0 charge: 52.5 Wh condition: 53.0/52.5 Wh (101%)
model: LGC L17L3PG1 status: Unknown
Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP
arch: Kaby Lake rev: A L2 cache: 8192 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36872
Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 801 7: 800 8: 800
Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A
bus ID: 01:00.0
Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2)
v: 4.5 Mesa 18.3.1 direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k4.19.13-1-MANJARO
Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: Lenovo
driver: r8822be v: kernel port: 4000 bus ID: 07:00.0
IF: wlp7s0 state: down mac: 06:51:84:ba:9f:cc
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8168 v: 8.045.08-NAPI port: 3000 bus ID: 08:00.0
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: e8:6a:64:12:ff:61
Local Storage: total: 1.03 TiB used: 19.57 GiB (1.9%)
ID-1: /dev/nvme0n1 model: RPFTJ128PDD2EWX size: 119.24 GiB
ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB
ID-1: / size: 107.92 GiB used: 19.55 GiB (18.1%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: swap-1 size: 8.80 GiB used: 17.0 MiB (0.2%) fs: swap
dev: /dev/nvme0n1p3
System Temperatures: cpu: 53.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 217 Uptime: 9h 35m Memory: 7.67 GiB used: 1.98 GiB (25.9%)
Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28

1 Like

Ok. I’ve solved it. How stupid:
I re-read the web and found sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop" here: https://askubuntu.com/questions/893384/wifi-doesnt-work-on-fresh-ubuntu-16-04
So first I thought that’s exactly what I’ve already tried via nano but then “whatever, might as well do it again”. Voila, that’s it. The -ideapad addition made the difference.
Cheers, and sorry for taking up your time.

in the future, place 3 backticks ``` above and below terminal output so it's formatted properly and easier to read. also, did you search for solutions before creating this thread?

disclaimer: if i sound like im being a condescending arse, it's not intentional. shoveling snow and a bad cold has left me a bitter grouchy man today. :cold_face:


Yes, I did search in Manjaro and through Google but found nothing that worked across the board.

It is working now...THANK YOU

1 Like

no problem, glad to hear it worked out. i think you'll find that most issues you might come across are easily solved with a quick forum search. searching the manjaro wiki/forum for manjaro solutions will save you alot of time, and then there is the arch wiki which is great and very informative. when those dont net me results, then i start messing with search engines.
add the word "arch" to any web search for solutions and you usually end up with one or at least the right road to continue down to get it fixed.

1 Like

Forum kindly sponsored by