Rufus doesn't work with Manjaro ISOs

ImageWriter and Rufus are recommended for making a bootable USB
https://wiki.manjaro.org/index.php/Burn_an_ISO_File#Writing_to_a_USB_Stick_in_Windows

Why do peeps keep having problems with such a simple program as Rufus. When I got my roommate to install Manjaro along side Windows 10 he used Rufus to create his Live Key without issue. Booted to it and installed Manjaro in dual boot without issue. Now that said you can get Etcher for windows besides for Linux.

We have to update our wiki. Currently we recommend to use Etcher:

2 Likes

Nobody knows anything until they do.

Posts like this arent helpful.

2 Likes

Anyway I have had the exact same set of problems with Rufus and Etcher. It doesn't seem it is a problem caused by them tho

Thanks for correcting me @philm

Do you have multiple partitions in the flash drive?

Yes, there are 2. Booting to the first one leads me to the screen where I can select Manjaro. I don't remember what the second one did, but it was not important

Reformat the flash drive to one partition then try etcher. I haven’t used that yet but @philm recommends that. I know I’ve had issues in the past booting off of flash drives with multiple partitions. Having two partitions shouldn’t matter, but give that a try. I successfully used Manjaro with Rufus two weeks ago. I could look up the version of Rufus and Manjaro later then report back later. Sadly I’m at work but I just installed AnyDesk on Manjaro. I’ll try to remote into my windows machine where I made the bootable flash drive and get that info to you.

Did that but still no luck :worried: I didn't really think it would make much of a difference since the programs themselves (Rufus or Etcher) partition the USB

Can't speak to MBR but if you're key is setup for a GPT / EFI / UEFI Live Key you will have two partition and free space at the end of the Flash drive. Using Etcher on a 16 gig Flash drive I have:

MJRO190P partition 1 3.0 GB
MISO_EFI partition 2 4.2 MB Fat
Free space 13 GB

Do you use USB3 for all this ?

OK, I was able to remote into my windows machine(From my iPhone, AnyDesk is nice, but it's annoying navigating around my Windows 10 machine on a phone).

I was using Rufus 3.8 and tested manjaro-kde-18.1.5-191229-linux54.iso and manjaro-kde-18.1.5-minimal-191229-linux54.iso both succesfully two weeks ago.

This is where I downloaded Rufus from. It is still showing version 3.8 on the site.
This is where I downloaded the ISO's from. Still showing 18.1.5

If this doesn't work, I would suggest Etcher then. I'll play around with Etcher tonight to see how it runs.

Edit: I looked a little more closely at your screenshots. You have the exact same thing I had, not sure why it suddenly doesn’t work for you. Everyone is mentioning DD but I’m running across that.

Edit: check out this response to a recent post with a similar but slightly different issue. I actually made a few changes in my BIOS and disable fast startup in windows.

EDIT: You could also try an older version of Manjaro which is located on the Manjaro SourceForge page here. If it works, you run updates on it so it becomes the latest version. Looks like it hasn't been maintained in a while or is no longer used.

EDIT: Here is an ISO created for machines having a hard time booting mainline Manjaro ISOs. WARNING, I've never tried this ISO, but it has been recommended by @philm in the past.

I just had a thought.

Has anyone looked into U3 Flash Drives and Non-U3 Flash Drives potentially being the issue? I just realized that all I have is U3 flash drives and they are design to work better with ISO 9660. I'll attach a picture of them later on. They are a bunch of Dell recovery Flash Drives that would get thrown out, I managed to keep about 10 of them.

I'm certainly not going to claim this is the fix, but I think it's worth looking into.

image

I'm assuming by U3 you mean USB 3.0? If so as long as you motherboards excepts booting from USB 3.0 as well as 2.0 other than the Flash drive being bad there should be on issue. A flash drive is a flash drive. I've never know one to work better with a particular ISO type.

No, I'm not referring to USB 3.0.
I've been using the same Rufus version and Manjaro ISO's as the user and have no problems. I'm wondering if it's my USB sticks.

I'm looking for any information that may validate or invalidate my theory that certain flash drives with either different controllers, firmware, or something, maybe causing problems with the ISO's being burned by RUFUS and other programs. So far it's just a theory.

There is a link in my above comment to U3 software, but that seems to be for SanDisk. So I think that is a dead end.

it very well could be the specific stics. i have a couple that i can store files on but cannot use for boot media. i have also seen this behaviour with hdd's.

U should write with DD Image Option, u can work with that.

Later as a side project, I'm going to find some software that can read the firmware on sticks and drives, and start a new topic, and see if we notice a pattern.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by