Running dedicated GPU Card in my laptop

There's plenty of those topics, but none of them is solution for my problem.

I have both Intel and GeForce GTX 1050 in my laptop. I tried to change bumblee for nvidia-390xx to run only on NVidia card however it didn't work as expected. Then I deleted it and get Pointer to TMDS table invalid (It's probably because nouveau drivers are not supporting my GPU). With liveUSB I reverted those with mhwd-chroot and then I lost access to nvidia-settings.

Can someone help with making dedicated GPU working as expected (f.e. in Steam Games)?

I'm not professional but U can change your kernel from chroot. Give it a try !

Changing kernels isn't a solution to my problem

If U can change your kernel, bumblebee doenst work and you can login your entire system :confused:

Edit: Sorry, I wont read end of your post :sob:

Have you tried this guide ?

Well what I want is Bumblebee running my dedicated GPU. And to know if that's possible?

Of course it is possible! But Im using prime method so I dont know what U shall do.

Can you give us output of :

inxi -Fx
sudo mhwd -l
xrandr --listprovider

mhwd -li

> 0000:01:00.0 (0302:10de:1c8d) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
          video-nvidia            2018.08.09               false            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI


> 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI


inxi -G

Graphics:  Device-1: Intel driver: i915 v: kernel 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.20.1 driver: intel unloaded: nvidia 
           resolution: 960x540~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
           v: 4.5 Mesa 18.2.1 

xrandr --listproviders

Providers: number : 1
Provider 0: id: 0x48 cap: 0xb, Source Output, Sink Output, Sink Offload crtcs: 4 outputs: 5 associated providers: 0 name:Intel

Are you sure of this? All these installed? I doubt it..
Install auto non-free.
Why use 390 when you can run the latest?

Ok I reinstalled system and have latest auto drivers still got problems

Heeey ! I have good new :slight_smile:

I broke my system for understand to bumblebee! Anyways I can handle it now :stuck_out_tongue:

Just read and fallow this post : Can't boot to manjaro after installing NVIDIA drivers

If U stuck at any point tell me :blush:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by