Ryzen 7 with GTX1660Ti driver problem (black screen before login)

Hello All,

I bought a new laptop with discrete graphics. The laptop is Asus FX705DU.

Spec:

  • NVIDIA GTX1660Ti
  • AMD Ryzen R7-3750H

I have read various articles on the internet as well as in this forum but I can't find a solution.

I tried to install driver over terminal and Hardware Configuration GUI. When I activate the proprietary driver (Auto install proprietary driver), after restart the system does not come to the login screen.

Video

The login screen works when I login in text mode and delete proprietary driver (returning it to open source).

DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=18.1.1
DISTRIB_CODENAME=Juhraya
DISTRIB_DESCRIPTION="Manjaro Linux"

5.2.21-1-MANJARO

0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:


              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2016.04.20                true            PCI

0000:01:00.0 (0300:10de:2191) Display controller nVidia Corporation:


              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-435xx            2019.08.25               false            PCI
video-nvidia-430xx            2019.08.25               false            PCI
video-nvidia-418xx            2019.08.24               false            PCI
       video-linux            2018.05.04                true            PCI
        video-vesa            2017.03.12                true            PCI

0000:05:00.0 (0300:1002:15d8) Display controller ATI Technologies Inc:


              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
        video-vesa            2017.03.12                true            PCI

Thank you.

Hullo,
For one thing you have multiple nvidia drivers installed and also vesa.. remove all that besides the latest nvidia then when you boot give this:

inxi -Fxxxza --no-host

Here is dump:

http://oneclickpaste.com/200415/

If the report is for installed and not all... :stuck_out_tongue_winking_eye:
Mixed reporting. I guess vesa and video-linux is installed.:slightly_smiling_face:

Do I need to remove all other drivers and left only Nvidia?

you do have nvidia drivers installed, your inxi output shows your using nvidia. check mhwd -li to see which packages are actually installed.

you have dual graphics, your cpu has an iGPU and you also have the nvidia dGPU. right now as you have it only your hdmi/dp will output video. for the laptop screen to work you would need a PRIME setup or since you have a turing class nvidia gpu you could use the new render offloading feature but external monitors wont work.

auto installing proprietary drivers wont work for your setup, you need the nvidia gpu to offload to the amd gpu for you to have display output. if you want a desktop to work from while you set it up you can auto-install the free drivers and reboot and from there you can setup whichever configuration you go with.

sudo mhwd -a pci free 0300

No it doesnt .. it shows the nvidia driver as 'n/a' and the amd card as using amdgpu.

Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 chip ID: 10de:2191
Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel
bus ID: 05:00.0 chip ID: 1002:15d8

(the rest of the info is pretty good though :wink:)

also .. just mentioning .. at some point OP may want to ditch the EOL 5.2 driver and probably try to track latest ... 5.3, then 5.4 (LTS?) when its out.

You have a hybrid graphics system: (Radeon RX Vega 10 + Nvidia GTX 1660Ti 6GB 80W)
According to your first post you have only the video-linux and video-vesa installed for both devices.
Unfortunately, I'm not sure how to configure such a combination.

Typically, the on chip device is used for primary display, while the secondary adaptor can be switched to for gaming, etc.

Reference: https://www.ultrabookreview.com/28095-asus-tuf-fx705du-review

Display: x11 server: X.org 1.20.5 driver: nvidia

i dont know whats going on with the n/a but xorg is running on the nvidia driver. if it's setup as prime it would be either modesetting, nvidia or amdgpu, nvidia . both modesetting and amdgpu support offloading it's just a matter of using a working xorg configuration and a display setup script for xrandr

I was going by the original post, which has all nvidia drivers false, and doesn't even list radeon or amdgpu at all for the amd part.

However, afaik the vega 10 part would require the 5.x series of kernel, yes?

BTW, xorg settings wouldn't matter if your not getting a framebuffer from the kernel.
Just a thought. :wink:
This also wouldn't be the first time xorg was setup for nvidia even without the drivers installed.

That and someone earlier encouraged the use of sudo mhwd -a pci free 0300
Which could potentially cause such a mismatch.

good call, yeah AFAIK support for the ryzen 3000 cpu's started with 5.3 but i might be mixing that up with the support for the 5700XT.

either way, 5.2 is EOL so installing 5.3 would make sense anyway just in case.

i just went through this ryzen/nvidia setup on a similar model not even a week ago. that user went with using the render offload "feature" of the 435xx nvidia drivers but was convinced this setup would never work on linux but it does. IMO prime would be the better way to go or optimus-switch with a few edits to the configs to replace modesetting for amdgpu.

this is the ryzen/nvidia thread i was referring to
https://archived.forum.manjaro.org/t/solved-hybrid-amd-nvidia-set-up/

Hello everyone,

I went through all the steps from the URL that @dglt mentioned, now there is no black screen anymore. However, I cannot use the external monitor. I often use my computer by extending an monitor and a laptop screen.

Nvidia panel sees external monitor via HDMI but I have no changing option

Screenshot%20from%202019-10-30%2008-08-03

Screenshot%20from%202019-10-30%2008-09-31

How I can use prime setup? Is this tutorial howto-set-up-prime-with-nvidia-proprietary-driver can help me?

Thanks.

render offload doesnt work with external monitors according to nvidia.

yes, but with some changes since yours is an amd/nvidia setup rather than a intel/nvidia setup. post these outputs, use the </> button when pasting terminal output so its formatted properly

inxi -Fxxxza
mhwd -li
xrandr --listproviders
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf

Thank you for your time. Here is:

inxi -Fxxxza

System:    Host: human-pc Kernel: 5.2.21-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=777bb19f-8486-4552-a526-837090116e52 rw quiet 
           apparmor=1 security=apparmor resume=UUID=e4e7d12b-ca33-4ad0-9fe2-38422122b783 udev.log_priority=3 
           Desktop: Gnome 3.34.1 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX705DU_FX705DU v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX705DU v: 1.0 serial: <filter> UEFI [Legacy]: American Megatrends v: FX705DU.306 
           date: 07/12/2019 
Battery:   ID-1: BAT0 charge: 49.3 Wh condition: 63.5/67.2 Wh (94%) volts: 15.8/16.6 model: FX70542 type: Li-ion 
           serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP arch: Zen+ 
           family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108102 L2 cache: 2048 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 36749 
           Speed: 1264 MHz min/max: 1400/2300 MHz boost: enabled Core speeds (MHz): 1: 1307 2: 1249 3: 1222 4: 1221 
           5: 1221 6: 1222 7: 1222 8: 1222 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: ASUSTeK driver: nvidia v: 440.26 
           bus ID: 01:00.0 chip ID: 10de:2191 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 05:00.0 
           chip ID: 1002:15d8 
           Display: x11 server: X.org 1.20.5 driver: amdgpu,nvidia compositor: gnome-shell 
           resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.21-1-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.2.2 direct render: Yes 
Audio:     Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:1aeb 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 05:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.2.21-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel 
           port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek vendor: AzureWave driver: rtw_pci v: N/A port: d000 bus ID: 04:00.0 chip ID: 10ec:c822 
           IF: wlp4s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 8.87 GiB (0.8%) 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN520 SDAPNUW-256G-1002 size: 238.47 GiB block size: 
           physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> rev: 20110000 scheme: MBR 
           ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0J scheme: MBR 
Partition: ID-1: / raw size: 125.09 GiB size: 122.63 GiB (98.03%) used: 8.87 GiB (7.2%) fs: ext4 dev: /dev/nvme0n1p4 
           ID-2: swap-1 size: 15.72 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) 
           cache pressure: 100 (default) dev: /dev/nvme0n1p2 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 41 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 251 Uptime: 7m Memory: 15.16 GiB used: 1.27 GiB (8.4%) Init: systemd v: 242 Compilers: gcc: N/A 
           Shell: bash v: 5.0.11 running in: gnome-terminal inxi: 3.0.36 

mhwd -li

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
    video-nvidia-440xx            2019.10.25               false            PCI
           video-linux            2018.05.04                true            PCI


xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x1ed cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4 outputs: 1 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
Provider 1: id: 0x1b8 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
/etc/X11:
total 32
drwxr-xr-x  5 root root 4096 Sep 11 14:06 .
drwxr-xr-x 99 root root 4096 Oct 31 23:08 ..
drwxr-xr-x  2 root root 4096 Oct 29 20:20 mhwd.d
drwxr-xr-x  3 root root 4096 Sep 11 14:07 xinit
drwxr-xr-x  2 root root 4096 Oct 29 20:36 xorg.conf.d

/etc/X11/mhwd.d:
total 16
drwxr-xr-x 2 root root 4096 Oct 29 20:20 .
drwxr-xr-x 5 root root 4096 Sep 11 14:06 ..
-rw-r--r-- 1 root root 1458 Oct 29 20:20 nvidia.conf
-rw-r--r-- 1 root root    0 Oct 29 20:20 nvidia.conf.nvidia-xconfig-original

/etc/X11/xinit:
total 28
drwxr-xr-x 3 root root 4096 Sep 11 14:07 .
drwxr-xr-x 5 root root 4096 Sep 11 14:06 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Oct 29 20:04 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

/etc/X11/xinit/xinitrc.d:
total 20
drwxr-xr-x 2 root root 4096 Oct 29 20:04 .
drwxr-xr-x 3 root root 4096 Sep 11 14:07 ..
-rwxr-xr-x 1 root root  318 Nov  9  2018 40-libcanberra-gtk-module.sh
-rwxr-xr-x 1 root root  203 Oct 21 11:27 50-systemd-user.sh

/etc/X11/xorg.conf.d:
total 24
drwxr-xr-x 2 root root 4096 Oct 29 20:36 .
drwxr-xr-x 5 root root 4096 Sep 11 14:06 ..
-rw-r--r-- 1 root root  266 Oct 29 19:41 00-keyboard.conf
-rw-r--r-- 1 root root  479 Oct 29 20:36 90-mhwd.conf
-rw-r--r-- 1 root root  555 Oct 29 20:25 99-amd-nvidia-prime-offload.conf

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
EndSection
Section "ServerLayout"
  Identifier "layout"
  Option "AllowNVIDIAGPUScreens"
  Screen 0 "iGPU"
EndSection

Section "Device"
  Identifier "iGPU"
  Driver "amdgpu"
  Option "DRI" "3"
EndSection

Section "DRI"
    Group "video"
    Mode 0666
EndSection

Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER" "Enable"
EndSection

Section "Screen"
  Identifier "iGPU"
  Device "iGPU"
EndSection

Section "Device"
  Identifier "nvidia"
  Driver "nvidia"
EndSection
Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
EndSection

Section "Device"
	Identifier "AMDGPU"
	Driver "amdgpu"
	Option "TearFree" "true"
EndSection

Section "OutputClass"
	Identifier "iGPU"
	MatchDriver "amdgpu"
	Driver "modesetting"
EndSection

Section "Device"
	Identifier "nvidia"
  Driver "nvidia"
EndSection

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	ModulePath "/usr/lib/nvidia/xorg"
	ModulePath "/usr/lib/xorg/modules"
EndSection

ls -la /etc/modprobe.d ; cat /etc/modprobe.d/*.conf
total 16
drwxr-xr-x  2 root root 4096 Oct 29 20:16 .
drwxr-xr-x 99 root root 4096 Oct 31 23:08 ..
-rw-r--r--  1 root root  129 Oct 29 20:20 mhwd-gpu.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm

ls -la /etc/modules-load.d ; cat /etc/modules-load.d/*.conf
total 20
drwxr-xr-x  2 root root 4096 Oct 29 20:16 .
drwxr-xr-x 99 root root 4096 Oct 31 23:08 ..
-rw-r--r--  1 root root   76 Oct 29 20:20 mhwd-gpu.conf
-rw-r--r--  1 root root   34 Oct 21 23:08 modules.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
nvidia
nvidia-drm
# List of modules to load at boot

1 Like

if you want to try a prime setup, give this a go.

sudo mhwd -r pci video-linux
sudo rm /etc/X11/xorg.conf.d/90-mhwd.conf
sudo mv /etc/X11/xorg.conf.d/99-amd-nvidia-prime-offload.conf /etc/X11/xorg.conf.d/99-amd-nvidia-prime-offload.conf.bak
sudo rm /etc/modprobe.d/mhwd-gpu.conf

create this one
sudo nano /etc/X11/xorg.conf.d/99-nvidia.conf
copy/paste

#/etc/switch/nvidia/99-nvidia.conf
#adjust BusID to match your nvidia GPU
#uncomment and edit the DPI option as needed
#to fix scaling issues.


Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver  "nvidia"
    BusID   "PCI:1:0:0"
    #Option  "DPI" "96 x 96"    #adjust this value as needed to fix scaling
    Option  "AllowEmptyInitialConfiguration"
EndSection

Section "Extensions"
    Option  "Composite" "Enable"
EndSection

create this file
sudo nano /etc/modprobe.d/99-nvidia.conf
copy/paste

blacklist nouveau
blacklist nvidiafb
blacklist rivafb
options nvidia_drm modeset=1

create this file
sudo nano /usr/local/share/optimus.desktop
copy/paste

[Desktop Entry]
Type=Application
Name=Optimus
Exec=sh -c "xrandr --setprovideroutputsource 1 0; xrandr --auto"
NoDisplay=true
X-GNOME-Autostart-Phase=DisplayServer

then run these:

ln -s /usr/local/share/optimus.desktop /usr/share/gdm/greeter/autostart/optimus.desktop
ln -s /usr/local/share/optimus.desktop /etc/xdg/autostart/optimus.desktop

then reboot. if that fails to load to a desktop, edit that last fileoptimus.desktop and change 1 0 to 0 1 like this

Exec=sh -c "xrandr --setprovideroutputsource 0 1; xrandr --auto"

and reboot again. let me know how it goes

3 Likes

Yes, that solved the problem. Thank you very much.

If I figured out well, with these settings, the discrete graphic card is always active? it also means shorter battery life.

your welcome, glad it worked out. :+1:

with your previous setup (render offload) the nvidia gpu was on all the time too, even when the nvidia gpu is doing nothing it has to remain on because xorg needs to run on the nvidia, yet everything is rendered by the iGPU unless you launch something with the correct variable.

at least with prime you get external monitors, no launch variables, and actually get use of the battery life being wasted.

1 Like

Everything is working fine except now I have another problem.

How to fix screen tearing?

I have tearing both on internal display and on external over HDMI.

Please see these screenshots:

Screenshot_2020-01-15_18-14-59

Screenshot_2020-01-15_18-15-29

Thanks

what setup did you end up going with? prime? render-offload?

I am using prime.

Forum kindly sponsored by