Ryzen 7 with GTX1660Ti driver problem (black screen before login)

post new info, the tearing can be fixed with prime sync but im not sure how well, if at all it works with amd/nvidia setups.

inxi -Fxxxza
xrandr --prop

also, are you still using the configuration from the post marked as solved?

Graphics:  Card-1: NVIDIA Device 2191 bus-ID: 01:00.0 chip-ID: 10de:2191
           Card-2: Advanced Micro Devices [AMD/ATI] Picasso bus-ID: 05:00.0 chip-ID: 1002:15d8
           Display Server: x11 (X.Org 1.20.4 ) drivers: modesetting,nvidia Resolution: 1920x1080@60.05hz
           OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 version: 4.6.0 NVIDIA 435.21 Direct Render: Yes
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
	CscMatrix: 65536 0 0 0 0 65536 0 0 0 0 65536 0 
	BorderDimensions: 4 
		supported: 4
	Border: 0 0 0 0 
		range: (0, 65535)
	SignalFormat: TMDS 
		supported: TMDS
	ConnectorType: HDMI 
	ConnectorNumber: 0 
	_ConnectorLocation: 0 
	non-desktop: 0 
		supported: 0, 1
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
	EDID: 
		00ffffffffffff0006af9d4200000000
		111c0104a5261678039675a356529c27
		0c505400000001010101010101010101
		010101010101403880b470383e401010
		3e007ed710000018403880b470387a42
		10103e007ed710000018000000fe0041
		554f0a202020202020202020000000fe
		004231373348414e30342e32200a00c6
	PRIME Synchronization: 0 
		supported: 0, 1
	vrr_capable: 0 
		range: (0, 1)
	abm level: 0 
		range: (0, 4)
	max bpc: 8 
		range: (8, 16)
	underscan vborder: 0 
		range: (0, 128)
	underscan hborder: 0 
		range: (0, 128)
	underscan: off 
		supported: off, on, auto
	scaling mode: None 
		supported: None, Full, Center, Full aspect
	link-status: Good 
		supported: Good, Bad
	CONNECTOR_ID: 53 
		supported: 53
	non-desktop: 0 
		range: (0, 1)
   1920x1080     60.05*+  40.01  
   1680x1050     60.05  
   1280x1024     60.05  
   1440x900      60.05  
   1280x800      60.05  
   1280x720      60.05  
   1024x768      60.05  
   800x600       60.05  
   640x480       60.05

Thanks

Yes, I still using the configuration from the post marked as solved.

you can try using xrandr to enable prime sync but im not sure if it works with amd/nvidia hybrid graphics.

xrandr --output eDP-1-1 --set "PRIME Synchronization" 1

then check xrandr --prop to see if prime sync is enabled. if that fails you can see if your display supports variable refresh

xrandr --output eDP-1-1 --set "vrr_capable" 1

check xrandr --prop to see if its enabled

~$ xrandr --prop | grep PRIME
PRIME Synchronization: 0
~$ xrandr --prop | grep vrr_capable
vrr_capable: 1

PRIME Synchronization not working. Changed vrr_capable but problem is not solved :frowning:

i think you and anyone else using an amd/nvidia hybrid bring the issue to nvidia devtalk and see if there is support planned for making prime sync work with the amd card either through modesetting or amdgpu. especially since this setup seems to be getting more and more common

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by