samba: failed to retrieve share list from server

A new issue has sprung up on my computer. I am unaware of changes that may have caused it.
I have a samba network at home with a mix of linux (Manjaro/xfce) and Windows 7/10 (uhg) computers. Samba has always worked well to connect each to each other. But now, when in Thunar I enter, for example: smb://computer_name
I get an error: Failed to retrieve share list from server: Invalid argument
A few notes:

  1. My installs are up to date.
  2. If I enter the IP, for example: smb://10.0.0.19, it will respond correctly on some of my manjaro machines, but not others. Wierd.
  3. I have tried completely uninstalling samba (with pacman -Rn samba) and reinstalling, but no help.

I have tried googling and trying various things, but nothing has helped. So now I turn to the manjaro community for help.

I have Manjaro XFCE also. I noticed the same issue last night when my Kodi configured Raspberry PI could not connect to my main computer upstairs. I've also uninstalled samba and reinstalled with no luck. My upgrades are also up to date, so a recent one must have changed something. I'll be watching for replies as well.

In Thunar...Browse Network (network:///) I get the "Failed to retrieve share list from server: Invalid argument." From Samba (smb:///) I get 0 items found.

Tried downgrading network manager and wpa_supplicant found in another article, but that didn't help either.

Thanks for your posts. Same problem here, even after tried to reinstall latest manjaro-kde 19.0.2 and manjaro-gnome 19.0.2 and updates applied.

With the install liveusb, before installation and immediately after, everything is OK, I can access the SMB shares on my network. It seems that there is an update that breaks something. I'm going to be crazy with this. I tried to play with smb.conf, and if I change client min protocol to CORE or NT1, it partially resolve the problem.

Partially because now, access is OK but every file on the SMB share is seen as a folder ! Everything is fine on Windows clients and Ubuntu clients accessing to the same SMB share.

I'm having the same problem. File sharing was working until a recent update, not sure which one. Now I can only get the "Failed to retrieve share list from the server" error when trying to access the Manjaro shares. Has anyone figured this out?

Hi,

Have a look here, maybe it will solved the issue.

Thank you for the suggestion. Being a bit leary of the downgrade process I decided to use that as a last resort. Your link took me to some other threads that lead me to try this:

Add or edit these two lines in smb.conf global section to read like this:
client min protocol = CORE
server min protocol = CORE

That worked for making my shares visible and retrievable. I still had some issues accessing the shares. I had to make some changes to the share in smb.conf but, the error "Failed to retrieve share list from the server" was fixed with the change from above.

2 Likes

I've seen several solutions involving setting combinations of min and max client and server protocols, but I can't get the browsing from Thunar to work no matter what.

Trying to browse with smbclient...
smbclient -L <server_ip>
...fails with:

protocol negotiation failed: NT_STATUS_INVALID_PARAMETER_MIX

I find nothing on NT STATUS, except nt status support which doesn't quite tell me anything.

I realize however, that smbclient defaults to the highest possible protocol (SMB3_11 by the looks of it), and I figure if I do this in smb.conf...

client min protocol = SMB3
client max protocol = SMB3
server min protocol = SMB3
server max protocol = SMB3

... then the protocol should be locked down pretty good.
But still I get the same error from smbclient.

So I try...
smbclient -L <server_ip> --debuglevel 2
...and it tells me I have permission denied on a file:

rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
added interface wlp16s0 ip=<client_ip> bcast=<subnet broadcast> netmask=<subnet mask>
tdb(/var/cache/samba/gencache.tdb): tdb_open_ex: could not open file /var/cache/samba/gencache.tdb: Permission denied
tdb(/var/cache/samba/gencache.tdb): tdb_open_ex: could not open file /var/cache/samba/gencache.tdb: Permission denied
tdb(/var/cache/samba/gencache.tdb): tdb_open_ex: could not open file /var/cache/samba/gencache.tdb: Permission denied
protocol negotiation failed: NT_STATUS_INVALID_PARAMETER_MIX

Now, that file is readable, so I don't know what this is all about.

$ ls -la /var/cache/samba/gencache.tdb
-rw-r--r-- 1 root root 1,3M 11.04.2020 13:06 /var/cache/samba/gencache.tdb

What I do know, however is that...

smbclient -m SMB3 -L <server_ip>

...gives me a nice list of shares from the Samba server - even though -m SMB3 does nothing more than specify what is already the default.

And incidentally, with --debuglevel 2 I still get a permission error on that file, so it probably hasn't got anything to do with it (it's not recreated either if I delete it, though the error remains).

I think a fair conclusion from this is that something doesn't quite work with the protocol negotiation - and because some applications can browse, such as smbclient, but not others, such as Thunar, it must be related to how the applications do that negotiation.

I think Thunar (and gvfs) uses libsmbclient to browse Samba shares and, without reference, I think that library can't browse protocols higher than NT1, except I can't get that to work anymore.

There's an old bug report that gvfs can't browse shares that has disablet SMB1, although I know I used it with NT1.

So, uh.. all that didn't really get me anywhere (Thunar still complains about not being able to retrieve a share list from the server).

But maybe somebody more knowledgeable than me can get something more out of all this?

samcompton, You're suggestion worked partially for me. I added:
client min protocol = CORE
server min protocol = CORE
to my smb.conf global section and restarted.

Now I can browse my Kodi machine; however, it still can't connect to my Manjaro XFCE machine. I suspected that would be the case because on my Manjaro XFCE machine in Thunar...Browse network when I click on the Manjaro shares I still get "Failed to retrieve share list from server: Invalid argument."

What other changes did you make to your shares in smb.conf to get them to work?

Exactly the same with my machines. do yo have more information or an solution in the meantime ?

I restored my machine from an image I made last month. Browse network from Thunar worked great with shares after restore.

So I tried to installed all updates except samba and smbclient. Now broken again, so it is more than just these two packages breaking the shares.

I'm going to restore my image again and only upgrade what I need until this is fixed.

Sorry, ATM not any clue... I hope someone will help us...

The issue with SMBv1 has been known for - at least - half a decade and as such it should come as no surprise it would be deprecated or disabled.

Modify the smb.conf on the server in question and set

Samba v4

min protocol = SMB3_00

Samba v3

min protocol = SMB2

Then restart the server.

A nice explanation of the different options can be found here

Unfortunately, some use cases cannot let change the smb.conf.

In my situation, I must access a NAS located on an Internet Box (Freebox from a french ISP). It's impossible to change anything on the server side for samba settings.

You can force your connection with a local smb.conf (you may need to create the folder)

sudo mkdir /etc/samba
sudo nano /etc/samba/smb.conf
[Global]
  workgroup = WORKGROUP
  min protocol = SMB3
  # server min protocol = SMB3
  # client min protocol = SMB3
  smb encrypt = mandatory

...

I know that providers of such boxes are not overly concerned with their users - as long as they pay the bill.

From other topics I have seen that adding this to the [Global] section of your local smb.conf could solve the issue - I couldn't quite deduct if it was server or client

[Global]
  server min protocol = NT1
  client min protocol = NT1
...

Do you have a Windows 10 computer? Or do you have a friend with such device?

If you can connect to the box using a Windows 10 - then the samba used on the box supports v2 and v3 and you should be able to connect to it using the newer protocols.

According to my search results (ddg) Microsoft removed the SMBv1 from Windows back in late 2017 as a result of the WannaCry ransomware.

1 Like

Thank you for your help.

I've already found the

 client min protocol = NT1

on smb.conf on client side. I mentioned it in a previous post. With it, I solved the access to the share problem. But the files seen as directories remains.

Only this shi*** SMB1 can be handled by the Freebox revolution, confirmed with Windows 10 . It is possible to activate SMB1 in this windows version. With SMB1 activated, access to the share is possible. Without, it's not possible.

As I said before, other linux hosts on my network (Ubuntu) works well. I know that SMB1 is a piece of shi*, but ATM we need it.

That is logical - Ubuntu aims for stability and predictability- so changes to software hits Arch based distributions first.

A little workaround for those who are in a similar situation than me (only SMB1 on the server side with no possibility to change that).

Look if another share protocol is proposed. On my internet box, NFS is not available but it's possible to use AFP (Appletalk). I'm using it now from my Manjaro Gnome with Nautilus flawlessly.

It's probably a better way than downgrade smbclient (not tested).

Update, I restored from a image I made in March. Marked the following items not to upgrade and samba shares are working now with everything else upgraded. I found this list of files in a ArchLinux bug report.

warning: ldb: ignoring package upgrade (1:1.5.6-2 => 1:2.0.9-1)
warning: libwbclient: ignoring package upgrade (4.10.10-2 => 4.11.7-1)
warning: python: ignoring package upgrade (3.8.1-4 => 3.8.2-1)
warning: samba: ignoring package upgrade (4.10.10-2 => 4.11.7-1)
warning: smbclient: ignoring package upgrade (4.10.10-2 => 4.11.7-1)
warning: tdb: ignoring package upgrade (1.3.18-4 => 1.4.3-2)

Thank you for the suggestion. Being a bit leary of the downgrade process I decided to use that as a last resort. Your link took me to some other threads that lead me to try this:

Add or edit these two lines in smb.conf global section to read like this:
client min protocol = CORE
server min protocol = CORE

That worked for making my shares visible and retrievable. I still had some issues accessing the shares. I had to make some changes to the share in smb.conf but, the error "Failed to retrieve share list from the server" was fixed with the change from above.

I just wanted to add that this fixed my issue.

I run just a file share from my Manjaro box to two Raspberry Pi's with Kodi.

Suddenly lost connection to the shares. Did everything, even re-installed manjaro.

But adding these two lines to the smb.conf fixed it.

Thanks.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by