Samson Q2U USB mic records only static until unplugged and replugged

As stated in the title, any recordings made with the mic consist only of static until it is unplugged and then plugged back in. I have tried to note any differences in settings between the un/replugging, and have so far come up with little actionable information because I'm not sure what some of it means.

Here's the inxi information (post replug of the mic if that matters):

System:    Host: H0mebase Kernel: 5.5.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: i3 4.18 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: A68HM-E33 V2 (MS-7721) v: 9.0 serial: <root required> UEFI: American Megatrends 
           v: 8.0 date: 02/16/2015 
CPU:       Topology: Quad Core model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G bits: 64 type: MCP arch: Steamroller 
           rev: 1 L2 cache: 2048 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 29559 
           Speed: 1697 MHz min/max: 1700/3700 MHz Core speeds (MHz): 1: 1697 2: 1696 3: 1949 4: 2213 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Tonga PRO [Radeon R9 285/380] vendor: XFX Pine driver: amdgpu v: kernel 
           bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon R9 380 Series (TONGA DRM 3.36.0 5.5.16-1-MANJARO LLVM 9.0.1) v: 4.6 Mesa 20.0.4 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] FCH Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 
           Device-2: Advanced Micro Devices [AMD/ATI] Tonga HDMI Audio [Radeon R9 285/380] vendor: XFX Pine 
           driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: Samson Q2U handheld mic with XLR type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2:4 
           Sound Server: ALSA v: k5.5.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.048.00-NAPI port: d000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: d8:cb:8a:5b:bc:9b 
Drives:    Local Storage: total: 223.58 GiB used: 43.96 GiB (19.7%) 
           ID-1: /dev/sda vendor: A-Data model: SP550 size: 111.79 GiB 
           ID-2: /dev/sdb vendor: A-Data model: SP550 size: 111.79 GiB 
Partition: ID-1: / size: 62.50 GiB used: 43.96 GiB (70.3%) fs: ext4 dev: /dev/sdb3 
           ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb4 
Sensors:   System Temperatures: cpu: 25.4 C mobo: N/A gpu: amdgpu temp: 52 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 53m Memory: 7.79 GiB used: 3.01 GiB (38.6%) Init: systemd Compilers: gcc: 9.3.0 clang: 9.0.1 
           Shell: zsh v: 5.8 inxi: 3.0.37 

I have recorded the state of alsa before and after by using the alsactl --file <path> store command and then diffing them. Here is a screenshot of the diff:
alsactl_state_diff

I can see that there are differences and that they are located in the microphone related settings, but I'm not sure what they mean and because of that I don't really know how to take action on them.

I am aware of this post and this one, but it doesn't look like a solution was found for either of them. That said, neither of them looked at the diff between the alsa settings, so I'm hoping that that extra info can help someone point me in a more fruitful direction.

Any help would be greatly appreciated!

Also, below is a screenshot of a before and after of aslamixer and the relevant tabs of pavucontrol. The before is on the bottom and the after is on the top:
alsamixer_and_pavucontrol_differences

The only differences that I can see are in the ordering of items and of course the static volume you can see on the mic in the "before" Input Devices tab.

I would have put this in the original post, but new members only get one picture :wink:

I should also report that I have already done the tsched=0 in /etc/pulse/default.paand thedefault-sample-rate = 48000in /etc/pulse/daemon.conf tricks as per the Arch wiki.

Finally, I have also tried the "remap to mono" trick also suggested at Arch Wiki here with no success.

I have the very same mic (but bought in 2013), I don't mess with alsa config, only pulseaudio and jack, and in these two the mic works flawlessly whether it's for use in browsers or daw like ardour. When you say recording, do you mean live voice or actually record something through some app?

Good question! I haven't tried just playing the mic through the speakers, but in any sort of recording like with OBS studio or even just the arecord command it's nothing but static. I'll update about playing the mic through the speakers.

No dice. I tried just looping the mic through the speakers and it is just static.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by