screen flickering is hardware accelerated apps & horrible screen tearing.

Hey guys, bit of a linux noob here and i seems to be having some problems with graphics on my 7000 series inspiron.

when i first installed manjaro i noticed programs like chrome and cs code has this weird screen flicker issue when i scrolls and sometimes even refused to load. if i disabled hardware acceleration on these programs everything worked fine.

i managed to permanently solve this issue by uninstalling the intel driver making the modesetting driver default and that has sorted out my screen flickering but not i have unbearable screen tearing.

so my question is, is there a way to stop the screen tearing on modesetting or prevent the screen flicker on the intel drivers.

Processor is i7-10510u
Graphics are Intel UHD Graphics.

any help will be appreciated. thank you

Add i915 to your mkinitcpio.conf and run mkinitcpio -P

Add a config to /etc/X11/xorg.conf.d using the TearFree option

You can also activate gfx.webrender.all and gfx.webrender.enabled in firefox

1 Like

i've not come across mesa, what is the difference between this and xf86-video-intel drivers ?

mesa is a 3D library

so i tried your suggested changes and it prevented my laptop from booting. it got stuck on 'Started TLP system startup/shutdown" but i was able to get into the CLI and hide the 20-intel.conf which has allowed me to boot up into the GUI again. any suggestions ?

inxi -Fxxxza --no-host
System:    Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=8027489c-e458-4966-ab4a-ffabbc0c866c rw quiet 
           Desktop: Gnome 3.34.4 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:   Type: Convertible System: Dell product: Inspiron 7391 2n1 v: N/A serial: <filter> Chassis: type: 31 
           serial: <filter> 
           Mobo: Dell model: 0M3KP1 v: A00 serial: <filter> UEFI: Dell v: 1.3.1 date: 11/28/2019 
Battery:   ID-1: BAT0 charge: 42.8 Wh condition: 42.8/45.0 Wh (95%) volts: 8.7/7.6 model: SMP DELL WDK3699 
           type: Li-poly serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: C (12) microcode: CA L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 1100 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 1000 2: 1000 3: 1000 4: 1000 5: 1000 
           6: 1000 7: 1000 8: 1000 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9b41 
           Display: x11 server: 1.20.7 driver: none compositor: gnome-shell resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics (Comet Lake 3x8 GT2) v: 4.6 Mesa 19.3.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:02c8 
           Sound Server: ALSA v: k5.4.22-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 3000 bus ID: 00:14.3 
           chip ID: 8086:02f0 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4-1.1:3 
           chip ID: 0bda:8153 serial: <filter> 
           IF: ens4u1u1 state: down mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 41.18 GiB (8.6%) 
           ID-1: /dev/nvme0n1 model: KBG40ZNS512G NVMe KIOXIA 512GB size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 10410104 scheme: GPT 
Partition: ID-1: / raw size: 99.51 GiB size: 97.45 GiB (97.93%) used: 41.18 GiB (42.3%) fs: ext4 
           dev: /dev/nvme0n1p8 
Sensors:   System Temperatures: cpu: 61.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 4477 
Info:      Processes: 274 Uptime: 17m Memory: 15.43 GiB used: 3.06 GiB (19.8%) Init: systemd v: 242 Compilers: 
           gcc: 9.2.1 Shell: zsh v: 5.8 running in: gnome-terminal inxi: 3.0.37 

here you go.

well that would be a problem ..

(how did you install or configure drivers?)

But you probably wanna do this

sudo mhwd -f -i pci video-linux

so i have video-linux showing as installed in the manjaro setting > hardware configuration.

i did some googling around when i first installed manjaro as that is when i had the screen flickering issue and i saw a suggestion to uninstall xf86-video-intel which did fix my issue but now i have the screen tearing. should i reinstall this ?

modesetting doesn't have a TearFree option.

have you tried 5.5 or 5.6 yet?

post outputs:

mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
pacman -Qs | grep -Ei 'xf86-video|vesa'

also mention any directions you may of found and tried to use, include links if possible.

I know that - I was suggesting to use the intel i915 and a corresponding config.

i have not tried updating the linux kernal as on yet but it was an option. i was going to see if it was another issue before trying that.

uninstalling xf86-video-intel is the only suggestion i have tried.

➜  ~ mhwd -li
ls -laR /etc/X11 ; cat /etc/X11/xorg.conf.d/*.conf
pacman -Qs | grep -Ei 'xf86-video|vesa'

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
total 32
drwxr-xr-x  5 root root 4096 Dec 29 11:20 .
drwxr-xr-x 93 root root 4096 Mar  2 16:04 ..
drwxr-xr-x  2 root root 4096 Nov 19 23:58 mhwd.d
drwxr-xr-x  3 root root 4096 Dec 29 11:20 xinit
drwxr-xr-x  2 root root 4096 Mar  2 12:51 xorg.conf.d

total 12
drwxr-xr-x 2 root root 4096 Nov 19 23:58 .
drwxr-xr-x 5 root root 4096 Dec 29 11:20 ..

total 28
drwxr-xr-x 3 root root 4096 Dec 29 11:20 .
drwxr-xr-x 5 root root 4096 Dec 29 11:20 ..
-rw-r--r-- 1 root root  739 Mar  4  2019 xinitrc
drwxr-xr-x 2 root root 4096 Feb 24 15:43 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  4  2019 xserverrc

total 20
drwxr-xr-x 2 root root 4096 Feb 24 15:43 .
drwxr-xr-x 3 root root 4096 Dec 29 11:20 ..
-rwxr-xr-x 1 root root  318 Nov  9  2018
-rwxr-xr-x 1 root root  203 Jan 22 22:16

total 20
drwxr-xr-x 2 root root 4096 Mar  2 12:51 .
drwxr-xr-x 5 root root 4096 Dec 29 11:20 ..
-rw-r--r-- 1 root root  266 Feb 24 15:25 00-keyboard.conf
-rw-r--r-- 1 root root  119 Mar  2 12:44 .20-intel.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
    userspace helper for uvesafb that runs x86 code in an emulated environment
local/xf86-video-amdgpu 19.1.0-1 (xorg-drivers)
local/xf86-video-ati 1:19.1.0-1 (xorg-drivers)
local/xf86-video-intel 1:2.99.917+899+gf66d3954-1 (xorg-drivers)
local/xf86-video-nouveau 1.0.16-1 (xorg-drivers)

here is the output.

what about using wayland instead of xorg? the arch wiki on gnome probably explains how to do that.

Brand new hardware?

Try the latest kernel.


so i recently reinstalled. i have install the latest kernal v5.6 experimental and program likes chrome or vscode (really anything that uses hardware acceleration) still have this flicker issue if i disabled hardware acceleration it clears right up. i followed linux-aarhus's advice and now "inxi -Fxxxza --no-host" is saying i am running the i915 drivers i will try swapping from xorg to wayland as per dglt's suggestion but i do believe this is a hardware/driver realted issue.

If its new .. wouldnt 'modesetting' be more likely to bring support ?
(given that xf86-intel is pretty much only for older things?)

1 Like

so i have swapped over to wayland from xorg and this seemes to have fixed my issue. everything renders properly and i have no screen tearing.

Thanks everyone for the help !!!! really appreciate it

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by