Screen flickers

So I am new to Manjaro, but not new to Linux.
I just installed Manjaro and the login screen is still but as soon as I login the screen flickers and for time to time goes black, just to come back soon after.

What can this be due to?

1 Like

My immediate guess is - wrong permissions on your /home/$USER folder - but that would only occur if you were using a folder from a different installation of Linux.

If the login screen (display manager) doesn't show at all it is a graphic configuration issue.

I raised the underscan in the Nvidia settings and now it is still.

2 Likes

Are you using picom/compton?
From:https://wiki.archlinux.org/index.php/Picom

Screentearing with NVIDIA's proprietary drivers

Try this setting in picom.conf :
vsync = "opengl"

There something I've read before about the flickering at boot can sometimes be xsetroot setting the background color. I can't remember the details entirely though.

Since I am new to Manjaro it didn't take long for me to pooch the whole installtion so I did a reinstall and choose free-drivers this time, no flickering no blackouts.

2 Likes

I have the same problem ever since I upgraded to Gnome 3.36. I am also using NVIDIA proprietary driver.

Likely a regression in GNOME 3.36. 3.36.1 is coming soon.

I have both Gnome 3.36 and KDE. The same happens with KDE, so I am not sure if it's a regression from Gnome's side (or I might just have a separate issue).

1 Like

So it started happening in KDE when you upgraded to GNOME 3.36? Weird how GNOME would affect KDE?

Or maybe this has nothing at all to do with GNOME 3.36?

Right, now I realized it may not be relevant to Gnome at all. My apology. I actually just switched to nouveau (unfortunately I got an NVIDIA GPU).

Oh, actually, even after I switched to nouveau, I still get the same issue. I finally realized I got a contact issue with my display port. Unplug and plug in, now all issues are gone.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by