Screens are blinking

Hello everyone. Sorry for this topic, I'm new in Linux and just begin learning Linux. I've installed Manjaro Gnome recently, and I ran into a problem: my screens are flickering. It's not critical, because I can still work with this issue, but it really annoys for me. Blink effect looks like you record screen from the camera, like that: https://youtu.be/oH9wkQkgMcI?t=178s

I have GeForce RTX 2070 SUPER, the first monitor connected via HDMI, the second monitor connected via HDMI-DP cable, but both monitors are flickering.

I tried changing GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub, I added i915.enable_psr=0. After that I ran sudo grub-mkconfig -o /boot/grub/grub.cfg, but it ddin't help me.

Hello,
That is for Intel GPU

Sounds like you are on a Desktop PC. Do you use the nouveau drivers for it or the nvidia one?
Ope terminal and run:
inxi -Fxxxza --no-host
Copy that text and share it here. Use ``` above and bellow it for proper formatting. Also share:
mhwd -li

Thanks a lot for your reply!
Yes, I use Desktop PC. I haven't installed any drivers after linux installation.

Result of inxi -Fxxxza --no-host

System:
  Kernel: 5.4.31-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=a032d202-59e8-44a7-aee8-3a1848028160 rw quiet 
  resume=UUID=b9fc7de6-b86b-450f-a9f1-29c40401f629 udev.log_priority=3 
  i915.enable_psr=0 
  Desktop: Gnome 3.36.1 wm: gnome-shell dm: GDM 3.34.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: TUF B450M-PRO GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 1820 date: 09/12/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 91065 
  Speed: 2195 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 
  1: 2195 2: 2196 3: 2195 4: 2195 5: 2195 6: 2195 7: 2196 8: 2196 9: 2196 
  10: 2194 11: 2184 12: 2195 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  always-on, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Gigabyte 
  driver: nouveau v: kernel bus ID: 06:00.0 chip ID: 10de:1e84 
  Display: x11 server: X.org 1.20.8 driver: modesetting 
  alternate: fbdev,nouveau,nv,vesa compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: llvmpipe (LLVM 9.0.1 128 bits) v: 3.3 Mesa 20.0.4 
  compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 06:00.1 chip ID: 10de:10f8 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 08:00.4 chip ID: 1022:1487 
  Device-3: Logitech 960 Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-6:6 chip ID: 046d:0a45 
  serial: <filter> 
  Sound Server: ALSA v: k5.4.31-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.36 TiB used: 46.12 GiB (3.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-75WN4A1 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 7113 scheme: GPT 
  ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q scheme: GPT 
  ID-3: /dev/sdc vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 4B6Q scheme: GPT 
Partition:
  ID-1: / raw size: 50.00 GiB size: 49.15 GiB (98.31%) 
  used: 15.04 GiB (30.6%) fs: ext4 dev: /dev/sdc2 
  ID-2: /home raw size: 178.38 GiB size: 174.58 GiB (97.87%) 
  used: 31.07 GiB (17.8%) fs: ext4 dev: /dev/sdc3 
  ID-3: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sdc1 
Sensors:
  System Temperatures: cpu: 51.4 C mobo: N/A gpu: nouveau temp: 28 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 843 
Info:
  Processes: 340 Uptime: 2h 03m Memory: 15.63 GiB used: 9.16 GiB (58.6%) 
  Init: systemd v: 244 Compilers: gcc: 9.3.0 clang: 9.0.1 Shell: bash 
  v: 5.0.16 running in: gnome-terminal inxi: 3.0.37 

Result of mhwd -li

Warning: No installed PCI configs!
Warning: No installed USB configs!

That is not quite useful for that GPU model, plus

Is like you would be on a virtual machine, so the GPU is not working at the potential it has. Install the proper driver:
sudo mhwd -i pci video-nvidia-440xx
then reboot your system and report back.

Thanks for not following my typo :wink:

After driver installation I rebooted my computer. Now system can't be started, only black screen is displayed with blinked underscore.

How to rollback these changes now? :slight_smile:

Press Ctrl+ALT+F3 then back to CTRL+ALT+F1 ... Do you get the Desktop?
Please remove the

From grub and update it. Reboot again after that.

If that doesn't work you can from Ctrl+ALT+F3 (TTY3) to remove the driver
sudo mhwd -r pci video-nvidia-440xx
and install back the nouveau driver
sudo mhwd -i pci video-linux
but to me this makes no sense.

When i pressed Ctrl + Alt + F3 console was opened, and then Ctrl + Alt + F1 returned to the black screen with underscore again, it didn't help me.

I removed driver video-nvidia-440xx as you suggested, now I am able to login to the system.
Also, I removed i915.enable_psr=0 from grub and rebooted.

My suggestion was in a particular order, and removing the nvidia driver as last resort. Anyway ... i'll step out from this topic.

Oh sorry, I didn't figure out, I will try to install the driver again with removed i915.enable_psr=0 option.

Ok, but remove the video-linux before installing the video-nvidia-440xx
sudo mhwd -r pci video-linux
then run
sudo mhwd -i pci video-nvidia-440xx

I honestly don't know why would hang the system to balk screen. Also remove tlp since you are on a Desktop PC. Also, maybe wayland session is enabled on your system and you log in automatically to it? Best would be to test in X11 session first.

1 Like

Yeap, I did as you said. Also, I made sure that only one driver is available, I ran command mhwd --pci -li and it displayed only one driver: video-nvidia-440xx, but I didn't help, black screen is still displayed after reboot. I don't know what wayland session means and I don't know how to test in X11 session, sry :slight_smile:

Ok, we can try a few things. While in the GRUB boot menu press e to edit it. On the linux line remove quiet and replace it with nomodeset, then press F10 to save and continue booting. There should be now a message where the system hangs.

EDIT: we should make sure your system is updated:
sudo pacman-mirrors -f && sudo pacman -Syyu
Install the second kernel just in case
sudo mhwd-kernel -i linux56
Reboot. In GRUB you can select what kernel to use and you can add the kernel parameters i mentioned. There should be no issue and i can't make much sense why in your case the issue persists.

I ran sudo pacman-mirrors -f && sudo pacman -Syyu and during installing I lost electricity in my home. The installation didn't finish, now the system can't be started. Are there any solutions to rollback installation?

You will need to chroot the system from the install media and finish the update.

I can't. When I choose Manjaro Linux in boot menu, I have the following error:

error: file `/boot/vmlinuz-5.4-x86_64' not found.
error: you need to load the kernel first.

No! You have to boot from LIVE MEDIA, not the installed system.

Oh, I got it, thanks. I am downloading live CD, I will try

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by