sd-umount: Failed to unmount /oldroot

Just by chance I saw that my PC throws errors incl. kernel panic whenever I shutdown the PC. There is no trace in the logs. But I have pictures:



So far I did not experience any negative impact, but it scares me.

I do not know if this is a kernel bug or a systemd bug. I found some info on the web. Some of which proposed to add the "shutdown" HOOK to /etc/mkinitcpio.conf etc. . I did that. But it did not help.

Any idea what is going on here?

1 Like

Maybe some job on shutdown. Check your services for a shutdown target.
Also try other kernels and/or fallback image.

I said: there is no trace in the logs. It happens at the very end of the shutdown process and powering off a second later. The last entries in the journal are:

Sep 10 17:57:05 rakete systemd[1]: Reached target Power-Off.
Sep 10 17:57:05 rakete systemd[1]: Shutting down.
Sep 10 17:57:05 rakete kernel: printk: systemd-shutdow: 57 output lines suppressed due to ratelimiting
Sep 10 17:57:05 rakete systemd-shutdown[1]: Syncing filesystems and block devices.
Sep 10 17:57:05 rakete systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Sep 10 17:57:05 rakete haveged[459]: haveged: Stopping due to signal 15
Sep 10 17:57:05 rakete haveged[459]: haveged starting up
Sep 10 17:57:05 rakete systemd-journald[460]: Journal stopped

Any external drives?

Just giving ideas...

No external drives. And I believe this issue is new. I will try kernel 4.19 and see....

It is definitely a systemd issue!

With kernel 4.19 I get the same three lines of error like in the first image but no kernel panic.

But when I downgrade systemd the issue is gone.

It was this update in testing that caused the issue:

[2019-09-06 22:31] [ALPM] upgraded systemd-libs (242.85-2 -> 243.0-2)
[2019-09-06 22:31] [ALPM] upgraded systemd (242.85-2 -> 243.0-2)
[2019-09-06 22:33] [ALPM] upgraded systemd-resolvconf (242.85-2 -> 243.0-2)
[2019-09-06 22:33] [ALPM] upgraded systemd-sysvcompat (242.85-2 -> 243.0-2)

Downgrading solved it:

[2019-09-10 18:53] [ALPM] downgraded systemd (243.0-2 -> 242.85-2)
[2019-09-10 18:54] [ALPM] downgraded systemd-libs (243.0-2 -> 242.85-2)
[2019-09-10 18:55] [ALPM] downgraded systemd-resolvconf (243.0-2 -> 242.85-2)
[2019-09-10 18:55] [ALPM] downgraded systemd-sysvcompat (243.0-2 -> 242.85-2)

I do not recommend to push systemd 243.0-2 to stable.


1 Like

Noticed this too, but i think the issue is solved with the 243.9-1 currently in unstable.

1 Like

I see I'm not the only one. But I only get the 2 sd-umount errors, I don't get a kernel panic or whatever that mess is in the 2nd picture, probably cause I'm on stable...

Yep I noticed it on my fresh install of Architect Testing this weekend. Forgot to report it.

1 Like

It's a regression in v243. It still happens in 243.51:

But the systemd issue I opened was closed by Poettering:

Umm. Kernel oopses are never something userspace should be able to trigger. Unfortunately your second pic cuts off where the interesting bits follow.

Either way this doesnt look like a systemd prob. If the kernel oopses its a kernel problem. Please contact your distro about this first.

(Also drop vbox kernel modules which arent upstream before testing. Kernel folks dont like testing that.)

Anyway. Closing this here.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by