Secondary monitor not detected

The Manjaro version that I installed is manjaro-kde-19.0.2-200303-linux54.
I have an Asus ROG laptop with i7-9750H and a GTX 1660Ti and I connected the secondary monitor through HDMI to the dedicated card but in display configuration, there is only the laptop's screen. Looking into hardware configuration I noticed that it automatically installed hybrid intel nvidia 440xx prime for both GPUs. Then I uninstalled it and installed the bumblebee version and now it's not booting up anymore, my screen is just black. I can reinstall it but I want to know if there is a fix for my initial problem. Isn't multi-monitor natively supported?! I did not encounter this in Ubuntu, I thought all modern distros can support it.
Do you have any ideas why this is happening?

Installing and uninstalling, then installing propriety graphics drivers can be a train-wreck in any desktop used in Linux.

With the GTX installed, is the i7-9750H still enabled in the BIOS?

With the presence of the GTX, it may have been disabled.

Are you trying to run both monitors with the GTX?

Or, are you trying to use the internal display (w/i7-9750H), AND an external display with the GTX?

Some references that may be helpful...

"Configure Graphics Cards" (Manjaro)

https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards

"Hybrid graphics" (Arch)

https://wiki.archlinux.org/index.php/Hybrid_graphics

"NVIDIA Optimus" (Arch) << You'll want to review this one.

https://wiki.archlinux.org/index.php/NVIDIA_Optimus
^^^ "NVIDIA Optimus is a technology that allows an Intel integrated GPU and discrete NVIDIA GPU to be built into and accessed by a laptop."

"Note: By default, optimus-manager only changes which graphics driver is active; it does not automatically turn off the NVIDIA GPU when not in use. To enable power management, see the upstream guide. Configurations that include a Turing architecture (or newer) GPU and an Intel Coffee Lake (or newer) CPU can use power management features built into the proprietary NVIDIA driver; see [6] for setup instructions."

"There should be an option to disable one of the cards. Some laptops only allow disabling of the discrete card, or vice-versa, but it is worth checking if you only plan to use just one of the cards."

"Multihead" (Arch)

https://wiki.archlinux.org/index.php/Multihead

"Bumblebee" (Arch)

https://wiki.archlinux.org/index.php/Bumblebee
^^^ "NVIDIA Optimus enabled laptops"
For use only for "Optimus" laptops.

"How To Use Multiple Monitors On Linux (With Xrandr)" (2019)

https://www.youtube.com/watch?v=wu2NWw2wPaA

"xrandr" (Arch)

https://wiki.archlinux.org/index.php/Xrandr

"Linux Monitor Calibration that Never Resets"

https://www.youtube.com/watch?v=lhiLWxJgiAo

"Linux Tutorial: Fixing KDE Dual Monitor Woes" (2016)

https://www.youtube.com/watch?v=S25XTiG4oRc
^^^ May not be applicable now...?

1 Like

I managed to install optimus using this tutorial Guide: Install and configure optimus-manager for hybrid GPU setups (Intel/NVIDIA)
but switching to Nvidia doesn't work. After I log back in there is still the Intel icon. I may have done something wrong, I don't know...

Did you do what was said in point 6 of the guide? About modifying SDDM config?

Please, try to switch two times from intel to nvidia and create the output of to the text file:

journalctl -u optimus-manager.service> optimus-manager.log.txt

journalctl -u sddm.service> sddm.log.txt

Open the files, move to the time when you attempted the switch, copy the output and post here.

So it's kinda working now. I didn't modify anything else. In optimus I set startup mode to Nvidia and rebooted the PC and boom, the secondary monitor is working.
If I switch from the icon in system tray it doesn't work, I must set the startup mode and reboot it. With hybrid mode the monitor doesn't work, so startup nvidia is the only way. I won't game on it so I hope the battery won't run out quickly.
It's really bad if this is needed in 2020 just to connect a secondary monitor...
Thank you guys!

Pretty sure it's just this:

https://wiki.archlinux.org/index.php/PRIME#Reverse_PRIME

This exact issue has also been posted about multiple times in the past couple of days. It shouldn't be this hard to search the forum.

That is normal. At the moment drivers in hybird mode aren't capable of outputting the picture to the secondary monitor, so you must use either Intel or Nvidia drivers if you want to use multi-monitor setup.

The lack of switch but the startup working is a very strong indicator that sddm is at fault somehow (preventing the switch). Please, check sddm config as described in point 6 of the guide.

I went to etc and there I have a sddm.conf.d folder in where I have 20-optimus-manager.conf which contains those two lines, kde-settings.conf and virtualkeyboard.conf.
I addee a '#' in front of those two lines but it's the same, switching doesn't take effect.

Looks like you edited wrong confs. Reverse changes and go to /etc/sddm.conf

So basically open in terminal:

sudo nano /etc/sddm.conf

and check whether there are lines that I mentioned. If you did any changes, reboot and then try the switch.

2 Likes

Thank you very much! I thought I can find the file using Dolphin. Now I noticed you are the one who wrote that guide, very good job! You should add this too sudo nano /etc/sddm.conf for noobs like me :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by