[Security Update] Firefox 69.0

I have built and pushed Firefox 69.0 to the following branches:

  • stable (-0)
  • testing (-0.1)
  • unstable (-0.1) Superceded by 69.0-1
  • x32-stable (-0)
  • x32-testing (-0.1)
  • x32-unstable (-0.1)

As is always the case for a short-turnaround update, this package has had only minimal testing.

Release notes: https://www.mozilla.org/en-US/firefox/69.0/releasenotes/
Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2019-25/
Overlay packaging files: https://gitlab.manjaro.org/security-overlay/firefox

Working OK?

  • 69.0-0 (stable) is fine
  • 69.0-0 (stable) has an issue (post)
  • 69.0-0.1 (testing, unstable) is fine
  • 69.0-0.1 (testing, unstable) has an issue (post)
  • 69.0-0 (x32-stable) is fine
  • 69.0-0 (x32-stable) has an issue (post)
  • 69.0-0.1 (x32-testing, x32-unstable) is fine
  • 69.0-0.1 (x32-testing, x32-unstable) has an issue (post)

0 voters


69.0-0 stable

If those are provided by Mozilla via AMO then you'll have to wait until they update them. The language packs in the repos were updated at the same time so should be compatible.


I updated the list of packages

1 Like

I definitely uploaded verison 69.0-0 for all i18n packages too (just checked again) so your mirror hasn't got them yet.

Keep checking, they'll arrive at some point.

1 Like

Sorry for disturbing is it some Firefox issue in repos? Just don't remember vote in Firefox update topics.

I've started adding a poll to check the package is working fine, and also so other people can see the package is working fine.


Gotcha. Just let me clarify, is it suppose to check whether upstream package is OK? As I understand there is not patches from Manjaro team.

No, this is a package built by me for Manjaro.

69.0 isn't in Arch yet.


This package (along with every other Firefox, Thunderbird, and Chromium security update I've packaged) has not been through the normal unstable->testing->stable process, hence it has had "minimal testing".

This means I want to check that the package is working properly for most people, and then if anyone does have a problem they know it should be a limited issue and not a general issue with the package.


Jonathon one love :wink:

Oh, the irony, Arch behind Manjaro on security updates :rofl:


It's a shame you are not on the Manjaro IRC channel to answer the Arch trolls there.

This hasn't been announced as a security update by Mozilla yet, and there are plenty of packages in stable which have... issues.

I am having an issue with youtube, since I updated all thumbnails in youtube appear just blank

Check your extensions.

No issue now, they haven't released the release notes yet, what's new in this version of firefox?

Why was the normal process bypassed?

Because the last stable update is quite a while in the past (for a rolling release distro) and there are still a few issues on testing that have to be ruled out until the next stable update can be released (at least that's my guess). In order to avoid longer waiting times for popular packages, manjaro overlays them. This is also used for security updates. You can find the packages in question here: https://gitlab.manjaro.org/security-overlay. These will usually be overlayed until the upstream archlinux packages hit stable.

1 Like

My firefox installation broke :cry:

###!!! [Parent][MessageChannel] Error: (msgtype=0x36004C,name=PContent::Msg_LoadProcessScript) Channel error: cannot send/recv
[Parent 30962, Gecko_IOThread] WARNING: pipe error (158): Connection reset by peer: file /build/src/firefox-69.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358
[Parent 30962, Gecko_IOThread] WARNING: pipe error (155): Connection reset by peer: file /build/src/firefox-69.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358
[Parent 30962, Gecko_IOThread] WARNING: pipe error (141): Connection reset by peer: file /build/src/firefox-69.0/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 358

Getting many lines of this error.

Edit 1: I tried refreshing, re-installing firefox but still the same result
Edit 2: is it related with kernel? I am currently on 5.2

Seems all fine here (XFCE, Kernel 4.14.138).
If I will encounter some issue, I will edit this post and change my answer to the poll.

Forum kindly sponsored by