[Security Update] Firefox 69.0

Seems fine here. Back button functionality may be a little different, after paging through an online site (an online manga reader), the back button returns me to the index page, rather than having to page back one page at a time or use the history to get back to it. This seems intentional, and I rather like it, but probably relates to the site's coding. Other sites behave as usual.

Those are "WARNING" messages.

Which part of Firefox broke?

I am not able to use firefox at all, it is opening but can not open any page or links. I rolled back to 68 and it is working, with refresh

Hmm.

Check you're fully up-to-date. Which branch are you on, which version do you see?

If a cleared profile works then this may have been an extension issue.

See the thread I posted above about Troubleshooting Firefox.

All fine to me. 2 installations.

I was using the same extensions on my desktop, it updated without any issue on it. I am still facing problems in my laptop no idea why it is happening.

OK, so

and

###!!! [Parent][MessageChannel] Error: (msgtype=0x360025,name=PContent::Msg_DataStoragePut) Channel error: cannot send/recv
Is this warning? or error? I deleted all my profile, refreshed firefox but still the problem persists :cry:
Edit 1:
image
Tried running safe-mode this is what it is showing, the same comes up when I try to open any link from other applications.

XPCOMGlueLoad error for file /usr/lib/firefox/libxul.so:
/usr/lib/firefox/libnss3.so: version `NSS_3.45' not found (required by /usr/lib/firefox/libxul.so)
Couldn't load XPCOM.

Also, I found these lines in the console, I think this might be the error anyway to solve this?

Branch, version, and check for updates.

Please provide the information I've asked for.

Branch stable, Firefox version 69, Manjaro version 18.0.4, checked for update, but no update found

Package version please.

69.0-0 is built against the libraries in stable so it works.

If you have the wrong libraries then your system is not up-to-date, so refresh your mirror list and check for updates again.

I am updated, I think the libnss3.so file was corrupted because when I removed it and reinstall firefox everything worked fine, now I have to login and reconfigure my firefox :cry:
Edit 1: Thank you Jonathon for your support, also thank you Manjaro team for being there to help every time :D, Best distro ever.

$ find / -xdev -name libnss3.so 2>/dev/null
/usr/lib/libnss3.so
$ pacman -Qo /usr/lib/libnss3.so
/usr/lib/libnss3.so is owned by nss 3.45-1

Better reinstall nss package than to remove a single file.

All went fine on 2 laptops, stable, kernel 5.2.

giggity :smirk:

I love that this was so fast that you beat the changelogs. Also, buttery smooth update. :+1:

2 Likes

No issues with Firefox or any extensions, good and fast work :slight_smile:

Stable 69.0.0 version are fine in my XFCE. No issue till now.

Released the update that was in unstable pro stable.

https://www.mozilla.org/en-US/firefox/69.0.1/releasenotes/

Screenshot_20190919_134629

2 Likes

Thanks, also worth noting that Mozilla are switching to a monthly release cycle in 2020 instead of every 6 weeks.

3 Likes

Forum kindly sponsored by