Serbian (Latin) keyboard layout problem

Hello everyone. I've just recently started using Linux, with Manjaro KDE being my first distro ever to try. It's installed on a laptop HP Pavilion Sleekbook 15 b003em:

  • Core i5-3317
  • 8 GB RAM
  • 120 GB Kingston V300 SSD
  • GeForce 630M (free drivers)

The problem:

After more than a couple of failed attempts to enter a password on some websites - pass incorrect - I started thinking that it wasn't just a typo. So I tried to type my password to a text editor in order to do a copy paste - and my key 1 (regular one above the letter Q) was not working. I also found out that the "v" key isn't working as well. The twist - "!" key and capital "V" are working as they should!

So I changed the keyboard layout to en_US, and everything is fine. Changed to Serbian (Cyrillic) - also works fine. This happens in all layouts that are Serbian (Latin), regardless if QWERTZ or QWERTY.

So, can anyone help the new guy with this?

Thank you in advance,
Predrag

EDIT: This also happens in Montenegrin (latin) layout.

I'm not sure whether the cause/issue is the same on KDE, however I had the exact same one (just with "v" though) on XFCE, both on Manjaro and Debian.

Solved by not letting the desktop configure/control the layouts, and instead setting them manually in /etc/default/keyboard.

So try disabling/unchecking the "Configure Layouts" button at "Settings-->Keyboard-->Layouts" and if necessary edit the /etc/default/keyboard (as root).
Mine is:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="rs,us"
XKBVARIANT="latinyz,"
XKBOPTIONS="kpdl:dot,grp:alt_shift_toggle,grp_led:scroll,terminate:ctrl_alt_bksp"

BACKSPACE="guess"

It will give you Serbian Latin Qwerty and US layouts. Adapt as necessary, save the file and restart X or just reboot. Hopefully it will work on KDE. :slight_smile:

Hey there, thanks for the answer. Unfortunately, it hasn't helped - did everything as you said, nothing. Also, there is no option in Plasma to uncheck the keyboard control through desktop...

Any further thoughts? This thing will get me insane! Why in Serbian-latin keyboard layout keys 1, 7 and small v do not work?! If I press Shift+any of these, they work as intended.

Thanks in advance,
Predrag

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by