Setting Manjaro as the default OS in dual boot with Windows 10

I have a dual boot (Windows 10 and Manjaro) in UEFI mode and MSI's Click BIOS 5.

Is it possible to boot Manjaro as a default and only if I press F11, optionally to boot Windows?

I just have silent-boot set up and selection is auto (last one you used).
Never see windows or grub unless I hit esc or or if there is a failure (in theory .. hasnt happened yet)

$ cat /etc/default/grub
GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

I don't see grub and my PC always boots Windows as a default, even GRUB_DEFAULT is set as "saved". I would love if I could achieve your setup.

#If you want to enable the save default function, uncomment the following
#line, and set GRUB_DEFAULT to saved.

GRUB_SAVEDEFAULT=true

Is there grubenv in /boot/grub?

# GRUB Environment Block
saved_entry=gnulinux-simple-UUID-xxxx
boot_success=1
boot_indeterminate=1

You dont see grub? How do you boot manjaro?

Okay, you start a new topic. Below was from your original topic.
And if 'command efibootmgr not found' that's because your original install was in bios-legacy.
Install package 'efibootmgr' and 'dosfstools' (if not installed).

Morning. So you now cannot set manjaro uefi as default boot through your bios.
You want manjaro boot to be default and both are now booted in uefi.

At manjaro terminal

efibootmgr

You should get outout for efiboot-entries of both windows and manjaro
say xxxx is for manjaro and yyyy for windows
Do

sudo efibootmgr -o xxxx,yyyy

There are other (firmware) entries listed, you do not need to list them all and there’s no need to include them in the command.
If in doubt provide output of ‘efibootmgr’

4 Likes

Through F11 (quick boot selection) during startup.

Thanks, it looked so promising, but after I did that, instead of booting straight to Manjaro, my PC again booted to Windows and ’efibootmgr’ reverted the boot order to its default (Windows on top). I don't understand what exactly reverts that order... Windows?

[joe@sensei ~]$ efibootmgr
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0000,0002,0001
Boot0000* Windows Boot Manager
Boot0001 Hard Drive
Boot0002* Manjaro
[joe@sensei ~]$ sudo efibootmgr -o 0002,0000,0001
[sudo] password for joe:
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000,0001
Boot0000* Windows Boot Manager
Boot0001 Hard Drive
Boot0002* Manjaro

After reboot, I go straight to Windows, then I reboot again and by F11 enter Manjaro:

[joe@sensei ~]$ efibootmgr
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0000,0002,0001
Boot0000* Windows Boot Manager
Boot0001 Hard Drive
Boot0002* Manjaro

Just found a valuable discussion here:

It's implemented in the firmware before any EFI binaries are run, so it's not something that efibootmgr can do anything about.

Therefore, I found a menu item inside of my BIOS to re-order my boot priorities:
Settings > Boot > UEFI Hard Disk Drive BBS Priorities

2 Likes

Well done! You even outsmarted yourself.. :rofl:
So now we know there is more than 100% to one's confidence :trophy:

1 Like

Yeah. lol That was confusing... the thing is I was trying really hard to Google first for the solution of my problem and found this: https://forum-en.msi.com/index.php?topic=294360.0

I've contacted MSI technical support. The outcome of our chatting was:

  • there are no options to manage UEFI boot entries from Click BIOS 5;
  • they are not planning to implement them.

Good to know. I can live with the current state of things.

I would suggest any multi-booter to grab this UEFI shell, put it on a FAT-formatted USB key and keep it under their pillow for when
things get bad.

That totally convinced me + I didn't check what the BBS stands for. Anyway, I'm glad my bios is not that bad after all. Thanks for your responses though!

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by