Setting Up NVIDIA Drivers, Driver not loaded

Here is my inxi -FX, and inxi -G below since I think separating that out would help as it should be more relevant.

System:    Host: yasser-pc Kernel: 5.4.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: KDE Plasma 5.17.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: G7 7588 v: N/A serial: <root required> 
           Mobo: Dell model: 0FDMYT v: A00 serial: <root required> UEFI: Dell v: 1.11.1 date: 07/15/2019 
Battery:   ID-1: BAT0 charge: 23.8 Wh condition: 41.6/56.0 Wh (74%) model: Samsung SDI DELL W7NKD86 status: Charging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 901 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 3: 901 4: 900 5: 900 6: 900 7: 900 8: 900 
           9: 900 10: 901 11: 900 12: 900 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.7 driver: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.3 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.4.18-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: c0:b6:f9:73:03:fc 
           Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Dell driver: alx v: kernel port: 3000 
           bus ID: 3b:00.0 
           IF: enp59s0 state: down mac: 54:bf:64:25:71:30 
Drives:    Local Storage: total: 1.03 TiB used: 94.56 GiB (9.0%) 
           ID-1: /dev/sda vendor: SanDisk model: X600 M.2 2280 SATA 128GB size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10SPZX-75Z10T1 size: 931.51 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 29.40 GiB used: 19.01 GiB (64.6%) fs: ext4 dev: /dev/sda5 
Sensors:   System Temperatures: cpu: 53.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 273 Uptime: 57m Memory: 15.35 GiB used: 2.15 GiB (14.0%) Init: systemd Compilers: gcc: 9.2.0 Shell: bash 
           v: 5.0.11 inxi: 3.0.37
Graphics:  Device-1: Intel UHD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.20.7 driver: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.3 

here is my 'mhwd -li'

> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI


Warning: No installed USB configs!

So I've been attempting to install my Nvidia drivers for my GTX 1060 Max-Q. I've been following the manjaor wiki and used Nouveau. After finally getting that to work, I'm now unable to run the command

sudo nvidia-settings

as I will be hit with this error.

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

When I was searching the error up I was mostly finding stuff related to bumblebee and stuff, not prime. When I went to the FAQ on here and I found instructions on how to set up prime, however, I end up getting stuck on step 3.1

Firstly, remove /etc/X11/xorg.conf.d/90-mhwd.conf and replace it with:
/etc/X11/xorg.conf.d/optimus.conf

The issue is, I don't have 90-mhwd.conf. All that's in xorg.conf.d directory according to the command 'ls -la' is

drwxr-xr-x 2 root root 4096 Feb 13 23:52 .
drwxr-xr-x 5 root root 4096 Dec 29 03:14 ..
-rw-r--r-- 1 root root 266 Feb 3 08:51 00-keyboard.conf
-rw-r--r-- 1 root root 108 Feb 13 23:52 10-optimus-manager.conf

Now I do see the optimus.conf file, which seems like it could be the new target for this step but I haven't made any changes to it yet. Currently when opening it in a text editor I get

Section "Device"
	Identifier "intel"
	Driver "modesetting"
	BusID "PCI:0:2:0"
	Option "DRI" "3"
EndSection

Which is similar to the code that step 3.1 has

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "AllowEmptyInitialConfiguration"
EndSection

Except this mentions nvidia, while the optimus.conf file talks about intel.

I haven't done anything yet, but I'm kind of stuck now. I can't seem to figure out what to do. Based on my 'inxi -G' it doesn't even look like a driver for the card is installed (although maybe that's because I'm using nouvea?) and I can't check the settings because the driver's not loaded.

Any help would be appreciated, but I'm still new to linux, so being a bit more hand holdy would be heavily appreciated. If there is a post with the same issue as me that I missed, just feel free to link it instead of answering. Thanks!!!

1 Like

What are you trying to do?

  1. Get nVidia working and screw without Intel and you won't be able to switch between the 2?
  2. Get both Intel and nVidia working and switch between the 2?

If 1:

  1. Warning! Whenever you want to switch back to your GUI
    Ctrl+Alt+F1 is your friend!
    Actually write down on a post-it right now:
    Ctrl
    Alt
    F1

  2. Save all your data and end all applications currently running

  3. Now switch to TTY2 with Ctrl+Alt+F2, log on and execute:

    sudo mhwd --remove pci video-hybrid-intel-nvidia-440xx-prime
    sudo mhwd --install pci video-nvidia-440xx
    sudo reboot
    
  4. Enjoy! :innocent:

If 2:

Read this excellent post:

:wink: :innocent: :+1:

3 Likes

For the first solution, just want to check before I try this later, but would I run into any kind of confliction issues doing this based on what I have already done to my system with nouveau and stuff?

So I ran the first option you said and it seemed to work seamlessly. No errors or anything. However, when I run inxi -G I get the output

Graphics: Device-1: Intel UHD Graphics 630 driver: i915 v: kernel
Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A
Display: x11 server: X.Org 1.20.7 driver: modesetting resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.6 Mesa 19.3.4

big part being that it still doesn't have a driver for the nvidia card. So I'm just wondering, how would I go about making sure my computer is in fact leveraging the nvidia card. Other than that, thanks for answering and helping out dude.

Edit: Forgot to also do and post mhwd -li, here it is

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

video-nvidia-440xx            2019.10.25               false            PCI

Your confusion comes from the fact that you didn't understand what those mhwd scripts are and how GPU driver works.

Basically, drivers are not configured (Arch base is in vanilla state, you must configure it all yourself manually) so installing them usually ends up with a black screen. Also, each hardware is different and needs different sets of driver packages. That is why Manjaro developers created MHWD, a script that scans your hardware, assigns one of the possible scenarios and installs all needed packages and configures them properly to run.

MHWD is not perfect and sometimes configs may fail you, again each hardware is different.

Anyway, that whould you see on MHWD list are predefined configurations. So when you use mhwd (in commandline or with GUI) you are doing a lot of stuff at once with a single click or command.

So if you had:

video-hybrid-intel-nvidia-440xx-prime

This meant, you already had both Intel and Nvidia drivers installed and configured. By default, the desktop uses Intel drivers and to run Nvidia you need to specify an environmental variable which you can do by adding to a start command before the app name

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia appname

where appname is any name of the program you want to run, so like steam, krita, etc.

An exception are Vulkan based apps, so mostly Proton based games. If Vulkan is used, it will use Nvidia automatically. In all other cases you need to add this command above.

So basically, your computer was all set and you had this Nvidia drivers all along. You just didn't know how to use them.

This kind of setup is known as a Hybrid setup. It has its drawbacks (like no external monitor output and the fact that Nvidia is rarely powered down completely so it's using more battery than pure Intel setup, but the newer hardware the better Hybrid is with battery savings).

video-nvidia-440xx - means that this is purely Nvidia based setup, all is run with Nvidia all the time. It's convenient if you are a heavy gamer but on a laptop it's uses a lot of battery power so you lose your mobility. So that is where you are right now.

If you want to be able to switch between different drivers and different modes (Intel, Hybrid, Nvidia), you need to go back to the video-hybrid-intel-nvidia-440xx-prime and then read carefully the tutorial how to install and configure optimus-manager.

As to the drivers themselves, for example nvidia-440xx-utils plus kernel module is actually the driver packages. YOU SHOULD NEVER INSTALL/UNINSTALL THEM MANUALLY. This is not Ubuntu where such things were done. In Manjaro you use MHWD and you save yourself a lot of headache.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by