Setting up PRIME Synchronization on AMD and NVIDIA [Help] -- video-hybrid-amd-nvidia-440xx-prime

The issue is the following. I’m currently running Manjaro 20.0.1 with GNOME. And I installed the hybrid driver for NVIDIA 1050TI which would be 440.82. mhwd did setup PRIME properly and I am able to run apps with the 1050TI but I experience severe tearing in all games.
The nvidia_drm module is active and all fine but PRIME Synchronization is not running. I tried setting it on xrandr with xrandr "display" --output --set "PRIME Synchronization" 1 but it fails and games continue to tear.

I am quite unsure how to manually set this up since the iGPU is a Ryzen 8 and most configurations are for intel. Even documentations are geared towards intel of course.

Here is the output of my xrandr --listproviders :
xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x55 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 4
outputs: 2 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
Provider 1: id: 0x1f7 cap: 0x0 crtcs: 0 outputs: 0 associated providers: 0 name:NVIDIA-G0

Edit:
nvidia-smi also works fine and detects the external GPU working when I play games or anything I decide to run with it.

see this topic

1 Like

Haven't tried this one yet although it does seem similar to what I had originally tried. I'll give it a try in a few hours and I'll let you know how it goes.

Thank you!

Well I did check on that forum but the issue still persists. There has been a small improvement but overall the same.

I was on the intel hybrid driver beforehand which still handled prime-run properly. Except that in both drivers, I'm still experiencing tearing.

This is the accumulative sum of what I could gather so far:

Ok soooo I wrote a post regarding this but shouldn't hurt to ask here. I have a Ryzen 5 3550H with a 1050TI and I used to be on the hybrid intel/nvidia 440 driver but now switched to the AMD one. Both seem to be working extremely similarly for me. But the issue I seem to have in game is tearing.

The drm module is set to 1 but xrandr has no option for Prime Synchronization so I end up having to wonder where I'd set that up if possible at all. The tear is a single line horizontally at the top of my screen.
Could anyone assist with the configuration? Or maybe can I get some guidance to a doc or anything since most is aimed towards Intel/Nvidia?

I'm running the current 5.6 kernel and battery life and everything else is snappy but I can't escape the tearing.

Here is some output from dmesg regarding the drm module:

sudo dmesg | grep drm
[ 1.847057] systemd[1]: Starting Load Kernel Module drm...
[ 1.854927] systemd[1]: modprobe@drm.service: Succeeded.
[ 1.855343] systemd[1]: Finished Load Kernel Module drm.
[ 2.226117] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[ 2.929212] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 2.929215] [drm] No driver support for vblank timestamp query.
[ 2.929221] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 0
[ 3.230569] [drm] amdgpu kernel modesetting enabled.
[ 3.231158] fb0: switching to amdgpudrmfb from EFI VGA
[ 3.237147] [drm] initializing kernel modesetting (RAVEN 0x1002:0x15D8 0x1025:0x1366 0xC2).

eDP is the output of my GPU under xrandr --verbose

And this is the error when trying to set PRIME Sync to 1:

xrandr --output eDP --set 'PRIME Synchronization' 1
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 11 (RRQueryOutputProperty)
Serial number of failed request: 33
Current serial number in output stream: 33

These are my configs under /usr/X11:

/usr/share/X11/xorg.conf.d/
10-amdgpu.conf 10-radeon.conf
10-amdgpu-nvidia-drm-outputclass.conf 20-nvidia-prime.conf
10-evdev.conf 40-libinput.conf
10-intel-nvidia-drm-outputclass.conf 70-wacom.conf
10-quirks.conf

And lastly. My OpenGL renderer:

OpenGL renderer string: AMD RAVEN (DRM 3.36.0, 5.6.15-1-MANJARO, LLVM 10.0.0)
OpenGL renderer string: GeForce GTX 1050 Ti/PCIe/SSE2

Edit: Also I'm sorry for the late reply. I had a long project on python with a few sleepless nights.

And if anyone is looking here with the same issue. Fear not.

Turns out that GNOME was not playing well with the automatic configuration supplied by mhwd.

I simply went over to XFCE and the tearing is now gone. I'll have to address some performance issues but at least no more tearing.

Have you figured out what causes PRIME Sync to not work? I tried the Hybrid driver just for the heck of it cause I was curious and I was previously running the non-hybrid PRIME setup.

Things I noticed:

  1. PRIME Sync was not available. I keep getting the same xrandr error as yours even though I have set nvidia_drm module to 1 and active. Playing some games causes severe tearing on mine but no tearing on the desktop whatsoever.
  2. CPU usage goes through the roof! My temps are constantly on 100C when doing a bit of gaming when or when not using the dGPU (I use an XPS so the temps are usually high to begin with). But with old PRIME I get average temps of 70-80 degrees. One of the main reasons I switched back to my old setup.

At first I thought I could live with the tearing since I did see performance improvements in gaming since the only thing the that uses the dGPU was the applications explicitly set up to run with it. But I can't risk the very high temps associated with using this new setup.

I'm using KDE btw( Manjaro stable channel).

Regardless, I still preferred the optimus-switch setup anyway since I can powerdown the dGPU when I'm on BAT power. Though not having the benefits of the offload scheme like better performance is a shame. I could have set it up on another device specifically for it.

Other EDITS: format and typos :slight_smile:
EDIT:
Seeing @dglt's post on another thread, it seems hybrid drivers does not support PRIME Sync at all. Now I just need to figure out why the high CPU usage/temps (even on a fresh Manjaro install) and the terrible tearing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by