Short battery life on my install

I have Acer Predator Helios 300 ( PH315-51 ). [Linux Kernel 5.6.16-1 linux 56]Before switching to manjaro kde from Windows 10, battery life was about 5Hr watching online courses(videos), Normal browsing etc. Not any heavy tasks like gaming or any which might be considered as heavy.
Now I've switched to Manjaro KDE, My battery life is 1Hr-10Min Maximum. I ran test around 5 times, the results are same. The fans spin constantly (slow speed, but they spin almost everytime, I can feel the heat coming from back at any given time).
Is there anything I'm doing wrong in all this?
please help, it is annoying me that my electricity bill is increasing every month of lockdown! (JK, but battery life sucks.)

What option you have adopted for GPU from those available ?

So, previously you had Manjaro Gnome or Manjaro XFCE ? How did you do the switch, fresh install or replacement?

We don't know. Sometimes is not just install and all done, but requires some tweaking. Share from terminal:
inxi -Fxxxza --no-host

1 Like

I had Windows 10 earlier, I fresh installed manjaro on laptop.
Where can I find these GPU settings?

If you didn't set any of those options i linked, there are nowhere on your setup. So, check them out, chose one that suits you best, and report back. Probably, from that list of options you would prefer this, and will aso work for your laptop:

1 Like

inxi -Fxxxza --no-host


Please share it as text. Use ``` above and below it for proper formatting.

1 Like
System:    Kernel: 5.6.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=8979169a-7efe-4486-a40e-9c05a1ceea3e rw 
           quiet resume=UUID=e2dbdf74-2a9d-4578-91d0-ea29a84feb57 udev.log_priority=3 
           Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Predator PH315-51 v: V1.26 serial: <filter> 
           Mobo: CFL model: Sienta_CFS v: V1.26 serial: <filter> UEFI: Insyde v: 1.26 date: 03/27/2019 
Battery:   ID-1: BAT1 charge: 23.9 Wh condition: 40.6/48.9 Wh (83%) volts: 14.9/15.2 model: LG PABAS0241231 
           type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: A (10) microcode: CA L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 1400 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 1400 2: 1401 3: 1400 4: 1401 5: 1400 
           6: 1401 7: 1401 8: 1401 9: 1400 10: 1401 11: 1400 12: 1401 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Acer Incorporated ALI driver: nvidia 
           v: 440.82 bus ID: 01:00.0 chip ID: 10de:1c8c 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
           compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.7 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a348 
           Sound Server: ALSA v: k5.6.16-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 
           bus ID: 00:14.3 chip ID: 8086:a370 
           IF: wlp0s20f3 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8169 v: kernel port: 3000 bus ID: 06:00.1 chip ID: 10ec:8168 
           IF: enp6s0f1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 147.85 GiB (14.1%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1P10 scheme: GPT 
           ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A3J0 
           scheme: GPT 
Partition: ID-1: / raw size: 110.94 GiB size: 108.70 GiB (97.98%) used: 36.03 GiB (33.1%) fs: ext4 
           dev: /dev/sda3 
           ID-2: swap-1 size: 7.81 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) 
           cache pressure: 100 (default) dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 294 Uptime: 1h 12m Memory: 7.62 GiB used: 1.51 GiB (19.8%) Init: systemd v: 245 
           Compilers: gcc: 10.1.0 Shell: bash v: 5.0.17 running in: konsole inxi: 3.0.37 

My battery life has been doomed after installing Manjaro KDE. Help!

IMO your title is very insulting towards the distro you wish to use. Also adding "Help!" in your title is rather redundant as you have obviously opened a help request and this simply comes off as pleading pitifully.

Just sayin, a little more attentention to users sensibilities might be in order when selecting your title. You can edit your title after the fact if you feel like perhaps being more tactful in your wording.


Is the title ok now? or should I change it again?

Let me help on that too :slight_smile:

According to inxi i think you will have to set some acpi custom kernel boot parameters. For that see this:

Together with that, add this custom kernel boot parameter too:

Also, as i pointed out already, you have to make sure the hybrid drivers are properly setup. So, check that last tutorial about it i linked.
Once that is done, and you can switch graphics, we can move to another step to investigate the power consumption.

1 Like

Hardware accelerated video playback in web browsers hasn’t been implemented in any of the major browsers on Linux. At least not by default. That’s one of the biggest power usage differences you’re going to face vs Windows.

You can follow steps found on the following page to try to enable it:

1 Like

I got Optimus manager Qt working....But one thing is that I have skipped tutorial from 9th point which is about driver series 435 and above and has to do with hybrid graphics.(Should I follow tutorial from 9th point?)

I'm already running 440XX. I don't want to use Nvidia at all. I have desktop for Gaming and I don't play on laptop anymore. So should I worry about Hybrid graphics?

With the setup provided initially, you have the dGPU still active. That means you use it or not, is still ON and using power. In order to turn it properly off, you have to use Switch to Intel
At least that is what i understand.

1 Like

I'm Sorry. This will not happen again. After reading the title provided by @bogdancovaciu (Thanks btw :sweat_smile:) I realised that the way my title sounded was completely wrong .

I will take care of this thing in future. Again thanks to @bogdancovaciu . Lesson learned.

It is already set to intel. I switched it once to nvidia and again switched it back to intel.
don't know about dGPU. Should I run that command and send the result here?

Well, the dGPU is de Nvidia GPU. If is already set to iGPU=intel GPU, see how it performs and if you notice same power consumption, same short battery life. Now that you can switch between those profiles with Optimus-Manager, you can find what suits and works better for your laptop.
Next step is to consult this:
By the way, tlp is installed by default, so just check a few settings of it.

I guess something wrong is happening. After replying to you, I left my laptop. After 5 min of inactivity it slept. Battery went from 81% to 66% in just 30 min.
just 1 min after posting this battery is on 62%.

I wonder if switching to 5.7 kernel would be beneficial in your case. Try that and see how it goes. I'm out of ideas, and because i can't find many references about this model, i can't suggest anything more. Maybe someone else will join with something practical.

1 Like

Okay. Let's see if someone joins. Actually I'm new. If you know someone, will you please tag them?
Thanks again.
Edit:- is kernel 5.7 stable?
btw, battery is on 52%

Is not LTS and is no longer an experimental kernel, so is stable enough ...
Does that Acer have some options in BIOS that could help your case? Like disable the dGPU ... some fan control ?

Forum kindly sponsored by