Shutdown problems, desktop freezing

I just recently installed Manjaro KDE. I'm having problems with Shutdown, Reboot, and Logout, whenever I attempt any of these, the desktop just freezes indefinitely and it doesn't Shutdown, Reboot etc.
I've had this problem on Antergos aswell so I'm assuming it might be an Arch problem. I feel like I've tried everything, nothing has worked.

I'm pretty new to Linux, so I'd appreciate answers that are well explained :stuck_out_tongue:

First of all we can't help if we have no idea what your system is. :wink:

So, have a read of this post:

and then post some information here (as text), principally inxi -Fxxxz.

As a new user you should also read:

as well as looking through the other threads in the #faq section.


Thanks for the quick answer.

inxi -Fxxxz seems to hang, and also my touchpad won't work after that command, until restart.

EDIT: The touchpad thing seems to be inconsistent.

Ah, this sounds like an Optimus laptop issue.

Can you boot the live installer and run it there?

Actually, I can't even do that, worked fine when I installed Manjaro yesterday, now I'm stuck at
A start job is running for LiveMedia MHWD Script.
with drivers=free and stuck at
Started TLP system startup/shutdown.
with drivers=nonfree.

Seems like my laptop is cursed with one problem after the other.

Worth reading:

The other option (if it's available) is to disable one or the other GPU in your BIOS settings. Pascal-era Nvidia GPUs are pretty light on battery use anyway.

I've tried the solution linked above, no luck, still stuck at Started TLP system startup/shutdown.

I've also looked through pretty much all the BIOS settings (there aren't a lot), and I'm pretty certain there are no options regarding the GPU.

EDIT: My laptop is an ASUS ZenBook Pro UX501VW btw, don't know if it helps.

When you get to grub, press e, then append a “3” to the line starting with Linux. This should get you into a command prompt. Then run dmesg, and journalctl -b. Look for anything funky. Lastly, try running startx from the command prompt.


It's been a while, I had to resort to using Windows again for the time being, as I was busy with school and couldn't afford to not have my laptop working. But I'm back with a fresh install, and exactly the same problems. I tried what you suggested, assuming you meant appending that to the line running the live media, did nothing, still wasn't able to boot to live media, not even command prompt. Seems like the problems keep stacking up, very frustrating.

Do you know if you have an nvidia graphics card in your laptop?

If you do have an optimus nvidia card, this should help.

I an optimus nvidia card, and it causes all kinds of boot issues for just about any linux that I have tried. The root cause is the nouveau (open source nvidia drivers) just don't work with my card and the kernel hangs at boot or crashes shortly after boot.

Try booting with free drivers only and blacklisting nouveau at boot. If you get to grub press "e" to edit. You'll be able to edit your boot parameters here, the changes will only effect the current boot attempt. You will see something similar to:

linux /boot/vmlinuz-linux root=UUID=978e3e81-8048-4ae1-8a06-aa727458e8ff quiet splash

Add modeset.nouveau=0 to it so it looks something like:

linux /boot/vmlinuz-linux root=UUID=978e3e81-8048-4ae1-8a06-aa727458e8ff modeset.nouveau=0 quiet splash

Press cntrl-x to boot. If everything starts up ok, you know it is a problem with the nouveau drivers. I would suggest blacklisting them permanently at that point.

You can do this by creating a file in /etc/modprobe.d

$ sudo bash -c "echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf"
$ sudo bash -c "echo options nouveau modeset=0 >> /etc/modprobe.d/blacklist-nouveau.

I also open /etc/default/grub file and add my nouveau blacklist there, looks something similar to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash modeset.nouveau=0 rd.driver.blacklist=nouveau"

Then update your grub

sudo update-grub

Try rebooting and all should be well, but the nvidia GPU is effectively disabled and useless on your system. You have some options to improve the situation below, but I would make sure you have a stable booting system before trying 2 or 3! Both methods work, but if you configure something wrong you will fail to boot again and will need to use the live CD to fix/edit things.

Improvements going forward are:
1.) Leave it alone, if all you want is a workstation and/or development station you're likely just fine with the integrated GPU.
2.) You want to game and need that nvidia GPU on all the time and don't care it will reduce battery life:

3.) You want the best of both worlds by selecting which card you use:


The problem has been happening pretty inconsistently, and I suddenly managed to sucessfully shutdown without any problems. I quickly rebooted, and was able to successfully run inxi -Fxxxz.

This is the output:

System:    Host: kristian-pc Kernel: 4.19.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.15.3 
           tk: Qt 5.12.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: N501VW v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: N501VW v: 1.0 serial: <filter> UEFI: American Megatrends v: N501VW.204 date: 11/12/2015 
Battery:   ID-1: BAT0 charge: 81.6 Wh condition: 81.6/96.0 Wh (85%) volts: 11.4/11.4 model: ASUSTeK ASUS Battery type: Li-ion 
           serial: <filter> status: Not charging cycles: 240 
CPU:       Topology: Quad Core model: Intel Core i7-6700HQ bits: 64 type: MT MCP arch: Skylake-S rev: 3 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41488 
           Speed: 1057 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1137 2: 1075 3: 1108 4: 1104 5: 1122 6: 1097 7: 1100 
           8: 1104 
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: ASUSTeK driver: N/A bus ID: 01:00.0 chip ID: 10de:139b 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 19.0.1 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a170 
           Sound Server: ALSA v: k4.19.32-1-MANJARO 
Network:   Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 bus ID: 03:00.0 chip ID: 8086:095a 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 253.38 GiB used: 12.39 GiB (4.9%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS256G39MND-2300A size: 238.47 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 0L00 scheme: GPT 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 14.91 GiB serial: <filter> rev: 1.20 scheme: MBR 
Partition: ID-1: / size: 233.43 GiB used: 12.39 GiB (5.3%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2100 
Info:      Processes: 218 Uptime: N/A Memory: 7.68 GiB used: 597.3 MiB (7.6%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.2 running in: yakuake inxi: 3.0.32

The problem seems to come and go.


It would be nice if you repair your post. Use paragraph code format, not inline.

this before and after paragraph >> ``` <<

Code text

1 Like

Sorry, done

1 Like

Could you share if you did something differently to make it shutdown?
I have the same configuration of graphics card as yours and have this same issue.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by