Sleep and Hibernate issue with UEFI

I decided to convert my GRUB special partition to UEFI and install Manjaro (before was Ubuntu grub), and since then hibernate mode is broken. It worked perfectly with special 'grub' partition in ubuntu and manjaro, but not with UEFI partition. Seems like laptop just can't shutdown completely. It stuck with a black screen, but power on.. Any suggestions how to fix it?

$ inxi -Fxzc0
System:    Host: mf-laptop Kernel: 4.19.62-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.3 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: K53SD v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: K53SD v: 1.0 serial: <filter> UEFI: American Megatrends v: K53SD.208 date: 08/10/2012 
Battery:   ID-1: BAT0 charge: 0.9 Wh condition: 0.9/57.2 Wh (2%) model: ASUSTek K53--52 status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mobile Mouse MX Anywhere 2 charge: 55% (should be ignored) 
           status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech K520 charge: 70% (should be ignored) status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35128 
           Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 807 3: 798 4: 798 5: 798 6: 797 7: 798 8: 798 
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel 
           bus ID: 00:02.0 
           Device-2: NVIDIA GF119M [GeForce 610M] driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: intel resolution: 1366x768~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.1.3 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Device-2: Micronas type: USB driver: snd-usb-audio bus ID: 3-1.1:3 
           Sound Server: ALSA v: k4.19.62-1-MANJARO 
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: e040 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: ASUSTeK driver: atl1c v: port: 9000 
           bus ID: 05:00.0 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.39 TiB used: 1.76 TiB (73.5%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST2000LM003 HN-M201RAD size: 1.82 TiB 
           ID-3: /dev/sdc type: USB model: Multiple Card Reader size: 119.08 GiB 
Partition: ID-1: / size: 39.62 GiB used: 14.11 GiB (35.6%) fs: ext4 dev: /dev/sda7 
           ID-2: /home size: 62.40 GiB used: 8.65 GiB (13.9%) fs: ext4 dev: /dev/sda8 
           ID-3: swap-1 size: 7.63 GiB used: 2.0 MiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 57.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2400 
Info:      Processes: 256 Uptime: 5h 35m Memory: 7.57 GiB used: 1.96 GiB (25.9%) Init: systemd Compilers: gcc: 9.1.0 
           Shell: bash v: 5.0.7 inxi: 3.0.35 

Hi @Slimy,

would be nice if you read this, first:

Could it be that your battery needs to be recharged or replaced? It's quiete low, maybe that's the reason.

No. Cant be. It's for sure related only with software

Did you check for any error-messages (journalctl -r for example)?
Check the timestamps carefully after reboot or if you get the machine up again from this state. And check if/what messages are missing that should be there.

I have the same issue on my Dell laptop. It appeared after some July-August update...

Well, thank you for your answer. But I'm just lost my options on this. And convert back to BIOS_GRUB and now it fine again. So fo sure issue with UEFI boot only.

This topic was automatically closed after 180 days. New replies are no longer allowed.

Forum kindly sponsored by