Slow Boot (more login really, hard to tell) - disks , maybe cache cpu

Hi All,

this issue has been driving me mad for some time now. My machine is very slow booting, taking several minutes before I can use Manjaro.

I dual boot with Windows 10 and Mint 19 on the same machine, both of those boot up in a very short space of time, this is limited to Manjaro (KDE5).

I have made a pastebin with what I hope are useful logs and details.

After grub the system seems to 'boot' quickly, around 10-15 seconds. At which point I get a black screen and the cursor. Then several minutes pass before the desktop appears and Steam loads etc...

I've had a clear out of files in my home directory, old apps and configs I am definitely not using. I have enabled haveged ( sudo systemctl enable haveged --now) and disabled some animations in KDE as I read somewhere it might help (it didn't).

Any suggestions on next steps would be appreciated.

Thanks in advance,
Noki

I just tried disabling the 'quiet' flag on grub and it is definitely not boot up.

I think the culprit is KDE (or SDDM), can I clear any configs for those apps and rebuild them without a re-installation. I don't mind losing settings if it fixes this issue.

Your system is probably low on entropy. This post below will explain how to remedy that. :arrow_down:

3 Likes

What you report/experience is not how it looks in the logs, I don't know what's the reason.
I can see a delay of about 2 minutes because of drive sector errors (sdc).
Search the posted log for sector to see.
Maybe the rest of DE delay has something to do with that as well.

1 Like

I've been through the posts linked and tried all the things. I guess I have done something strange to have caused this.

sdc is the newest disk in the machine, only a couple of months old. It became my new /home disk recently. I used rsync to copy most of my previous one over.

My guess is I have copied over something from a previous install (perhaps even distro) which has caused this. I've been distro hopping every few months for the past couple of years. My wild hedonism is catching up with me it seems.

A re-installation with another back up and rebuild of the /home partition seems to be in order. Though a more carefully planned one.

Thanks for you help.

I have just completed a full re-installation. I backed up my home drive and nuked it during the install process.

I built a new GPT table and partitioned and formatted the whole disk to be a new /home

The root drive was also killed and the /boot/efi partition is the one Windows 10 made which works usually. So a nice freshilicious install.

Booted up and get the same result, journalctl -b and -p3 in a pastebin here. It is rather irritating.

Could the disk be bad? this a new drive I brought from Amazon about 2 months ago. It seems to work fine as I run games copy files around and it appears fine once it's up and running. Speedwise I have hasd no complaints. Just this slow boot thing that I can't explain.

Perhaps tomorrow I'll do and install and try putting home on another known to be working partition on another disk, see what happens.

Is there a way I can test the SSD to see if I do have a dud.

I'm really stuck at this point.

Thanks again,

Noki

If you are starting Steam...etc. on login, there's your problem.

1 Like

In this instance on a fresh install the system is clean. Only the default packages.

Hi, I'm Confused. Nice to meet you! :handshake:

If it is not haveged or a bad disk, try changing your grub to grub-vanilla.
People with windows and manjaro have experienced problems with this.
As in your previous installation, if you leave alone the black screen of death for say 2 minutes, see if that boots up. And tell us what that boots up to.

ps: I'm basing this on the fact you do not have a problem with Linux Mint.

1 Like

I never had this issue with Arch neither. I am perplexed to say the least.

Thanks for the help so far but I am at a loss.

Testing the disk has come up empty, I ran a FSCK from a live USB that found no errors.

I then used GSmartControl to run an Extended test on the SSD that took 80 mins. No errors found.

The only test I can think of is to replace the cable that drive is using, maybe try formatting it in NTFS and letting Windows have a go with it, see if it shows anything else.

Beyond that I am stumped. If the drive is ok then my issue is software, and I'm not sure what to check next.

I have nearly the same Hardware but newer Kernel (unstable). I have no OC but it work fine up to 4200 MHz, you have OC 4300 MHz.

System:    Host: mx Kernel: 5.3.1-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: i3 4.17.1 info: i3bar 
           dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: P8Z77-V DELUXE v: Rev 1.xx serial: <filter> BIOS: American Megatrends v: 2104 
           date: 08/13/2013 
CPU:       Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56185 
           Speed: 2431 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1808 2: 1679 3: 1619 4: 1642 5: 1676 6: 1765 7: 1783 
           8: 1656 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ZOTAC driver: nvidia v: 435.21 bus ID: 01:00.0 
           chip ID: 10de:1c03 
           Display: x11 server: X.Org 1.20.5 driver: nvidia compositor: compton resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 direct render: Yes 
CPU:       Topology: Quad Core model: Intel Core i7-3770K bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 56185 
           Speed: 2431 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1808 2: 1679 3: 1619 4: 1642 5: 1676 6: 1765 7: 1783 
           8: 1656 

My boot time on i3wm (grub-vanilla) and KDE (btrfs-grub) is ~5sec.

~ >>> systemd-analyze                                                                                                               
Startup finished in 2.316s (kernel) + 2.847s (userspace) = 5.164s 
graphical.target reached after 2.658s in userspace

Try Manjaro minimal OS without gaming stuff :wink:

I've given up for now, this issue is persistent and limited to Manjaro.

I will give up for now, try again in a few weeks unless anyone has any further suggestions?

Thanks,
Noki

Try other kernels. It happens...
And...

Don't use parts of other systems when creating a new Linux system (unless you know what you are doing). It is often a reason for such troubles (not that it is for your current one...)!

4 Likes

Yeah I recently did a clean install, rebuilt the GPT table and made a new partition for home. All clean and fresh.

I haven't tried other kernels, but over the past few months I have installed a few as part of regular updates. Just never manually selected a different one. Guess that's another thing I could try.

I totally agree with @Agents. You create a FrankenManjaro then want the helpers on the forum to troubleshoot your issue. That is impossible if you have a non-standard install. Don't put this on Manjaro unless you have done a fresh install of one of the official Manjaro editions.

3 Likes

Hope he listens to you, artists, like me, are not always taken so seriously :wink:

3 Likes

As I have stated since the original post. I am now on a completely clean install with fresh partitions created during the install of Manjaro (from a USB stick I downloaded and made the same day as I installed).

The slightly borked /home folder had nothing to do with this issue, as it is still happening with the clean and fresh install.

1 Like

Find what runs CPU in process manager.
Possible apps:

  • baloo
  • updatedb
  • pamac*
  • dropbox, megasync, insync etc (cloud sync)

Check your autostart apps and services.

Run systemd-analyze blame and systemd-analyze --user blame.
Also make a graffic

$ systemd-analyze plot >bootup.svg
$ systemd-analyze --user plot >login.svg

Open with a viewer.

3 Likes

check if partition alignment is correct on SSD

sudo parted /dev/sdX align-check optimal Y

replace X with drive letter for SSD
replace Y with partition number(s)

1 Like

Forum kindly sponsored by