Slow boot to Manjaro, strange update-grub output

Grub menu does not show up?
Can you boot now into manjaro?
How, if the boot menu does not show?
Above quotes shows it did.

Please confirm. Can you boot into manjaro?

ps: don't worry about tmpfs now. It doesn't matter. And it doesn't matter if it is in fstab or not in fstab. We don't need to worry about it now.

ps: there is no need to reinstall Arcolinux.
Just change the fstab uuid for its /boot/efi
Then from Manjaro grub (if it is working, it should be) manually boot Arco and then just do grub-install && update-grub.

To boot manually arco, at manjaro grub menus, go to prompt and boot manually
grub> set root=(hd0,3) # if it is in sda3, if sda4, (hd0,4)
grub> linux /boot/vmlinuz-linuz root=/dev/sda3 rw
grub> initrd /boot/initramfs-linux.img
grub> boot

When booted,
sudo grub-install
sudo update-grub

I'm away from the computer right now.

Yes, I can boot to Manjaro, but I do not see the Manjaro boot/grub screen. It goes from the "interrupter option screen" to black, then eventually to Manjaro login screen.

I have installed the previous lts kernel but do not know how to select it to use if I don't have the grub screen option to select it.

Spencer

Okay, don't worry about it. just press 'esc' (within 5 seconds) to see the grub menu.
It's our brand new grub (sarcaasm) that works that way.
We'll fix it after we fix Arco.
See my edited last post on how to fix arco.

ps: I don' use SArco, check if kernel is in /boot and is vmlinuz-linuz and initramfs file is initramfs-linux.img.

Also is arco in sda3 or sda4? I think sda3, but confirm.

I did try this earlier before the most recent reinstall and I had the grub screen to work with. I didn't notice any improvement. The Arcolinux was running the 4.20 kernel and it booted very quickly.

I'll give it a shot when I get home.

Arco was installed in sda3 but I have not reinstalled yet.

Check my recent posts.
Good luck and good night.
ps: @AgentS, if he is not sleeping, can help you when I'm sleeping.

2 Likes

Good night and thank you for your help!

Looks like it.

ls /boot
efi                                 intel-ucode.img
grub                                linux414-x86_64.kver
initramfs-4.14-x86_64-fallback.img  linux419-x86_64.kver
initramfs-4.14-x86_64.img           memtest86+
initramfs-4.19-x86_64-fallback.img  vmlinuz-4.14-x86_64
initramfs-4.19-x86_64.img           vmlinuz-4.19-x86_64

I'm not sure how to do this. I no longer have a /boot/efi/EFI/Arcolinux.

$ ls /boot/efi/EFI
boot  Manjaro

How do I know what UUID to enter into fstab?

Still not seeing grub menu. Press 'esc' within 5 seconds of what? If I press during reboot before interrupter screen, then it gives me a diagnostic splash screen. If I press after the interrupter screen it gives me nothing until login shows up.

as soon as you see the bios splash screen at boot, you can also hold or tap shift repeatedly during boot and that should show you the grub selection

1 Like

Strange. I just tried that. rebooted from terminal, saw the splash screen and started tapping shift repeatedly. No grub showed up but the boot was very quick like I would normally expect it. How would pressing shift accelerate this?

EDIT:

So I was reading the documentation on systemctl to learn how to enable and disable systemd-swap and i found the systemctl reboot command. Previously I was only using reboot to perform a reboot on the system. The grub menu showed up! Is there a difference in execution between the two commands?

I chose Advanced Manjaro and selected the 4.14 kernel. There seems to be no improvement over the 4.19 kernel.

Further consideration. Would it be possible for the grub menu to be there but I simply couldn't see it, and thus it was waiting for my response until it timed out? This could account for some of the delay. Also, does pressing shift accelerate through that selection?

Okay, I'm happy but a wee bit befuddled. I've shutdown then restarted the system, and rebooted several times now and the grub menu is showing up reliably and boot time has drastically decreased. I've switched back and forth between the 4.14 and the 4.19 kernels and updated grub after each change. Both are now booting fine and quick.

I'm not sure exactly what fixed the issue, but I'm sure it was a combination of everything y'all have suggested. I'll update if anything changes as I add in some programs and change things to the way I like them.

EDIT:
I'll take a look at the several things we looked at earlier to see if there are any big differences.

1 Like

hey, it's working. thats all that matters. glad it worked out :+1:

1 Like

If the slowness was in the system stage, it maybe explained by the lack of system entropy.
If so, you may install and enable haveged.

If the problem is entropy, yes.

You can chroot in Arcolinux, mount $esp at /boot/efi and install grub, as suggested by the "sleepless" @gohlip :stuck_out_tongue_winking_eye:.

2 Likes

The UUID in Arco fstab is same as in Manjaro's, because it is the same $esp partition.

UUID=E597-DAFE  

Boot into Arco (after fixing its fstab) when you get to see Manjaro grub and then press 'c'
You will get to grub prompt (grub>). Then enter these commands and press 'enter' after each command.

When booted (to Arco)

To fix Manjaro's grub.. (refer here), at Manjaro terminal...
In /etc/default/grub, add this line

GRUB_TIMEOUT_STYLE=menu

Also in /etc/default/grub, change

GRUB_TIMEOUT=10

At terminal,

sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install 
sudo update-grub

And these 2 additional commands

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/sda -p 1 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"

And note you must use Manjaro's grub (or refind or systemd-boot) to boot Manjaro.
Arco grub cannot boot Manjaro. So you must set Manjaro grub as default.
At Arco or Manjaro terminal..

sudo efibootmgr -o 0011

Unless you do not have or want Manjaro, Manjaro bootloader must always be the default.

(also sleepless) @AgentS is right about the entropy part (haveged). But the key to get to the manjaro grub is to use 'esc' key.
You might get away with 'shift' or 'F8' but if your system does not allow it, you will get error 'Interrupt key not found'. Just use 'esc' key to get to grub menu. But with the changes in this post, your menu will appear (entropy excepted).

2 Likes

Evening gents. Thank you for the thorough responses.

I was having trouble with your instruction re: booting into Arco because I didn't have Arco installed on my drive anywhere after i used the live environment to reformat the drive. I had erased everything, built a new partition table, and then installed Manjaro. Were you referring to booting to Arco in a live environment, editing fstab with UUID, etc? If so, I missed the boat on that. :sweat_smile:

Regarding entropy, I ran cat /proc/sys/kernel/random/entropy_avail earlier before any re-installation and got a value of 3628. It was suggested to install haveged if I was below 1000. Is this acceptable or should I still install haveged?

There is nothing like the energy of an 18 month old and a 3 year old to encourage a little impatience. I went ahead and used the Arco USB and installed Arco to sda3. I then rebooted, went into BIOS to place Manjaro at the head of the boot order. Manjaro Grub showed up (on its own accord) with Manjaro as the only option. I ran sudo update-grub and it detected Arco on sda3. I rebooted, Manjaro Grub showed up and both Manjaro and Arco were there as were their associated "advanced" options. I tested booting into both OS's from Manjaro grub successfully. Both booted quickly (~10seconds) and appear to be functioning well.

Are there any outputs I can provide right now to see if I need to take further action? @gohlip, you have suggested a few things in your most recent post. Do you still recommend them if things appear to be working well?

Thanks again for your time!

Spencer

EDIT: I'm still processing through the suggestions you made and reading the wiki's and tutorials you both referred me too. Thank you!

1 Like

Since everything is working fine now, there's no need for further action,
But if Manjaro's grub gives you some silliness, you can do the changes in /etc/default/grub and the terminal commands after that.

Cheers, take care. And you're welcome.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by