Slow GPU performance with Intel on Bumblebee

Hi community,
I enabled hardware acceleration on Chrome, but very bad video performance. That is why sadly I launch Chrome with --disable-gpu option, and again video performance is not good. One more when I run primusrun google-chrome-stable or primusrun chromium, it gives me mesa libgl errors. How do I get GPU performance better on Bumblebee?

Take a look at this:

I don't know how good is Wayland in GNOME with hybrid GPU's, and what can be done for better performances.

Problem is that I can't run primusrun with chrome or chromium. It gives me errors that I said above.

Be specific, include both the command line commands and the exact output. Without this very difficult to help you.

Is it only chrome giving you performance errors?

What is the FPS output of

glxgears
primusrun glxgears

Have you tried X instead of Wayland?

EDIT :

I gather you have enabled hardware acceleration in chrome? Have a read of this, which covers this with optimus tech

https://bbs.archlinux.org/viewtopic.php?id=194418

More generic info on hardware acceleration in Arch

https://wiki.archlinux.org/index.php/Hardware_video_acceleration

There have been documented bugs with hardware acceleration with Wayland also. Not sure if any are still outstanding.

465 frames in 5.0 seconds = 92.816 FPS
300 frames in 5.0 seconds = 59.997 FPS
300 frames in 5.0 seconds = 59.986 FPS
301 frames in 5.0 seconds = 60.016 FPS
300 frames in 5.0 seconds = 59.992 FPS
301 frames in 5.0 seconds = 59.999 FPS
301 frames in 5.0 seconds = 60.007 FPS
290 frames in 5.0 seconds = 57.845 FPS
301 frames in 5.0 seconds = 60.010 FPS
300 frames in 5.0 seconds = 59.992 FPS
300 frames in 5.0 seconds = 59.993 FPS
301 frames in 5.0 seconds = 60.012 FPS
300 frames in 5.0 seconds = 59.985 FPS
300 frames in 5.0 seconds = 59.997 FPS

With hardware acceleration on chrome I noticed color confusion on videos(especially on blue suit). However in chrome with option disabled gpu or disabled hardware acceleration, video performance better than this. In firefox also same.

Screenshots:

Screenshot-20170918104738-1366x736Screenshot-20170918104754-1366x736
In chrome WebGL is the main problem for videos, becaus of gpu.

Same within Xorg.

primusrun google-chrome-stable

primus: warning: reusing initial X connection for display thread
libGL error: MESA-LOADER: failed to retrieve device information
libGL error: unable to load driver: i915_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i915
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
[7929:8246:0918/114227.475875:ERROR:x11_util.cc(77)] X error received: serial 34, error_code 157, request_code 152, minor_code 6
primus: fatal: failed to acquire direct rendering context for display thread

If the option hardware acceleration disabbled in chrome primusrun google-chrome-stable works..

Strange behaviour. Disabling Gnome Control Center -> Color -> Laptop Screen fixes my issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by