Slow/Laggy animations

Hi everybody
Sorry my question might seem silly
My kde plasma animations(transitions like maximizing/minimizing) are sooooooooo much laggy
Take a look at it:
Screen Recording
How can I fix that?

It helps if you tell us what hardware you are using. Right in the forum instructions, it says to post the output of

inxi -Fxxxazc0 --no-host

Thanks
You're right i forgot that
This is my specs:

System:    Kernel: 5.6.3-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 root=UUID=96a0b878-81c6-4185-a7dc-35203f8f78f0 rw 
           quiet apparmor=1 security=apparmor resume=UUID=9455bd93-79ea-45ef-86ab-3398c5e8844e 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 81DE v: Lenovo ideapad 330-15IKB serial: <filter> Chassis: 
           type: 10 v: Lenovo ideapad 330-15IKB serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO v: 8TCN53WW date: 05/17/2019 
Battery:   ID-1: BAT0 charge: 5.3 Wh condition: 25.0/30.0 Wh (83%) volts: 7.6/7.6 model: LGC L17L2PF1 
           type: Li-poly serial: <filter> status: Charging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: A (10) microcode: CA L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 32012 
           Speed: 800 MHz min/max: 400/1800 MHz Core speeds (MHz): 1: 800 2: 800 3: 794 4: 800 5: 800 6: 800 
           7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Lenovo driver: nvidia v: 440.82 bus ID: 01:00.0 
           chip ID: 10de:1d10 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.6.3-2-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo driver: ath10k_pci 
           v: kernel port: 3000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: <filter> 
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:3 chip ID: 0cf3:e500 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 1.82 TiB used: 172.75 GiB (9.3%) 
           ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: LDM2 scheme: GPT 
Partition: ID-1: / raw size: 1.80 TiB size: 1.77 TiB (98.38%) used: 172.75 GiB (9.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 17.11 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) 
           cache pressure: 100 (default) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 61.5 C mobo: N/A gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 253 Uptime: 1h 02m Memory: 15.55 GiB used: 1.92 GiB (12.4%) Init: systemd v: 244 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.16 running in: konsole inxi: 3.0.37

I can tell you that laggy resizing on browsers is a known issue and it's not KDE fault. It's a complicated, upstream issue and depending on a site, it will look ok or completely uneven.

However, dolphin and other apps should transform smoothly, so something is off. Maybe it's just settings or maybe issue with drivers?

You have hybrid GPUs so you may want to have more advanced setting then default one so you could switch drivers and GPU modes at will:

Thank you so much
Yes I installed that
I'm using my Intel card
So I guess everything should be ok, then why it's still laggy?
Someone told me to install nvidia drivers
But I think I did so already
Take a look at thisScreenshot_20200413_182110

video-linux is not needed on this list and may be causing the issue. Remove it. Of course, make a backup so you could reverse the change if it goes wrong.

I'm using optimus-manager myself and I have only video-hybrid-intel-nvidia-440xx-prime, which is enough to have all possible configurations.

Also, when you have optimus-manager, you can switch Intel drivers from Intel (non-free) to modesetting (free) to see if it changes anything.

Of course, you can also check out your kwin settings or tweak desktop effects you use, because it may be just a simple change of settings.

Thanks
I checked everything on desktop tweaks list but none of them solved my problem
This is the full list of tweaks
Screenshot_20200413_183503 Screenshot_20200413_183458 Screenshot_20200413_183447 Screenshot_20200413_183435
Also I myself edited the hardware list and installed video-linux for intel. Thanks for the help.Should I remove video-modesetting and video-versa on the list as well?

Sorry I have another question
Is there something wrong with these settings?
Screenshot_20200413_183812

No, relay on the mhwd, so remove only video-linux. Rest is installed by your current video-hybrid-intel-nvidia-440xx-prime configuration, so manually uninstalling any graphic related packages would just break things.

Remember, that those options on mhwd list are just CONFIGURATIONS, not packages or drivers, so each configuration installs and configures a set of packages/drivers.

As to the settings you showed, they depend on hardware so for some different setting will be the right one, so I can't tell. If optimus-manager works, then leave as it is. I have a similar setup but the difference is that I use nouveau for switching, which works for me, but often doesn't work for others.

So What's wrong with my system after all?
Is it because hardware configurations, drivers, display compositor, etc?

I don't know. This isn't a specific issue that would point to one issue. At the moment you have unneeded graphical packages that MIGHT be causing this problem. Or this could be something entirely else, but let's remove one problem at a time.

Like I said: video-hybrid-intel-nvidia-440xx-prime installed already all needed packages and video-linux is just overkill which could cause potential conflicts.

Ok now I removed it
now it looks like it:
Screenshot_20200413_184707

Ah, I thought that you are talking about some packages. Sorry. Yes, video-modesetting and video-vesa are also unneeded, so yeah, uninstall them as well.

video-hybrid-intel-nvidia-440xx-prime already added all packages for both intel and nvidia. Other configurations are just competition that cause issues.

Sometimes there are dependencies, so if those operations break something and you won't boot into graphical session, simply use mhwd commands to remove current video-hybrid-intel-nvidia-440xx-prime and install it again, to fix the configuration. But maybe this won't be needed, so don't do it just now.

Ok now I removed those two as well
Now what should I do? :sweat_smile:

Reboot and cross your fingers, because if something went wrong, graphical session won't start and you will have access to tty only. So have some additional computer or phone on the side, so you could check forum or commands on the web to fix the issue.

Yes I have the forum on my phone
Ok now I restart and then will tell the result

It's still the same
I just notice one weird thing right now !
https://streamable.com/isk5u8

Hmm... No idea what that is, never seen anything like it.

What Intel drivers do you use at the moment. Intel or modesetting? I have modesetting myself.

Screenshot-2020-04-13-16-38-59

Screenshot_20200413_191100

OK, change Tearfree do Yes, and DRI to 3. Not sure what it will do, but it works for me :wink:

As to the weird effect with Dolphin, it could be a cache issue, so you may way to delete the insights of ~/.cache, reboot. Apps will populate the cache again when needed.

Forum kindly sponsored by