Slow to respond mute/unmute Fn key

Hello everyone,

I've recently made the switch to Manjaro Xfce from Lubuntu and have been loving almost every bit of it. Unfortunately, I am having just this one issue that's starting to drive me slightly insane. Occasionally when I startup the machine I'll get a message saying "Disabling IRQ #36". Sometimes I'll see this briefly, and other times the machine will hang there. When I am able to boot I checked cat /proc/interrupts and see that for number 36, that one of the processor cores is at max clock speed. The line reads: "IR-IO-APIC 22-fasteoi snd_hda_intel:card1". Investigating further, I found out that this is the sound driver for the main audio output for my machine (the other output driver is for the HDMI). I have noticed from the beginning (right after a fresh install) that whenever I use the function key on my keyboard to mute/unmute it takes longer than it should to register the change. There is also a noticeable 15-20% spike in CPU usage during this delay. Interestingly, changing the volume up and down with the Fn keys works normally. I've tried switching kernels to 5.2.21-1 and 4.19.81-1 but the problem persists. I've tried combing the forums here as well as google but I am unable to find a post with a similar problem to mine, but I apologize anyway if this has already been resolved. I should also mention, sometimes when I start up the machine there is no problems at all, that is, no disabling IRQ #36 message, normal CPU usage, and normal snappy FN key response to muting/unmuting. This is the part that's driving me crazy, I can't figure out why it sometimes work and it sometimes doesn't! Let me know if you need additional information.

Thanks in advance for any tips/assistance!

First off, Welcome to the forum. In order for people to help you, you will need to provide more information. Take a look at this post and add the required information.

Hi linesma!

Thanks for the welcome and pointing out the etiquette. Here's some hopefully helpful info:

inxi -Fxxxza --no-host output:

System:    Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 
           root=UUID=3eab464c-db72-4fe8-830c-edac8ee64769 rw quiet acpi_backlight=native apparmor=1 
           security=apparmor resume=UUID=94f265b8-7abf-4c37-b443-12bcd20258f1 udev.log_priority=3 
           Desktop: Xfce 4.14.1 tk: Gtk 3.24.12 info: xfce4-panel, plank wm: xfwm4 dm: LightDM 1.30.0 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Laptop 14-bw0xx v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: HP model: 8324 v: 22.26 serial: <filter> UEFI: AMI v: F.26 date: 07/23/2018 
Battery:   ID-1: BAT0 charge: 20.3 Wh condition: 30.1/30.1 Wh (100%) volts: 11.1/10.9 model: HP Primary 
           type: Li-ion serial: <filter> status: Discharging cycles: 271 
CPU:       Topology: Dual Core model: AMD E2-9000e RADEON R2 4 COMPUTE CORES 2C+2G bits: 64 type: MCP 
           arch: Excavator family: 15 (21) model-id: 70 (112) stepping: N/A microcode: 6006705 
           L2 cache: 1024 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 5990 
           Speed: 1331 MHz min/max: 1100/1500 MHz boost: enabled Core speeds (MHz): 1: 1760 2: 1842 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
Graphics:  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard driver: amdgpu 
           v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
           Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting 
           alternate: fbdev,vesa resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD STONEY (DRM 3.33.0 5.3.8-3-MANJARO LLVM 9.0.0) v: 4.5 Mesa 19.2.2 
           direct render: Yes 
Audio:     Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:01.1 
           chip ID: 1002:15b3 
           Device-2: AMD Family 15h Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:09.2 chip ID: 1022:157a 
           Sound Server: ALSA v: k5.3.8-3-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard 
           driver: r8169 v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
           Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel 
           port: e000 bus ID: 03:00.0 chip ID: 8086:24fb 
           IF: wlo1 state: up mac: <filter> 
Drives:    Local Storage: total: 447.13 GiB used: 43.25 GiB (9.7%) 
           ID-1: /dev/sda vendor: Team model: T253X1480G size: 447.13 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: BB.3 scheme: GPT 
Partition: ID-1: / raw size: 438.03 GiB size: 430.16 GiB (98.20%) used: 43.25 GiB (10.1%) fs: ext4 
           dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 10 (default 60) 
           cache pressure: 100 (default) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 34 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 215 Uptime: 2h 47m Memory: 7.31 GiB used: 1.55 GiB (21.2%) Init: systemd v: 242 
           Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 running in: xfce4-terminal inxi: 3.0.36 

The output for dmesg was immense, so I decided to put it on pastebin so there isn't a huge wall of text here:

Here's the output for journalctl:

-- Logs begin at Sat 2019-11-02 21:17:39 EDT, end at Sat 2019-11-09 11:47:17 EST. --
Nov 02 21:17:39 Vaquero kernel: Linux version 5.3.7-2-MANJARO (builduser@lancaster) (gcc version 9.2.0 (GC>
Nov 02 21:17:39 Vaquero kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=3eab464c-db72->
Nov 02 21:17:39 Vaquero kernel: KERNEL supported cpus:
Nov 02 21:17:39 Vaquero kernel:   Intel GenuineIntel
Nov 02 21:17:39 Vaquero kernel:   AMD AuthenticAMD
Nov 02 21:17:39 Vaquero kernel:   Hygon HygonGenuine
Nov 02 21:17:39 Vaquero kernel:   Centaur CentaurHauls
Nov 02 21:17:39 Vaquero kernel:   zhaoxin   Shanghai  
Nov 02 21:17:39 Vaquero kernel: x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
Nov 02 21:17:39 Vaquero kernel: x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
Nov 02 21:17:39 Vaquero kernel: x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
Nov 02 21:17:39 Vaquero kernel: x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
Nov 02 21:17:39 Vaquero kernel: x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'st>
Nov 02 21:17:39 Vaquero kernel: BIOS-provided physical RAM map:
Nov 02 21:17:39 Vaquero kernel: BIOS-e820: [mem 0x0000000000000000-0x000000000009ffff] usable
Nov 02 21:17:39 Vaquero kernel: BIOS-e820: [mem 0x00000000000a0000-0x00000000000fffff] reserved
lines 1-17

Let me know if there's any thing else I can provide!

Thanks so much

Hello everybody,

It seems like my issue disappeared after updating to today's stable update: [Stable Update] 2019-11-14 - Kernels, Plasma, KDE Apps, KDE Frameworks, Mesa, Nvidia. I wish I knew exactly what fixed it, but I'd be willing to wager it was an issue with the kernel (since that was updated to 5.3.11). Thanks to everybody who tried to help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by