Slow wifi, multiple fixes and reinstalls tried

I have a 2011 13 inch mac book pro. It was running Ubuntu 16.04 and I recently upgraded it to 18.04. This broke the internet and a bunch of other things. I reinstalled 16.04 but the internet over wifi was still slow.

I decided to take this opportunity to install Manjaro, something I had been very excited to try.

On my other laptop, a 2014 BMP I get internet speeds over 15mbps but on my Manjaro machine, I don't get over 2mbps.

My connection is very slow for both browsing the web on Vivaldi, Chromium and FireFox as well as when using pacman/yaourt. I presume this has something to do with my wifi driver because when I use my phone to connect I get fast speeds. (Unfortunately, I don't have an ethernet cable to try.)

I've tried countless solutions that I found here and on arch wikis but I'm still a bit of a noob so I can't say that these were the correct approaches. Regardless, these attempts did not help my speeds.

Does anyone have any hints on how I should attack this problem or even what would be the best diagnostics to run?

Paste the output of inxi -Fxxxz so we can see exactly what hardware you have.

Also have a read of

Thanks a lot. My appologies for not reading the good info post.

here ithe output of inxi -Fxxxz:

System:    Host: kai-MJ Kernel: 4.14.39-1-MANJARO x86_64 bits: 64 compiler: gcc v: 7.3.1 Desktop: Gnome 3.28.2 
           info: gnome-shell dm: gdm Distro: Manjaro Linux 17.1.10 Hakoila 
Machine:   Type: Laptop System: Apple product: MacBookPro10,2 v: 1.0 serial: N/A Chassis: type: 10 
           v: Mac-AFD8A9D944EA4843 serial: N/A 
           Mobo: Apple model: Mac-AFD8A9D944EA4843 v: MacBookPro10,2 serial: N/A UEFI: Apple 
           v: MBP102.88Z.0106.B12.1702171357 date: 02/17/2017 
Battery:   ID-1: BAT0 charge: 66.6 Wh condition: 66.7/73.9 Wh (90%) volts: 12.4/11.2 model: SMP bq20z451 
           type: Li-ion serial: N/A status: Full cycles: 617 
CPU:       Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19961 
           Speed: 1197 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1198 3: 1196 4: 1197 
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0166 
           Display: x11 server: X.Org 1.19.6 driver: i915 compositor: gnome-shell resolution: 2560x1600~60Hz 
           OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.0.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Card-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:1e20 
           Sound Server: ALSA v: k4.14.39-1-MANJARO 
Network:   Card-1: Broadcom Limited NetXtreme BCM57786 Gigabit Ethernet PCIe driver: N/A port: N/A 
           bus ID: 02:00.0 chip ID: 14e4:16a3 
           Card-2: Broadcom Limited BCM4331 802.11a/b/g/n driver: bcma-pci-bridge v: N/A bus ID: 03:00.0 
           chip ID: 14e4:4331 
           IF-ID-1: wlp3s0b1 state: up mac: <filter> 
Drives:    HDD Total Size: 233.76 GiB used: 26.95 GiB (11.5%) 
           ID-1: /dev/sda vendor: ^APPLE model: APPLE SSD SM256E size: 233.76 GiB serial: <filter> rev: 9A1Q 
           scheme: GPT 
Partition: ID-1: / size: 220.13 GiB used: 26.95 GiB (12.2%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 256 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 62.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 192 Uptime: 2h 14m Memory: 7.67 GiB used: 2.35 GiB (30.6%) Init: systemd v: 238 
           Compilers: gcc: 8.1.0 Shell: bash v: 4.4.19 running in: terminator inxi: 3.0.08 

Oh, this thing again... :roll_eyes:

Also, update. :wink:

Will do as soon as I get my network working again.

I created the blacklist.conf file. How can I check which driver version I have to remove? I have tried to delete all of the listed ones but I got error: target not found: b43 or another driver.

Further, after blacklisting those options, I have no internet. How can I use pacman to download new drivers without this?

Also, thanks, this level of support is amazing!!!!

run the update, even with a slow connection. It could already fix ur problem. Stable LTS Kernel is now 4.14.44

Found this on the Arch wiki page for Broadcom:

BCM4331 noticed to have problems with b43-firmware-classic. Use b43-firmwareAUR for this card instead.

I believe the b43 firmware is also included in the manjaro-firmware package. Is that installed?

after I created and populated the blacklist.conf file I no longer have any internet connection at all. When I go into settings I have "No Wi-Fi Adapter Found".

I presume I could remove the blacklist but that would put me back to square one.

Update: after removing the blacklist.conf file I again have an internet connection but it is just as slow.

Am I correct in assuming that adding the blacklist shouldn't distrust my wifi?

I'm pretty sure we can get this working for you. Unfortunately, not having a working ethernet connection is a little limiting. We need to know what you have already attempted aside from the blacklisting. Did you attempt to install other drivers or firmware/headers.

We need to know which modules you currently have loaded. Could you please post the results of the command:

less /proc/modules

Worst case scinario I can connect with my phone instead of ethernet.

Would it be better for me to reinstate the blacklist.conf and install new packages from my phones connection?

I believe this approach would also require me to know which packages to delete which I currently cant find.

I was able to download

$ sudo pacman -S linux414-headers
$ sudo pacman -S broadcom-wl-dkms

the output of less /proc/modules is:

fuse 118784 3 - Live 0xffffffffc1417000
cmac 16384 1 - Live 0xffffffffc08ea000
rfcomm 86016 16 - Live 0xffffffffc0927000
bnep 24576 2 - Live 0xffffffffc0911000
snd_hda_codec_hdmi 57344 1 - Live 0xffffffffc0918000
snd_hda_codec_cirrus 24576 1 - Live 0xffffffffc090a000
snd_hda_codec_generic 86016 1 snd_hda_codec_cirrus, Live 0xffffffffc0959000
btusb 53248 0 - Live 0xffffffffc130f000
btrtl 16384 1 btusb, Live 0xffffffffc08f4000
btbcm 16384 1 btusb, Live 0xffffffffc0905000
btintel 16384 1 btusb, Live 0xffffffffc08ef000
bluetooth 630784 41 rfcomm,bnep,btusb,btrtl,btbcm,btintel, Live 0xffffffffc1364000
ecdh_generic 24576 1 bluetooth, Live 0xffffffffc08fe000
hid_generic 16384 0 - Live 0xffffffffc08d2000
input_leds 16384 0 - Live 0xffffffffc08e0000
intel_rapl 24576 0 - Live 0xffffffffc1308000
x86_pkg_temp_thermal 16384 0 - Live 0xffffffffc08e5000
intel_powerclamp 16384 0 - Live 0xffffffffc08f9000
coretemp 16384 0 - Live 0xffffffffc08db000
mousedev 24576 0 - Live 0xffffffffc1410000
hid_apple 16384 0 - Live 0xffffffffc097d000
kvm_intel 225280 0 - Live 0xffffffffc132c000
joydev 24576 0 - Live 0xffffffffc1325000
usbhid 57344 0 - Live 0xffffffffc0984000
bcm5974 20480 0 - Live 0xffffffffc0795000
hid 131072 3 hid_generic,hid_apple,usbhid, Live 0xffffffffc16d7000
kvm 708608 1 kvm_intel, Live 0xffffffffc1253000
iTCO_wdt 16384 0 - Live 0xffffffffc0827000
iTCO_vendor_support 16384 1 iTCO_wdt, Live 0xffffffffc08c1000
nls_iso8859_1 16384 1 - Live 0xffffffffc08c7000
i915 1937408 16 - Live 0xffffffffc0a4e000
nls_cp437 20480 1 - Live 0xffffffffc08cc000
mac_hid 16384 0 - Live 0xffffffffc08a7000
evdev 20480 13 - Live 0xffffffffc081a000
vfat 20480 1 - Live 0xffffffffc0810000
fat 81920 1 vfat, Live 0xffffffffc08ac000
irqbypass 16384 1 kvm, Live 0xffffffffc080b000
crct10dif_pclmul 16384 0 - Live 0xffffffffc0806000
crc32_pclmul 16384 0 - Live 0xffffffffc0822000
ghash_clmulni_intel 16384 0 - Live 0xffffffffc0737000
cfg80211 733184 0 - Live 0xffffffffc099a000
pcbc 16384 0 - Live 0xffffffffc06ce000
i2c_algo_bit 16384 1 i915, Live 0xffffffffc0732000
aesni_intel 188416 2 - Live 0xffffffffc0878000
drm_kms_helper 196608 1 i915, Live 0xffffffffc0847000
aes_x86_64 20480 1 aesni_intel, Live 0xffffffffc0838000
crypto_simd 16384 1 aesni_intel, Live 0xffffffffc0833000
glue_helper 16384 1 aesni_intel, Live 0xffffffffc074b000
applesmc 24576 0 - Live 0xffffffffc082c000
cryptd 28672 3 ghash_clmulni_intel,aesni_intel,crypto_simd, Live 0xffffffffc078d000
input_polldev 16384 1 applesmc, Live 0xffffffffc06b7000
snd_hda_intel 45056 3 - Live 0xffffffffc06ab000
intel_cstate 16384 0 - Live 0xffffffffc0842000
intel_rapl_perf 16384 0 - Live 0xffffffffc066e000
drm 434176 6 i915,drm_kms_helper, Live 0xffffffffc079b000
snd_hda_codec 151552 4 snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_codec_generic,snd_hda_intel, Live 0xffffffffc0767000
pcspkr 16384 0 - Live 0xffffffffc0626000
snd_hda_core 90112 5 snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec, Live 0xffffffffc0750000
mei_me 45056 0 - Live 0xffffffffc073f000
snd_hwdep 16384 1 snd_hda_codec, Live 0xffffffffc0687000
thunderbolt 98304 0 - Live 0xffffffffc0719000
intel_gtt 24576 1 i915, Live 0xffffffffc06f2000
rfkill 28672 6 bluetooth,cfg80211, Live 0xffffffffc0666000
agpgart 49152 2 drm,intel_gtt, Live 0xffffffffc06c1000
snd_pcm 118784 4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core, Live 0xffffffffc06fb000
snd_timer 36864 1 snd_pcm, Live 0xffffffffc06a1000
syscopyarea 16384 1 drm_kms_helper, Live 0xffffffffc0697000
sysfillrect 16384 1 drm_kms_helper, Live 0xffffffffc069c000
sysimgblt 16384 1 drm_kms_helper, Live 0xffffffffc05d5000
snd 90112 14 snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_codec_generic,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer, Live 0xffffffffc062c000
fb_sys_fops 16384 1 drm_kms_helper, Live 0xffffffffc05d0000
mei 114688 1 mei_me, Live 0xffffffffc06d5000
soundcore 16384 1 snd, Live 0xffffffffc06bc000
shpchp 40960 0 - Live 0xffffffffc068c000
i2c_i801 28672 0 - Live 0xffffffffc067f000
lpc_ich 28672 0 - Live 0xffffffffc0677000
uvcvideo 102400 0 - Live 0xffffffffc060c000
acpi_als 16384 0 - Live 0xffffffffc05cb000
sbs 20480 0 - Live 0xffffffffc05c5000
kfifo_buf 16384 1 acpi_als, Live 0xffffffffc0589000
industrialio 81920 2 acpi_als,kfifo_buf, Live 0xffffffffc0651000
apple_gmux 16384 0 - Live 0xffffffffc0648000
videobuf2_vmalloc 16384 1 uvcvideo, Live 0xffffffffc0442000
sbshc 16384 1 sbs, Live 0xffffffffc0643000
videobuf2_memops 16384 1 videobuf2_vmalloc, Live 0xffffffffc0584000
apple_bl 16384 1 apple_gmux, Live 0xffffffffc0607000
video 45056 2 i915,apple_gmux, Live 0xffffffffc05fb000
videobuf2_v4l2 28672 1 uvcvideo, Live 0xffffffffc05f3000
ac 16384 0 - Live 0xffffffffc03fd000
videobuf2_core 45056 2 uvcvideo,videobuf2_v4l2, Live 0xffffffffc05dd000
button 16384 1 i915, Live 0xffffffffc05ea000
videodev 204800 3 uvcvideo,videobuf2_v4l2,videobuf2_core, Live 0xffffffffc0592000
media 45056 2 uvcvideo,videodev, Live 0xffffffffc0578000
sch_fq_codel 20480 1 - Live 0xffffffffc0572000
uinput 20480 0 - Live 0xffffffffc056c000
sg 40960 0 - Live 0xffffffffc0437000
crypto_user 16384 0 - Live 0xffffffffc03c3000
ip_tables 28672 0 - Live 0xffffffffc03f5000
x_tables 45056 1 ip_tables, Live 0xffffffffc031c000
ext4 716800 1 - Live 0xffffffffc04bc000
crc32c_generic 16384 0 - Live 0xffffffffc03b4000
crc16 16384 2 bluetooth,ext4, Live 0xffffffffc0359000
mbcache 16384 1 ext4, Live 0xffffffffc02b4000
jbd2 118784 1 ext4, Live 0xffffffffc0462000
fscrypto 32768 1 ext4, Live 0xffffffffc030c000
sd_mod 61440 4 - Live 0xffffffffc03a4000
ahci 40960 3 - Live 0xffffffffc033d000
libahci 40960 1 ahci, Live 0xffffffffc0301000
xhci_pci 16384 0 - Live 0xffffffffc02af000
ehci_pci 16384 0 - Live 0xffffffffc0334000
sdhci_pci 36864 0 - Live 0xffffffffc03b9000
libata 278528 2 ahci,libahci, Live 0xffffffffc035f000
sdhci 57344 1 sdhci_pci, Live 0xffffffffc034a000
led_class 16384 3 input_leds,applesmc,sdhci, Live 0xffffffffc032b000
crc32c_intel 24576 2 - Live 0xffffffffc0315000
xhci_hcd 241664 1 xhci_pci, Live 0xffffffffc0480000
ehci_hcd 94208 1 ehci_pci, Live 0xffffffffc044a000
scsi_mod 212992 3 sg,sd_mod,libata, Live 0xffffffffc0402000
mmc_core 167936 2 sdhci_pci,sdhci, Live 0xffffffffc03cb000
usbcore 286720 8 btusb,usbhid,bcm5974,uvcvideo,xhci_pci,ehci_pci,xhci_hcd,ehci_hcd, Live 0xffffffffc02ba000
usb_common 16384 1 usbcore, Live 0xffffffffc02aa000

sorry for the long printout.

Ok do me a favor please do not install those packages yet.

Gotcha will remove.

You don't need to do anything yet. Please just wait for instructions.

Did you install the dkms drivers and headers?. Are they currently installed. Do not remove them if they are just let me know what you have done since you posted your modules output.

I have just removed them. I'm sure I can reinstall and repost my modules output if that would help

Let's see what u got:

cat /lib/modules/$(uname -r)/modules.dep | grep wireless | grep broadcom

Then grep your wifi module with lsmod. Unload it with modprobe -v -r and try to get the b43 loaded with modprobe -v b43

$ cat /lib/modules/$(uname -r)/modules.dep | grep wireless | grep broadcom
kernel/drivers/net/wireless/broadcom/b43/b43.ko.xz: kernel/drivers/bcma/bcma.ko.xz kernel/net/mac80211/mac80211.ko.xz kernel/net/wireless/cfg80211.ko.xz kernel/drivers/ssb/ssb.ko.xz kernel/drivers/mmc/core/mmc_core.ko.xz kernel/net/rfkill/rfkill.ko.xz kernel/drivers/leds/led-class.ko.xz kernel/drivers/char/hw_random/rng-core.ko.xz kernel/drivers/pcmcia/pcmcia.ko.xz kernel/drivers/pcmcia/pcmcia_core.ko.xz
kernel/drivers/net/wireless/broadcom/b43legacy/b43legacy.ko.xz: kernel/net/mac80211/mac80211.ko.xz kernel/net/wireless/cfg80211.ko.xz kernel/drivers/ssb/ssb.ko.xz kernel/drivers/mmc/core/mmc_core.ko.xz kernel/net/rfkill/rfkill.ko.xz kernel/drivers/leds/led-class.ko.xz kernel/drivers/char/hw_random/rng-core.ko.xz kernel/drivers/pcmcia/pcmcia.ko.xz kernel/drivers/pcmcia/pcmcia_core.ko.xz
kernel/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko.xz: kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko.xz kernel/net/wireless/cfg80211.ko.xz kernel/drivers/mmc/core/mmc_core.ko.xz kernel/net/rfkill/rfkill.ko.xz kernel/drivers/usb/core/usbcore.ko.xz kernel/drivers/usb/common/usb-common.ko.xz
kernel/drivers/net/wireless/broadcom/brcm80211/brcmsmac/brcmsmac.ko.xz: kernel/lib/cordic.ko.xz kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko.xz kernel/drivers/bcma/bcma.ko.xz kernel/net/mac80211/mac80211.ko.xz kernel/net/wireless/cfg80211.ko.xz kernel/net/rfkill/rfkill.ko.xz kernel/drivers/leds/led-class.ko.xz

issue an

lsmod | grep <any of the module names before .ko>

You want to try all of them if nothing is returned. Without the path of course

The wl drivers should work for this card.

This is what I would do:

If the file /etc/modprobe.d/blacklist.conf does not exist create it:

Blacklist the following modules.

If the file /etc/modprobe.d/blacklist.conf does not exist create it:
With a text editor create the file /etc/modprobe.d/blacklist.conf with the contents:

blacklist b43
blacklist b43legacy
blacklist ssb
blacklist brcmsmac
blacklist bcma
blacklist brcm80211

Next, install the linux headers package:

sudo pacman -S linuxXXX-headers

Where "XXX" is your kernel version.


sudo pacman -S linux414-headers

Once the linux headers package installation is complete:


Install the broadcom-wl-dkms drivers from the Manjaro extra repository.

sudo pacman -S broadcom-wl-dkms


Forum kindly sponsored by